Вход | Регистрация

1С:Предприятие ::

Метки:запросы, Запросы и построители

Ошибка Кратность 633

Я
   Максвер
 
06.07.04 - 12:54
Запрос выполняется но приходится соглашатся с ошибкой. Может кто подскажет в чем загвоздка.
Функция ТекстЗапроса()
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)

    |Период с ДатаНачала по ДатаКонца;
    |Фирма            = Регистр.ПартииНаличие.Фирма,
    |                  Регистр.ПартииОтданные.Фирма;
    |УпрАналитика    = Регистр.ПартииНаличие.Фирма.УпрАналитика,
    |                  Регистр.ПартииОтданные.Фирма.УпрАналитика;
    |ЮрЛицо         = Регистр.ПартииНаличие.Фирма.ЮрЛицо,
    |                  Регистр.ПартииОтданные.Фирма.ЮрЛицо;
    |СтатусПартии     = Регистр.ПартииНаличие.СтатусПартии,
    |                  Регистр.ПартииОтданные.СтатусПартии;
    |Номенклатура    = Регистр.ПартииНаличие.Номенклатура,
    |                  Регистр.ПартииОтданные.Номенклатура;
    |Размер         = Регистр.ПартииНаличие.Размер,
    |                  Регистр.ПартииОтданные.Размер;
    |Цвет           = Регистр.ПартииНаличие.Размер,
    |                  Регистр.ПартииОтданные.Размер;
    |МОЛ_Комиссионер= Регистр.ПартииНаличие.МОЛ,
    |                  Регистр.ПартииОтданные.Договор.Владелец;
    |Покупатель        = Регистр.ПартииНаличие.ТекущийДокумент.Реализация.Контрагент,
    |                  Регистр.ПартииНаличие.ТекущийДокумент.РеализацияРозница.Контрагент,
    |                  Регистр.ПартииНаличие.ТекущийДокумент.ОтчетККМ.Контрагент,
    |                  Регистр.ПартииНаличие.ТекущийДокумент.РеализацияПрочее.Контрагент,
    |                  Регистр.ПартииНаличие.ТекущийДокумент.ВозвратОтПокупателя.Контрагент,
    |                  Регистр.ПартииОтданные.ТекущийДокумент.ОтчетКомиссионера.Контрагент;
    |Поставка        = Регистр.ПартииНаличие.Партия,
    |                  Регистр.ПартииОтданные.Партия;
    |СвойствоПартии    = Регистр.ПартииНаличие.Партия.Свойство,
    |                  Регистр.ПартииОтданные.Партия.Свойство;
    |Поставщик        = Регистр.ПартииНаличие.Партия.Поставщик,
    |                  Регистр.ПартииОтданные.Партия.Поставщик;
    |ДокПоставки    = Регистр.ПартииНаличие.Партия.ПриходныйДокумент,
    |                  Регистр.ПартииОтданные.Партия.ПриходныйДокумент;
    |КодОперации    = Регистр.ПартииНаличие.КодОперации,
    |                  Регистр.ПартииОтданные.КодОперации;
    |НомерСтроки    = Регистр.ПартииНаличие.НомерСтроки,
    |                  Регистр.ПартииОтданные.НомерСтроки;
    |Договор        = Регистр.ПартииОтданные.Договор;
    |ВалВзаим        = Регистр.ПартииОтданные.Договор.ВалютаВзаиморасчетов;
    |Док            = Регистр.ПартииНаличие.ТекущийДокумент,
    |                  Регистр.ПартииОтданные.ТекущийДокумент;
    |Сумма1            = Регистр.ПартииНаличие.СуммаРуб,
    |                  Регистр.ПартииОтданные.СуммаРуб;
    |Сумма2            = Регистр.ПартииНаличие.СуммаБезНДС,
    |                  Регистр.ПартииОтданные.СуммаБезНДС;
    |Сумма3            = Регистр.ПартииНаличие.СуммаУпр,       
    |                  Регистр.ПартииОтданные.СуммаУпр;       
    |Оборот            = Регистр.ПартииНаличие.ПродСтоимость;
    |ОборотКом        = Регистр.ПартииОтданные.ПродСтоимость;";
    ТекстЗапроса = ТекстЗапроса + "Количество = Регистр.ПартииНаличие.Количество, Регистр.ПартииОтданные.Количество;";
    Если ВидСуммы = 1 Тогда// бух с НДС

        ТекстЗапроса = ТекстЗапроса + "Сумма = Регистр.ПартииНаличие.СуммаРуб, Регистр.ПартииОтданные.СуммаРуб;";
    ИначеЕсли ВидСуммы = 2 Тогда// бух без НДС

        ТекстЗапроса = ТекстЗапроса + "Сумма = Регистр.ПартииНаличие.СуммаУпр, Регистр.ПартииОтданные.СуммаУпр;";
    КонецЕсли;
    ТекстЗапроса = ТекстЗапроса +
    "Функция ПриходС = Приход(Сумма);
    |Функция РасходС = Расход(Сумма);
    |Функция ПриходК = Приход(Количество);
    |Функция РасходК = Расход(Количество);
    |Функция ВозвратК = Приход(Количество)Когда(КодОперации в КодыВозвратов);
    |Функция ВозвратС = Приход(Сумма)Когда(КодОперации в КодыВозвратов);
    |Функция РасходБезНДС = Расход(Сумма2);
    |Функция РасходСНДС = Расход(Сумма1);
    |Функция ВозвратБезНДС = Приход(Сумма2)Когда(КодОперации в КодыВозвратов);
    |Функция ВозвратСНДС = Приход(Сумма1)Когда(КодОперации в КодыВозвратов);
    |Функция ОборотСумма = Сумма(Оборот)Когда(КодОперации в КодыОборота);
    |Функция ОборотУпр = Сумма(ПересчетВалюты(Оборот, Док))Когда(КодОперации в КодыОборота);
    |Функция ОборотКомРасход = Сумма(ПересчетВалюты(ОборотКом, Док, ВалВзаим, глРубли))Когда(КодОперации = глКО.ОтчетРеализатора);
    |Функция ОборотКомРасходУпр = Сумма(ПересчетВалюты(ОборотКом, Док, ВалВзаим, глДоллары))Когда(КодОперации = глКО.ОтчетРеализатора);
    |Функция ОборотВ = Сумма(Оборот)Когда(КодОперации в КодыВозвратов);
    |Функция ОборотУпрВ = Сумма(ПересчетВалюты(Оборот, Док))Когда(КодОперации в КодыВозвратов);
    |Условие (НЕ(КодОперации в КодыПеремещений));";       
    Возврат ТекстЗапроса;
КонецФункции
//

Функция ТекстЗапросаПоОтчетам()
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)

    |Период с ДатаНачала по ДатаКонца;
    |Фирма            = Регистр.ПартииНаличие.Фирма,
    |                  Регистр.ПартииОтданные.Фирма,
    |                  Регистр.РеализованныйТовар.Фирма;
    |УпрАналитика    = Регистр.ПартииНаличие.Фирма.УпрАналитика,
    |                  Регистр.ПартииОтданные.Фирма.УпрАналитика,
    |                  Регистр.РеализованныйТовар.Фирма.УпрАналитика;
    |ЮрЛицо         = Регистр.ПартииНаличие.Фирма.ЮрЛицо,
    |                  Регистр.ПартииОтданные.Фирма.ЮрЛицо,
    |                  Регистр.РеализованныйТовар.Фирма.ЮрЛицо;
    |СтатусПартии     = Регистр.ПартииНаличие.СтатусПартии,
    |                  Регистр.ПартииОтданные.СтатусПартии;
    |Номенклатура    = Регистр.ПартииНаличие.Номенклатура,
    |                  Регистр.ПартииОтданные.Номенклатура,
    |                  Регистр.РеализованныйТовар.Номенклатура;
    |МОЛ_Комиссионер= Регистр.ПартииНаличие.МОЛ,
    |                  Регистр.ПартииОтданные.Договор.Владелец;
    |Покупатель        = Регистр.ПартииНаличие.ТекущийДокумент.Реализация.Контрагент,
    |                  Регистр.ПартииНаличие.ТекущийДокумент.РеализацияРозница.Контрагент,
    |                  Регистр.ПартииНаличие.ТекущийДокумент.ОтчетККМ.Контрагент,
    |                  Регистр.ПартииНаличие.ТекущийДокумент.РеализацияПрочее.Контрагент,
    |                  Регистр.ПартииНаличие.ТекущийДокумент.ВозвратОтПокупателя.Контрагент,
    |                  Регистр.ПартииОтданные.ТекущийДокумент.ОтчетКомиссионера.Контрагент;
    |Поставка        = Регистр.ПартииНаличие.Партия,
    |                  Регистр.ПартииОтданные.Партия,
    |                  Регистр.РеализованныйТовар.Партия;   
    |СвойствоПартии    = Регистр.ПартииНаличие.Партия.Свойство,
    |                  Регистр.ПартииОтданные.Партия.Свойство;
    |Поставщик        = Регистр.ПартииНаличие.Партия.Поставщик,
    |                  Регистр.ПартииОтданные.Партия.Поставщик,
    |                  Регистр.РеализованныйТовар.Партия.Поставщик;
    |ДокПоставки    = Регистр.ПартииНаличие.Партия.ПриходныйДокумент,
    |                  Регистр.ПартииОтданные.Партия.ПриходныйДокумент,
    |                  Регистр.РеализованныйТовар.Партия.ПриходныйДокумент;
    |КодОперации    = Регистр.ПартииНаличие.КодОперации,
    |                  Регистр.ПартииОтданные.КодОперации;
    |НомерСтроки    = Регистр.ПартииНаличие.НомерСтроки,
    |                  Регистр.ПартииОтданные.НомерСтроки;
    |Договор        = Регистр.ПартииОтданные.Договор;
    |ВалВзаим        = Регистр.ПартииОтданные.Договор.ВалютаВзаиморасчетов;
    |Док            = Регистр.ПартииНаличие.ТекущийДокумент,
    |                  Регистр.ПартииОтданные.ТекущийДокумент,
    |                  Регистр.РеализованныйТовар.ДокПродажи;
    |Вознаграждение = Регистр.РеализованныйТовар.Вознаграждение;
    |КолОтч             = Регистр.РеализованныйТовар.Количество;
    |СтоимостьОтч     = Регистр.РеализованныйТовар.ПродСтоимость;
    |ОтчетКомитенту = Регистр.РеализованныйТовар.ТекущийДокумент;
    |Сумма1            = Регистр.ПартииНаличие.СуммаРуб,
    |                  Регистр.ПартииОтданные.СуммаРуб;
    |Сумма2            = Регистр.ПартииНаличие.СуммаБезНДС,
    |                  Регистр.ПартииОтданные.СуммаБезНДС;
    |Сумма3            = Регистр.ПартииНаличие.СуммаУпр,       
    |                  Регистр.ПартииОтданные.СуммаУпр;       
    |Оборот            = Регистр.ПартииНаличие.ПродСтоимость;
    |ОборотКом        = Регистр.ПартииОтданные.ПродСтоимость; 
    |Количество     = Регистр.ПартииНаличие.Количество, 
    |                  Регистр.ПартииОтданные.Количество;
    |Сумма             = Регистр.ПартииНаличие.СуммаРуб, 
    |                  Регистр.ПартииОтданные.СуммаРуб;
    |Функция ПриходС = Приход(Сумма);
    |Функция РасходС = Расход(Сумма)Когда(СтатусПартии <> глСП.Т_Принятый);
    |Функция ПриходК = Приход(Количество);
    |Функция РасходК = Расход(Количество)Когда(СтатусПартии <> глСП.Т_Принятый);
    |Функция РасходКВсего = Расход(Количество);
    |Функция РасходП = Расход(Количество)Когда(СтатусПартии = глСП.Т_Принятый);
    |Функция ВозвратК = Приход(Количество)Когда(КодОперации в КодыВозвратов);
    |Функция ВозвратС = Приход(Сумма)Когда(КодОперации в КодыВозвратов);
    |Функция РасходБезНДС = Расход(Сумма2)Когда((Не(КодОперации в КодыПеремещений)) и (СтатусПартии <> глСП.Т_Принятый));
    |Функция РасходСНДС = Расход(Сумма1)Когда(СтатусПартии <> глСП.Т_Принятый);
    |Функция ВозвратБезНДС = Приход(Сумма2)Когда(КодОперации в КодыВозвратов);
    |Функция ВозвратСНДС = Приход(Сумма1)Когда(КодОперации в КодыВозвратов);
    |Функция ОборотСумма = Сумма(Оборот)Когда((КодОперации в КодыОборота) и (СтатусПартии <> глСП.Т_Принятый));
    |Функция ОборотУпр = Сумма(ПересчетВалюты(Оборот, Док))Когда((КодОперации в КодыОборота) и (СтатусПартии <> глСП.Т_Принятый));
    |Функция ОборотКомРасход = Сумма(ПересчетВалюты(ОборотКом, Док, ВалВзаим, глРубли))Когда((КодОперации = глКО.ОтчетРеализатора) и (СтатусПартии <> глСП.Т_Принятый));
    |Функция ОборотКомРасходУпр = Сумма(ПересчетВалюты(ОборотКом, Док, ВалВзаим, глДоллары))Когда(КодОперации = глКО.ОтчетРеализатора);
    |Функция ОборотВ = Сумма(Оборот)Когда((КодОперации в КодыВозвратов) и (СтатусПартии <> глСП.Т_Принятый));
    |Функция ОборотУпрВ = Сумма(ПересчетВалюты(Оборот, Док))Когда(КодОперации в КодыВозвратов);
    |Функция КолОтчитались = Расход(КолОтч);
    |Функция ОборотОтчитались = Расход(СтоимостьОтч);
    |Функция КомВознаграждение = Сумма(Вознаграждение);
    |Условие (НЕ(КодОперации в КодыПеремещений));";       
    Возврат ТекстЗапроса;
КонецФункции
 
  Рекламное место пустует
   SnarkHunter
 
1 - 06.07.04 - 13:06
Думаешь кто-то будет ЭТО читать?
Лучше текст ошибки привел...
   lexa
 
2 - 06.07.04 - 13:11
см функцию ПересчетВалюты
   Максвер
 
3 - 06.07.04 - 14:13
Значение не представляет агрегатный объект кратность 633.
   lexa
 
4 - 06.07.04 - 14:33
а аргументы какого типа у функции, посмотри что ты в нее передаешь и что надо
   Максвер
5 - 06.07.04 - 15:03
Спасибо Lexa тебе большое


Список тем форума
Рекламное место пустует   Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует