Вход | Регистрация

1С:Предприятие ::

Метки:Обучение и сертификация

Вопрос по аттестационному заданию №3 (Торговля и Склад)

Я
   Nat
 
06.07.04 - 11:18
Процедура ОбработкаПроведения()
    СпецРег=СоздатьОбъект("Регистры");
    СпецРег.Актуальность(1);
гОст=СпецРег.ОстаткиСерий;
    Если ИтогиАктуальны()=0 Тогда  
        РегОст.ВременныйРасчет(1);
          СпецРег.РассчитатьРегистрыПо(ТекущийДокумент());
    КонецЕсли;
  
"Не могу рассчитать временные итоги после ТА!"
 
  Рекламное место пустует
   Nat
 
1 - 06.07.04 - 11:23
Ой, извините...
У меня проблема с актуальностью итогов, в следующем фрагменте метод РассчитатьРегистрыПо(ТекущийДокумент()) вызывает следующую ошибку:
"Не могу рассчитать временные итоги после ТА!"
Если кто-нибудь занимался этой задачей - подскажите, пожалуйста.
Заранее благодарна
Процедура ОбработкаПроведения() 
   СпецРег=СоздатьОбъект("Регистры"); 
   СпецРег.Актуальность(1); 
   РегОст=СпецРег.ОстаткиСерий; 
   Если ИтогиАктуальны()=0 Тогда   
       РегОст.ВременныйРасчет(1); 
       СпецРег.РассчитатьРегистрыПо(ТекущийДокумент()); 
   КонецЕсли; 
   ....
КонецПроцедуры
   DimG
 
2 - 06.07.04 - 11:30
не ходи пока на аттестацию.
   Nat
 
3 - 06.07.04 - 11:46
Спасибо, дельный совет.
Я учусь на этих примерах - а если ответить нечего, то лучше промолчать.
   BorisG
 
4 - 06.07.04 - 11:52
(3) если хочешь получить ответ, нужно набраться терпения и не делать замечаний отвечающим...
Кроме того...
"Не задавайте вопросы из домашних заданий... Эти вопросы заданы для работы вам, чтобы вы могли научиться на собственном опыте." (с) Эрик Раймонд
Как правильно задавать вопросы (Эрик Раймонд)
   Nat
 
5 - 06.07.04 - 11:54
Еще раз спасибо
   Shadal
 
6 - 06.07.04 - 12:27
У тебя документ последний либо после ТА попробуй рассчитать регистрыНА а не ПО
Мож чё и выйдет.
   Shadal
 
7 - 06.07.04 - 12:28
либо документ не записан а он новый
   Nat
 
8 - 06.07.04 - 12:34
(6) - РассчитатьРегистрыНА(ТекущийДокумент()) дает тот же результат
(7) - у меня действительно новый документ, но так и должно быть по заданию (если я правильно поняла): "необходимо реализовать режим допроведения документа ... с поддержкой в актуальном состоянии временного расчета регистра с учетом уже записанных при пробитии предыдущих чеков движений. "
   колодина
9 - 07.07.04 - 06:04
нужно сравнить ТА с документом который проводишь, ведь это может быть не новый документ? и в зависимости от того, в каком положении ТА, рассчитывать итоги. а если документ новый, то конечно на него рассчитывать регистры нельзя - ведь ТА еще не сдвинулась. поэксперементируй в отладчике и все станет понятно. достатоно один раз внимательно отследить изменения ТА.
   Nat
 
10 - 07.07.04 - 10:37
Спасибо !
разобралась...
 
 


Список тем форума
Рекламное место пустует  
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует