Вход | Регистрация

1С:Предприятие ::

Метки:документы

c4et-factura (укр 253)

Я
   Crystalizer
 
05.07.04 - 10:31
документ "счет" (фактура) при проведении изменяет данные по счетам или нет?
что вообще он делает при проведении, простите за ламеризм...?

Процедура ОбработкаПроведения()
    глКомментарий("Начало",2,Контекст);

    Если ПроверкаШапки() = 0 Тогда
        глНеПроводить(Контекст);
        Возврат;
    КонецЕсли;
    
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
        Если ПроверкаСтроки() = 0 Тогда
            глНеПроводить(Контекст);
            Возврат;
        КонецЕсли;
    КонецЦикла;
    глКомментарий("Окончание",2,Контекст);
КонецПроцедуры
 
 
   Gavrila
 
1 - 05.07.04 - 10:45
Скорее всего просто контроль на заполнение реквизитов, а движений он не делает
   Crystalizer
 
2 - 05.07.04 - 10:51
ясно

а скажи почему это не работает:

Процедура ОбработкаПроведения()
    глКомментарий("Начало",2,Контекст);

    Если ПроверкаШапки() = 0 Тогда
        глНеПроводить(Контекст);
        Возврат;
    КонецЕсли;
    
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
        Если ПроверкаСтроки() = 0 Тогда
            глНеПроводить(Контекст);
            Возврат;
        КонецЕсли;
        
        Операция.НоваяПроводка(); 
//////////////

// здесь такое выдает:
Операция.НоваяПроводка();
{Документ.Счет.Модуль Документа(52)}: Недопустимая операция
хотя в других документах видел делается по такой же схеме. да и генератор сам такое написал правда в другом документе

        Операция.Содержание = Примечание;
        Операция.Дебет.Счет = СчетПоКоду("РТ",        ПланыСчетов.Основной);
        Операция.Количество = кво;
        Операция.Дебет.Субконто(1, ВидыСубконто.Контрагенты, Контрагент);
        Операция.Дебет.Субконто(2, ВидыСубконто.ТМЦ, ТМЦ);
        
    КонецЦикла;
    
    Операция.СуммаОперации = Итог("Сумма");
    Операция.Записать();

    глКомментарий("Окончание",2,Контекст);
КонецПроцедуры
   Bekas
 
3 - 05.07.04 - 10:59
В свойствах документа "Счет" не установлен признак принадлежности к бух.учету
   Crystalizer
 
4 - 05.07.04 - 11:01
Bekas: большое спасибо!


Список тем форума
  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует