Вход | Регистрация

1С:Предприятие ::

Метки:формы

Внешний отчет, как закрыть форму при нажатии кнопки печать

Я
   Druid_A
 
02.07.04 - 14:46
Печатаю ценники через внешние обработки, подскажите,  как сделать чтобы при нажатии кнопки печать, форма из которой произведено нажатие автоматом закрылась, процедура работала как надо.
Для того чтобы после печати заново вызывать процедуру, а не попадать в старую форму
 
  Рекламное место пустует
   Crystalizer
 
1 - 02.07.04 - 14:54
можешь написать в конце процедуры что то типа "Закрыть();" или "Закрыть;"
не помню точно
такое есть во многих стандартных
посмотри хелп по "закрыть" если не получится
   SnarkHunter
 
2 - 02.07.04 - 14:56
Форма.Закрыть(0)
   Druid_A
 
3 - 02.07.04 - 15:21
Спасибо! Помогло!!!
___________________
Тогда встречный вопрос! Как перетащить список наминклатуры из приходной накладной во внешний отчет?
всякую ересь туда переносит, но не то что надо! Может есть где готовое решение?
   SnarkHunter
 
4 - 02.07.04 - 15:37
Может и есть... Вообще-то тривиальная задачка-то...
   gr13
 
5 - 02.07.04 - 15:37
много способов есть... например перебором строк...
или ВыгрузитьТабличнуюЧасть... книга 1 стр. 280 ЖКК...
   lexa
 
6 - 02.07.04 - 15:49
а какую ересь?
   Warlock
 
7 - 02.07.04 - 20:56
Если ДокПриходнаяНакладная - это нужный документ, то
ДокПриходнаяНакладная.ВыбратьСтроки();
Пока ДокПриходнаяНакладная.ПолучитьСтроку() = 1 Цикл
 //Обработка для ДокПриходнаяНакладная.Номенклатура

КонецЦикла;
   skunk
 
8 - 03.07.04 - 05:57
а ТиС посмотреть ломает
   Guk
 
9 - 03.07.04 - 07:19
(4) А какая не тривиальная?...
   Bekas
 
10 - 03.07.04 - 08:38
Про тривиальную ничего не скажу, не знаю. А вот триальная...
//*******************************************

// Внешняя обработка, которая сама себя удаляет при завершении работы.
// © Андрей Журавлёв, 2003 1c@dv-com.net

//*******************************************
Перем Путь,Имя;
//*******************************************

Процедура ПриЗакрытии()
ФС.УдалитьФайл(Путь+Имя);
КонецПроцедуры 
//*******************************************

РасположениеФайла(Путь,Имя);
 
  Рекламное место пустует
   mszsuz
 
11 - 03.07.04 - 11:03
Код в (10) можно оптимизировать, сэкономив при этом память и получить выигрыш в быстродействии:
ФС.УдалитьФайл(РасположениеФайла()); 
:)
   Druid_A
 
12 - 05.07.04 - 09:57
Дело в том что печать ценников работает у меня как внешний отчет! Который я прикручиваю регистрируя внешние печатные формы.
Работает все отлично можно печатать кучу разных видов ценников, но для этого приходится постоянно набивать из номенклатуры ассортимент. А хотелось бы как и при стандартной печати получать список во внешний отчет из приходной накладной. Перепробовал уже все, ничего не получается…. Что делать ума не приложу. В саму конфигурацию вмешиваться не хочется. Как быть?
   romix
 
13 - 05.07.04 - 10:48
Если совсем новичок (по вопросу видно, что изучаешь 1С пару дней или недель), тебе надо поучиться, чтобы людей не грузить, и самому голову не ломать над простейшими вещами. Рекомендую сайт www.firststeps.ru, раздел 1С.
   lexa
 
14 - 05.07.04 - 11:00
в ТиС в PrnForms printcen.ert посмотри как она устроена, а вообще при регистрации внешних печатных форм в обработку передается контекст формы, через него ты имеешь доступ к табличной части документа
Док = Форма.Параметр();
Док.ВыбратьСтроки();
Пока Док.ПолучитьСтроку() = 1 Цикл
...
КонецЦикла;
Тем самым получаешь доступ не только к сиску номенклатуры но и к количеству
   Druid_A
 
15 - 05.07.04 - 11:14
Да, я не профи.... и у нас в городе к сожалению нет людей способных помочь в таких вопросах! Именно по этой причине пришла идея занятся этим вопросом самостоятельно. Спасибо всем за помощь (тем кто не смотря на мою не образованность) все же помогал! Разберусь, уверен! Отдельное спасибо "Lexe" :)
Да опыта не хватает, но на сколько я понимаю именно для этого и существуют форумы! Тему можно закрыть, просто по причине ее бесполезности!


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует