Вход | Регистрация


1С:Предприятие ::

Метки:бухгалтерский учет

ОСВ по о-п-е-р-а-ц-и-я-м!

Я
   Crystalizer
 
30.06.04 - 15:07
нужно сделать чтобы оборотно-сальдовая выдавала данные и по операциям. как обратиться к операциям из данных по бухитогам? или это вообще нужно делать как-то иначе.

можно обращаться ит.операция но ничего оттуда получить не получаеца.
 
 
   GrayT
 
1 - 30.06.04 - 15:14
Код показал бы. Интересней "гадать" было бы
   Crystalizer
 
2 - 30.06.04 - 15:20
код...
код - это ОСВ по счету (из бух для укр 253), но урезана так чтоб показывать только нужное для счета 281.
   Crystalizer
 
3 - 30.06.04 - 15:27
как я понял это нужно делать внутри цикла прохода по итогам отбирая значения по счету 281 и по заданному периоду
а с бухитогами будет связь только по субконто
   GrayT
 
4 - 30.06.04 - 15:27
Под "кодом" я подразумевал код программы. Насколько я понял ты его изменял.
Украинскую бухню не видел, а в российской ОСВ разворачивается по операциям рассшифровкой для выбранных субконто.
   Ira
5 - 30.06.04 - 15:33
Ит.ВыполнитьЗапрос(НачДата,КонДата,ВыбСчет,,,,"Операция");
Ит.ВыбратьПериоды()
Пока Ит.ПолучитьПериод() = 1 Цикл
-//--//
КонецЦикла
Могу выслать пример с детализацией по проводкам.
   Crystalizer
 
6 - 30.06.04 - 15:39
не - переписывать всю осв не хочеца %)))

значит там есть цикл выборки данных по субконто...
туда я вписываю такое:

                    Если по_опер=1 Тогда
                        оп = создатьобъект("операция");
                        оп.ВыбратьОперацииСПроводками(Дата1, Дата2, СчетПоКоду("281"), , 3, , , ); 
                        оп.ИспользоватьСубконто(ВидыСубконто.ТМЦ, Ит.Субконто(2));
                       //оп.ВыбратьОперации(Дата1, Дата2);

                        Пока оп.получитьоперацию() = 1 Цикл
                            Т.ВывестиСекцию("операция"); 
                        КонецЦикла;
                    КонецЕсли;

и вроде выдает документы...
но как получить в данном случае из операции {Количество и Сумму} по {дебету и кредиту} на начало периода, обороты, и на конец периода...?
   GrayT
 
7 - 30.06.04 - 15:50
Что значит получить из операции "на начало и на конец"? Операция - это набор проводок, при чем тут остатки. Получить остатки на начало операции нужно?
Ну а обороты данной операции - это и есть количество и сумма данных проводок
   Crystalizer
 
8 - 30.06.04 - 16:13
GrayT: вот я сам сижу и фтыкаю.... :()
как же данные из проводок разложить в ОСВ "на начало пирода, конец и обороты за"........ ?!
   It is me
 
9 - 30.06.04 - 16:39
А журнал-ордер по счету с детализацией до операции из той же типовой сформировать слабо?
   Crystalizer
 
10 - 30.06.04 - 16:51
it is me: журнал-ордер? это что?

подскажите может так можно:
                    Если по_опер=1 Тогда
                        оп = создатьобъект("операция");
                        оп.ВыбратьОперацииСПроводками(Дата1, Дата2, ,СчетПоКоду("281"), 3, , , ); 
                        оп.ИспользоватьСубконто(ВидыСубконто.ТМЦ, Ит.Субконто(2));
                        Пока оп.получитьоперацию() = 1 Цикл

////////////// И ВОТ ТУТ выбрать проводки и смотреть если счет дебета 281 - значит эту сумму/колво писать в дебет. но только дебет чего? дебет оборотов за период???



                            Т.ВывестиСекцию("операция"); 
                        КонецЦикла;
                    КонецЕсли;
 
 
   Crystalizer
 
11 - 30.06.04 - 17:18
а как вообще обращаться к данным проводки в данной операции?
   Gavrila
 
12 - 30.06.04 - 17:24
(11) Прислушайся лучше к (9) , типовую без крайней нужды лучше не менять
   It is me
 
13 - 30.06.04 - 17:30
Отчеты-Журнал ордер по субконто-Детализация-Операция
   Crystalizer
 
14 - 30.06.04 - 17:31
Gavrila: шеф дал такое задание, не я придумал.
   Gavrila
 
15 - 30.06.04 - 17:34
(14) слушаться шефа вредно (иногда), заработаешь потом кучу головной боли, лучше разберись с журнал-ордером и попробуй доказать ему, что это то что ему нужно :)
   Crystalizer
 
16 - 30.06.04 - 17:39
It is me: спасибо - ну для сверки это тошо надо :)
   It is me
 
17 - 30.06.04 - 17:46
Для сверки то что надо - карточка счета&карточка субконто
   Gavrila
 
18 - 30.06.04 - 17:49
+(15) а если по вопросу (0) смотри (5)
Ит.ВыполнитьЗапрос(НачДата,КонДата,ВыбСчет,,,,"Операция");
Здесь "Операция" - это период выборки итогов, а вот в самом цикле "Пока Ит.ПолучитьПериод() = 1 Цикл" уже можешь получить "Ит.Операция".
Вроде так, если нужно все таки делать в ОСВ, открой Журнал-Ордер и сделай поиск по ключевым словам, ну типа "Период", "ВыбратьПериоды" и так далее, там довольно таки понятно это сделано.
   427
 
19 - 30.06.04 - 18:26
ХХХХХХХХ некоторых вопрошающих беспредельна
   Crystalizer
 
20 - 30.06.04 - 18:34
Gavrila: нда... теперь мне кажеца шо таки придёца так делать...
   Crystalizer
 
21 - 30.06.04 - 22:31
я шот не могу понять как разложить это по операциям
вернее по операциям раскладывается но суммы какие-то не те что в "журнал-ордер по субконто"

скажите, такой код верен:

                    Ит2 = Создатьобъект("БухгалтерскиеИтоги");
                    Ит2.ИспользоватьСубконто(ВидыСубконто.ТМЦ, Ит.Субконто(2), 1, 0 );
                    Ит2.ВыполнитьЗапрос(Дата1, Дата2, СчетПоКоду("281"), , , 1,"Операция", "1+4");
                    Ит2.ВыбратьПериоды();
                    Пока Ит2.ПолучитьПериод() = 1 Цикл
                        оп = Ит2.Операция;
                        Т.ВывестиСекцию("операция"); 
/// выводятся: "оп.сумма" и "оп.количество" по каждой операции

                    КонецЦикла;

он стоит внутри вычисления ОСВ в цикле получения данных по 2му субконто (тмц) и вычисляет НАЧАЛЬНЫЕ количества и суммы...

или так нельзя получать суммы и количества из операций (имею ввиду "оп.сумма" и "оп.количество")?
   Warlock
 
22 - 30.06.04 - 22:48
Сумма в перации может рассчитываться различными методами(выбирается в параметрах операции):
- не рассчитывать
- по всем проводкам
- по первой проводке
или вручную сумму можно закатать. Отсюда и левые суммы. Тебе наверно надо по проводкам...
   Crystalizer
 
23 - 30.06.04 - 23:09
если делать вывод через Ит2.СНД("К") и Ит2.СНД() то получается правильно... но не всегда
например в операции "Перемещение ПМ-0000002 (15.02.03)" значения больше чем в "журнал-ордере по субконто".  почему так может быть?
   Warlock
 
24 - 30.06.04 - 23:32
(23)Напиши сумму в журнале-ордере, сумму получаемую в запросе и проводки, формируемые перемещением.
   Crystalizer
 
25 - 30.06.04 - 23:40
например, в журнале ордере:
(Нач.ост.Деб.)
сумма = 2,800.00 
колво = 112.000

у меня:
сумма = 5385.17
колво = 202

может она как-то суммируется?
потому как в ж-о в этой строке по счету 28 = 2500, далее кред оборот = 2500, далее кон.ост.деб=300. ну тогда бы было 5300. откуда ещё 85... ндс?%)
   Crystalizer
 
26 - 30.06.04 - 23:57
кстати... проводки-то...
   Crystalizer
 
27 - 01.07.04 - 00:11
в проводках суммы другие.
для счета 281 они меньше
но я смотрю что сумма остатка на начало периода = 2500 + сумма остатка на конец периода.
2500 = проводка по Кт 281 "Перемещение: Прод. стоимость"
и сумма остатка на конец периода у меня отличаеца. или я уже считаю шото совсем не в тему?!
   GrayT
 
28 - 01.07.04 - 00:16
оп.Сумма возвращает тебе сумму первой проводки вероятно.
Пользуйся СНД. А то что сумма с ЖО не совпадает.... так там сальдо на начало дня стоит, а у тебя на операцию
   Crystalizer
 
29 - 01.07.04 - 00:25
GrayT: так и пользуюсь уже СНД/СНК/...
а чего ты считаешь что там сальдо на начало дня? я ж выбираю детализацию по операциям там (чтоб теже знач-я были)?!
   GrayT
 
30 - 01.07.04 - 00:30
В украинской в ЖО по субконто можно период указать? В российской только в ведомости по счету.
Что то я косяков тогда особо не вижу.
Третий параметр в ИспользованииСубконто - 2 кажись лучше смотрелось бы. И то что Ит.Субконто(2) возвращает нормальные данные ты проверял, надеюсь
   Crystalizer
 
31 - 01.07.04 - 00:45
детализация:
-проводка
-операция - выбираю
-дата
-неделя
-...

да "отбирать" красивее только от этого лучше не становица.
блин, вроде всё так красиво а суммы не те %)))



Список тем форума
  Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует