Вход | Регистрация

1С:Предприятие ::

Метки:коллекции значений

таблицазначений.количествострок() -- что за глюк?

Я
   Crystalizer
 
29.06.04 - 11:49
есть такое:

    Сообщить(" >>> " +список.КоличествоСтрок() );
    для ц = 1 по список.КоличествоСтрок() цикл
        сообщить(ц);
        пр = список.ПолучитьЗначение(ц, "Ссылка");


в результате:

 >>> 1330
1
2
...
1330
пр = список.ПолучитьЗначение(ц, "Ссылка");
{C:\1CV7S\ОБР_ДОККК.ERT(134)}: Номер за пределами значения!

почему за пределами если это граница?
 
  Рекламное место пустует
   laeg
1 - 29.06.04 - 11:59
Покажи вес цикл, быть такого не может. Ты случайно не удаляешь в цикле строчки ?
   cup of tea
2 - 29.06.04 - 12:00
а "КонецЦикла" - где?
Если между "Сообщить()" и ПолучитьЗначение() - тогда все так и задумано ))
   Crystalizer
 
3 - 29.06.04 - 12:05
б*я!!!
laeg: спасибо, таки да, бес попутал %)
   laeg
4 - 29.06.04 - 12:24
Совет:
ном = список.КоличествоСтрок()
Пока ном >= 1 Цикл
    Если (нужно удалить) Тогда
       Список.УдалитьСтроку(ном);
    КонецЕсли;
     ном = ном - 1;
КонецЦикла


Список тем форума
Рекламное место пустует   Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует