Вход | Регистрация


1С:Предприятие ::

Метки:Общие вопросы

1С это язык скриптов или все же программирования?

Я
   Vser1
 
29.06.04 - 10:31
Если исходить из того, что модуль программного кода 1С интерпретируется во время выполнения, то C и басик NET тоже скриптами можно обозвать, ведь они интерпретируются через фреймворк (== типа среда 1С). ООП можно организовать через компоненту 1С++.

=============================================
ЗЫ: встретил на одном форуме, возник вопрос какие мнения будут на специализированном форуме по данному вопросу, ссылку на исходник дам попозже.
 
  Рекламное место пустует
   SnarkHunter
 
1 - 29.06.04 - 10:33
Не все ли равно...
Для начала дай точное определение что такое "скрипт" и что такое его язык...
   Valery
 
2 - 29.06.04 - 10:36
Ты имееш ввиду, что язык программирования это с компилятором, скрипт - интерпретатор?
   SiMazx
 
3 - 29.06.04 - 10:43
Вот на что может повлиять любой вариант ответа? Вот мне лично глубоко пофих...
Шашлык-машлык, не видишь - мы кющаем...
   Valery
 
4 - 29.06.04 - 10:52
(3) Конечно совершенно по барабану. Компилятор интерпретатор.
раньше было foxpro и clipper. Все один к одному только один интерпретатор другой компилятор. Как тут понять в таком случае?
   SnarkHunter
 
5 - 29.06.04 - 10:53
Да и клиппер не совсем компилятор...
   Матрейя
7 - 29.06.04 - 18:23
Все реальные 1с-ники давно перешли на 2с :)
   Матрейя
10 - 29.06.04 - 18:27
 
  Рекламное место пустует
   romix
 
16 - 29.06.04 - 19:50
1С - это не скрипты!!!!
Скрипты автоматизируют/имитируют работу пользователя в "юниксовой" текстовой консоли. В противном случае это приложение. :-)
   Волшебник
 
17 - 29.06.04 - 22:02
Очень даже возможно, что встроенный язык 1С:Предприятия 7.7 - скриптовый язык, аналогично PHP или JavaScript. И в этом нет ничего плохого. Он изначально не задумывался как универсальный язык программирования, типа C++.

Как говорит доктор Александр Червоненко: "Не важно, что ты делаешь и во что веришь. Важно, как это изменяет тебя". Хоть горшком назови... Если инструмент помогает быстро и качественно решать поставленные задачи, интересен, дает свободу творчеству, наконец, обеспечивает пропитание, то это хороший инструмент.
   Warlock
 
18 - 29.06.04 - 22:19
ИМХО Язык 1С можно называть скриптовым пока рассчитываются формулы типа Итог("Сумма") или процедурки типа
Если ПустоеЗначение(Цена)=1 Тогда
   Предупреждение("ВведитеЦену!!!");
   СтатусВозврата(0);
КонецЕсли;

Но если реализована обработка загрузки выписки банка, то какие тут скрипты?!

А вообще, все равно, как называть, язык 1С:Предприятие решает (пытается решать) задачи, для которых был создан...
   Матрейя
21 - 29.06.04 - 23:22
20. А чем 1с-язык не язык высокого уровня? Отличия основные только в том, что нельзя создавать свои классы не используя ВК.
   Матрейя
23 - 29.06.04 - 23:42
Тем не менее, созданный набор классов достаточен для большинства экономических задач. Если интересует что-то более продвинутое, тогда пробуй 2с. У меня лично возникло очень приятное чувство, когда я сам создал объект ТЗ и описал его свойства и методы. А потом сравнил с ТЗ 1с на скорость: ввод 50000 строк по 3 столбцам (значения 1,2,3) в 1с на моем компе - 4,5 сек, моя ТЗ-3 сек.
   Матрейя
25 - 29.06.04 - 23:54
24. Вот смотри код метода ТЗ.НоваяСтрока()
Функция НоваяСтрока() Экспорт
    ЕстьСтрок=ЕстьСтрок+1;
    НомерСтроки=ЕстьСтрок;
    Для П=1 По ЕстьАтрибутов Цикл
        Данные[П].ДобавитьЗначение();
    КонецЦикла;
КонецФункции

И это все :)) Данные[П] - столбцы ТЗ, выполненные в виде СЗ. То есть ТЗ - массив СЗ.
   Матрейя
26 - 29.06.04 - 23:56
Вот так происходит опеределение СоздатьОбъект("ТаблицаЗначений"):

Функция ПолучитьТипОбъекта()Экспорт
     Возврат "ТаблицаЗначений";
КонецФункции
   Матрейя
27 - 29.06.04 - 23:57
И последний пример, который показывает реализацию метода Знач=ТЗ.ИмяКолонки в переборе:
Функция ПолучитьАтрибут(Имя) Экспорт
    НомКол=ПолучитьИмяАтрибута(Имя);
    Если Число(НомерСтроки)>0 Тогда
        Если НомКол>0 Тогда
            Возврат (Данные[НомКол].ПолучитьЗначение(НомерСтроки)); 
        Иначе
            Ошибка("Неизвестный идентификатор колонки : "+Имя);
        КонецЕсли
    Иначе
        Ошибка("Не было выборки строк");
    КонецЕсли;
КонецФункции
   Матрейя
29 - 30.06.04 - 00:09
28. Краткое состояние проекта 2с:
1. Ядро (уровень 0 - интерпретатор) практически завершена функциональность. Глюки есть, их больше чем в v77, но меньше чем в v8. В ближайшее время будет начата работа по "вылизыванию" уровня 0.
2. Уровень 1 - классы - прилагается демо-конфигурация с примитивным и кривым набором объектов (они просто создавались в спешке для тестирования уровня 0), но их достаточно чтобы вникнуть и начать создавать свои.
3. Уровень 2 - конфигурация из объектов уровня 1 пока еще никто не создал, поскольку нет качественных объектов 1 уровня.
4. Нормальная дока - выйдет в ближайшее время.
5. Скорее всего на следующей недели или около этого выйдет конвертор данных из 1с v7 в 2с. Будут конвертироваться только объекты конфигурации, без кода.
   Vser1
 
32 - 30.06.04 - 02:22
Похоже серьезного обсуждалаво не получиться ;))) так что привожу ссылку на источник вопроса:
http://www.ykt.ru/cgi-bin/forum/iforum.isa?f=13&a=rx&id=884943



Список тем форума
Рекламное место пустует   Рекламное место пустует
Выдавать глобальные идеи — это удовольствие; искать сволочные маленькие ошибки - вот настоящая работа.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует