Вход | Регистрация

1С:Предприятие ::

Метки:безопасность

Помогите с ограничением прав доступа

Я
   Appon
 
27.06.04 - 15:44
Как добавить в стандартные ограничение прав, например, запрет просмотра проведенной накладной.Или хотя бы подскажите в какой стороне искать?
 
 
   Орк
 
1 - 27.06.04 - 16:01
Например запрет просмотра проведенного документа:

Процедура ПриОткрытии()
    Если Проведен()=1 Тогда
       // А можно-ли Расчипупкину смотреть документ?

        Если ИмяПользователя()="Расчипупкин" Тогда
             Предупреждение("Расчипупкин - №;%:?*");
             СтатусВозврата(0);//Скажем документу - не моги открываться

             Возврат;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

Аналогично можно использовать ИмяКомпъютера(), НазваниеНабораПрав()...

Вставляешь СтатусВозврата(0) в процедуры, называемые
предопределенными (суть - события в других языках) и получаешь
отказ в выполнении оных.
   427
 
2 - 27.06.04 - 16:52
Запрет просмотра проведенной накладной.... хм... мудро

Только вот в отчетах то она полностью в развернутом виде видна ....
   Appon
 
4 - 27.06.04 - 18:10
А по поводу отчетов.Это все делаеться для продавцов, а им стандартной функцией запрещены отчеты.Делаеться это только от того что бы от нечего делать они не начали шариться по накладным других магазинов и потом не обсасывать всем косточки
   427
 
5 - 27.06.04 - 18:51
К сожалению, вынужден огорчить....
Если отчеты запрещены, это не значит, что их нельзя запустить.... Уже на всех форумах растрезвонили..... если среди знакомых у продавцов есть программист - они давно уже все посмотрели... Там все так просто...

И кстати, зачем в одном магазине - доки другого? Они вроде как (чужие) не нужны....


Список тем форума
Рекламное место пустует  
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует