Вход | Регистрация

1С:Предприятие ::

Метки:отчеты

Товарный отчет с фильтрацией по складу

Я
   mkos
 
26.06.04 - 11:45
Добрый день.
Необходимо в типовой торговле в отчете "Товарный отчет" (включен в состав конф.)
добавить на форму реквизит "Склад" для фильтрации документов в
которых есть данный реквизит по этому рекизиту.
В результате добавления к запросу текста:
СтрД="";
Для ин=1 По Метаданные.Документ() Цикл
   
Если глЕстьРеквизитШапки("Склад",Метаданные.Документ(ин).Идентификатор) = 0 Тогда
   Продолжить;
КонецЕсли;
            
Если ПустаяСтрока(СтрД)=0 Тогда
        СтрД=СтрД+","+РазделительСтрок;
КонецЕсли;
СтрД=СтрД+"Регистр.ПартииНаличие.ТекущийДокумент."+Метаданные.Документ(ин).Идентификатор+".Склад";
КонецЦикла;
СтрД=СтрД+";";
ТекстЗапроса = ТекстЗапроса+РазделительСтрок+"Склад = "+СтрД+РазделительСтрок+"Условие (Склад в ВыбСклад);";

Начальный и конечный остатки (в печатной форме "Остаток на...") равны нулю. Есть возможность
получить данные показатели путем перебора всех докуметов делающих движения в "Партии наличие"
с самого начала. Однако это,я думаю,  никого не устоит (работать будет медленно).
Есть ли вариан рашения данного вопроса?
 
 
   Aiuan
 
1 - 26.06.04 - 12:09
я делал через патрииНаличие... и в общем таких уж больших тормозов не наболюдалось.... хатя у меня все работают на терминалах сервера... так шта...
   mkos
 
2 - 26.06.04 - 12:21
Дело в том, что документов в базе за 3 года,
хотя у меня тоже терминальный сервер. Однако другого решения не вижу.
   NS
 
3 - 26.06.04 - 12:57
(0) Тебе ж сальдо (остатки) не нужны?
Только приход/расход?
Намного проще делается...
   makip
4 - 26.06.04 - 13:10
Ясное дело:
запрос ко всем документам(в цикле... Регистр.ПартииНаличие.ТекущийДокумент.<ВидДокумента>)
с функциями приход(СуммаБезНДС) и расход(СуммаБезНДС) и получение нужного
начОст как итгогвого приход-расход, а конОст как начОст+ПриходЗаПериод-РасходЗаПериод (период пользователь выбирает на форме). Как-то еще проще делается?


Список тем форума
Рекламное место пустует   Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует