Вход | Регистрация


1С:Предприятие ::

Метки:бухгалтерский учет

Есть ли в бухзапросе метод ?

Я
   AlexMan
 
24.06.04 - 17:17
В черном запросе есть возможность типа:
Условие(не(Номенклатура в СписокСпр));
В этом случае в запрос попадет все кроме элементов из списка СписокСпр а в БухЗапросе есть такая конструкция?
 
  Рекламное место пустует
   Gavrila
 
1 - 24.06.04 - 17:25
"В черном запросе" - это сильно :))))))))))))
   AlexMan
 
2 - 24.06.04 - 17:28
Так вроде их так называют.....
   Gavrila
 
3 - 24.06.04 - 17:31
(2)не, не слыхал еще, но смешно :)
   AlexMan
 
4 - 24.06.04 - 17:35
Задача такая : в отчет загнать все кроме некоторой группы справочника (сделать надо бух запросом) как это сделать на копманенте бухгалтерия?
   It is me
 
5 - 24.06.04 - 17:42
Загнать все что надо выводить в СЗ и юзать метод ИспользоватьСубконто(ВидыСубконто.ТвойВид,СЗ,1)
   AlexMan
 
6 - 24.06.04 - 17:47
(5) Я так и делаю только все равно выводит все что надо и НЕ надо т.к. то что НЕ надо лежит в группе которыя нужна . По этотому я и спрjсил про метод как в черном запросе в нем если мне не изменяет склероз все ок (если выбрал в фильтре НЕ нужную группу значит она не попадет в запрос где бы не находилась или я не прав ???)
   It is me
 
7 - 24.06.04 - 18:10
Ты не прав...
   NS
 
8 - 24.06.04 - 19:31
СЗ1 получаешь методом
ТекстЗапроса="Тов=Справочник.Номенклатура.ТекущийЭлемент();
             |Условие (не(тов в СЗ));
             |Группировка Тов без групп;";
ТЗ=Создатьобъект("ТаблицаЗначений");
СЗ1=создатьобъект("СписокЗначений");
Запрос.Выполнить(ТекстЗапроса);
Запрос.Выгрузить(ТЗ,0,0);
ТЗ.Выгрузить(СЗ1,,,"Тов");
а дальше - бух. запрос фильтруешь по СЗ1...
   427
 
9 - 24.06.04 - 19:32
фигня ...
   NS
 
10 - 24.06.04 - 19:32
извиняюсь - есно текущийЭлемент; - без скобок.
 
  Рекламное место пустует
   427
 
11 - 24.06.04 - 20:38
фсе рафно фихня...
   AlexMan
 
12 - 24.06.04 - 21:27
(8) Не понял чем здесь поможет Запрос по справочнику (СЗ чем отличается от СЗ1)?
(9) Может ты подскажеш чего делать то?
   NS
 
13 - 24.06.04 - 23:34
(12) А чего тут понимать?
В СЗ1 выгружаются все элементы - кроме СЗ...
   AlexMan
 
14 - 25.06.04 - 09:25
(13) То что выгружаются то понятно но как это поможет (читай (6))
(7) Вчера в Торговле 8_7 проверял в черном запросе все работает как я написал в (6) It is me посмотри внимательно.......
   AlexMan
 
15 - 25.06.04 - 12:22
up! может кто из корифеев вспомнит как такое реализовать ...
   427
 
16 - 25.06.04 - 12:36
пытаюсь вспомнить.... фсе хфигня......
   AlexMan
 
17 - 25.06.04 - 12:40
(16) Ты согласен что на опер. учете это корректно работает?
   NS
 
18 - 25.06.04 - 15:43
(AlexMan) Просто клиника.
   AlexMan
 
19 - 25.06.04 - 15:48
(18) Ты сам то пробывал что написал в (8) ?
   Tyпoй Mля
20 - 25.06.04 - 15:51
Пробавал
Пробевал
Пробёвал
Пробивал
Пробувал
Пробывал
Пробэвал
Пробювал
Пробявал

Сколько вариантов...
   NS
 
21 - 25.06.04 - 15:52
(19) Не хами...
Сначала делаешь (19)
Потом (5)
ИспользоватьСубконто(ВидыСубконто.ТвойВид,СЗ1,1);
   NS
 
22 - 25.06.04 - 15:53
Есно не (19), а (8)
   AlexMan
 
23 - 25.06.04 - 15:54
(20) а еще есть варианты?
   Tyпoй Mля
24 - 25.06.04 - 15:58
(23)Есть. Правильный. Но я тебе его не скажу.
   AlexMan
 
25 - 25.06.04 - 15:58
1 (21) в (19) нет ни грама хамства
2 (21) Я уже писал что примерно так и делал читай внимательно (6).
   Tyпoй Mля
26 - 25.06.04 - 15:59
Грама нету, а граммов сколько угодно.
   AlexMan
 
27 - 25.06.04 - 16:02
(24) Ты бы лучше на (0) ответил (если знаеш ответ) , чем за моей орфографией следить...
   Tyпoй Mля
28 - 25.06.04 - 16:06
Откуда мне ответы знать, я же тупой мля. ЗнаешЬ?
   NS
 
29 - 26.06.04 - 00:41
неужели никто не знает?
   BorisG
 
30 - 26.06.04 - 01:18
И никто не сталкивался? ;-))
   NS
 
31 - 26.06.04 - 01:22
(30) И не говори...
Ну... Митичкин.... Должен ведь знать?
   427
 
32 - 26.06.04 - 12:10
ну чЁ малчите то? никто не знает?
быстро помогите
   NS
 
33 - 26.06.04 - 15:37
Ну где же Митичкин? Организовал форум - помогай лохам!
 
  Рекламное место пустует
   (0) Все очень просто
34 - 26.06.04 - 15:46
Нет
   gerasan
 
35 - 27.06.04 - 07:44
Если кому-то не нравится (8) + (5), то напомню, что вообще-то "черным" запросом можно воспользоваться для получения бухгалтерских итогов.
   427
 
36 - 27.06.04 - 08:13
(35) да что ты говоришь? А то мы не знаем.....
   Z1
37 - 27.06.04 - 09:42
(0) читай очень внимательно rtml для
ИспользоватьСубконто
   AlexMan
 
38 - 28.06.04 - 10:02
Здрасте всем.
(35) 8+5 - мне очень нравится , только проблема в том что это не работает , я уже устал отсылать всех в (6) по этому напишу еще раз : Есть группа Гр1 в ней есть Гр11,Гр12,.....Гр1N Если в запросе не нужна группа Гр1К то в черном запросе можно написать : Условие(не(Номенклатура в СписокСпр)); ( СписокСпр-Содержит группу Гр1К)
в этом случае у меня будут видны итоги не только по всем группам Гр11,Гр12,.....Гр1N кроме Гр1К но и по группе Гр1.
Если же в бух запросе собирать в список только нужные группы тогда не будет итогов по Гр1 (ее вообще нет в запросе) (т.к. если ее включть в список нужных групп тогда не удается отфильтровать  Гр1К)... получается замкнутый круг....
На выходных меня осинило идеей использовать черный запрос для получения бух итогов но там результат меня просто поразил : 1 Если к примеру будет отрицательный кредитовый остаток по Пассивному счету (например по счету 60.1) то в запросе такое творится - мама не горюй...
2 При этом если запрос выгрузить в ТЗ то там то все как надо - мистика да и только ... Видимо придется использовать Черный запрос + ТЗ.
(36) Мог бы и сам раньше подсказать....

(37) если ты имееш в виду третий параметр метода ИспользоватьСубконто(,,р,); где р=3; то ты сильно заблуждаешся.

Всем спасибо за ценные советы , постараюсь сегодня реализовать все что задумал о результатах сообщу позже...
   Мдя....
 
39 - 28.06.04 - 11:14
»
   BorisG
 
40 - 28.06.04 - 11:39
(39) А может лучше ЖКК для начала открыть? Там есть... ;-))
Это такая интересная штука ;)
   AlexMan
 
41 - 28.06.04 - 11:52
(39) Пример не работающего черного запроса:
    Сч26=СчетПоКоду("26");
   //Создание объекта типа Запрос

    
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)

    |Период с ДатаНач по ДатаКон;
    |Обрабатывать НеПомеченныеНаУдаление;
    |Счет = Операция.Счет;
    |СтатьиОбщехозяйственныхЗатрат = Операция.Субконто.СтатьиОбщехозяйственныхЗатрат; 
    |Сумма = Операция.Сумма;
    |Функция СуммаДО = ДО(Сумма);
    |Группировка СтатьиОбщехозяйственныхЗатрат;
    |Группировка Месяц;
    |Условие(Счет = Сч26);
    |Условие(не(СтатьиОбщехозяйственныхЗатрат в СписокРодителей));
    |//}}ЗАПРОС

    ;
   // Если ошибка в запросе, то выход из процедуры

    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
   //ТабЗн=СоздатьОбъект("ТаблицаЗначений"); 

   //Запрос.Выгрузить(ТабЗн,0,1);

   //ТабЗн.ВыбратьСтроку();

    НомСтрочки=1;
    
   // Подготовка к заполнению выходных форм данными запроса


   // Заполнение полей "Заголовок"

    Пока Запрос.Группировка(1) = 1 Цикл    
        Пока Запрос.Группировка(2) = 1 Цикл
            Если Запрос.СтатьиОбщехозяйственныхЗатрат.ЭтоГруппа()=1 Тогда 
                Сообщить("Группа");
                Сообщить(Запрос.СтатьиОбщехозяйственныхЗатрат); 
            Иначе  
                Сообщить("Элемент");
                Сообщить(Запрос.СтатьиОбщехозяйственныхЗатрат);
            КонецЕсли;
        КонецЦикла;     
   КонецЦикла;
Самое прикольное что итогов по группам нет вообще !!! в сообщить срабатывает только "Элемент" а "Группа" ни разу не выводится....
Есть идеи?
   AlexMan
 
42 - 28.06.04 - 12:33
+(41)  Если написать так:
Пока Запрос.Группировка(1) = 1 Цикл    
     Если Запрос.СтатьиОбщехозяйственныхЗатрат.ЭтоГруппа()=1 Тогда 
          Cообщить("Группа"); 
          Сообщить(Запрос.СтатьиОбщехозяйственныхЗатрат); 
          Сообщить(Запрос.СуммаДО);
     КонецЕсли; 
          Пока Запрос.Группировка(2) = 1 Цикл 
          КонецЦикла;     
КонецЦикла; 

Тогда Сообщить срабатывает!!!! только Запрос.СуммаДО - откровенно не те суммы что должны быть (сравнивал с ОСВ по счету) причем где то те цыфры где то не те, от конкретного субконто зависит . Блин а дома то все работало (правда без ТЗ тоже не очень но здесь то и до ТЗ никак не доползу)
Help!!!!!
   AlexMan
 
43 - 28.06.04 - 15:35
+(42) В черном запросе не накапливаются итоги по группам элементов справочника в предопределенной групперовке Месяц (запросы писал к разным объектам конфы БухИт, Документы) , что с этим делать ? (в бух запросе напротив с этим нет проблем).
   427
 
46 - 28.06.04 - 18:29
(задумчиво).... иии-эх.... глаза то по утру мыть надо.... мне ....
   NS
 
47 - 29.06.04 - 03:38
Пять дней на такую задачу...
Если ты даже за это полташку получил... еслиб мне так платили...
Выкупил бы НАХ у Нуралиева всю контору...
   NS
 
48 - 29.06.04 - 03:38
Пять дней на такую задачу...
Если ты даже за это полташку получил... еслиб мне так платили...
Выкупил бы НАХ у Нуралиева всю контору...
   AlexMan
 
49 - 30.06.04 - 09:53
(47)-(48) Ты полагаеш что я только эту задачу и решал все 5 дней ???? Ну ты и приколист , меня давно бы выгнали...
P.S. Естественно паралельно я решал другие задачи.
 
  Рекламное место пустует
   SnarkHunter
 
50 - 30.06.04 - 10:55
И так же успешно как эту?
   AlexMan
 
51 - 30.06.04 - 11:35
(50) Эту задачу я решил (правда пришлось с юзерами договариватся о переносе "мешающих" групп на верхний уровень чтобы не мешали) ... А остальные задачи я решил также успешно как и эту :))



Список тем форума
Рекламное место пустует   Рекламное место пустует
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит Тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует