Вход | Регистрация

1С:Предприятие ::

Метки:

SOS: спасение новичка дело рук самого хомячка???

Я
   Spoofy
 
20.12.03 - 02:25
Помогите пожалуйта разобраться с двумя вопросами!!!

1.................................................

Пока СпрТовары.ПолучитьЭлемент()=1 Цикл
Если СпрТовары.ПринадлежитГруппе("Спиртное")=1 Тогда
     Сообщить(СпрТовары.Наименование);     
КонецЕсли
КонецЦикла; 

в справочнике Товары есь группа "Спиртное", в которой есть элементы, почему ничего не выводится? 8(

2...................................................

Есть два справочника: Сотрудники и Должности. Реквизит справочника Сотрудники "Должность" имеет значение Справочник.Должности
Как корректно установить фильтр по этому реквизиту???
Например
СпрСотр.ВыбратьЭлементыПоРеквизиту("Должность", "Программист", 0, 0);
отфильтровывает весь справочник, почему??? 8((
 
 
   Волшебник
 
1 - 20.12.03 - 03:11
По 1-му вопросу:

ошибка здесь:
ПринадлежитГруппе("Спиртное")

нужно передавать не строку, а группу справочника (элемент). То есть перед этим нужно ее сначала найти по наименованию:

Если СпрТовары.НайтиПоНаименованию("Спиртное")=1 Тогда
Группа = СпрТовары.ТекущийЭлемент();
КонецЕсли;

и так далее.

По 2-му вопросу:
То же самое. Должность (значение отбора) должно представлять собой не строку, а элемент справочника.
   Spoofy
 
2 - 20.12.03 - 20:02
Всё, вьехал!!! Спасибо огромное! Продолжаю секс.
   Волшебник
 
3 - 20.12.03 - 20:10
(2) будь с ней помягче и она тебе улыбнется :)
   ally
 
4 - 21.12.03 - 08:08
(3) 5 баллов


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует