Вход | Регистрация

1С:Предприятие ::

Метки:Встроенный язык

Как разобрать Имя, Фамилию, Отчество на отдельные состовляющие

Я
   bam
 
24.06.04 - 12:55
Как получить отдельно имя фамилию и отчество, в справочнике сотрудников - то они все в одном свойстве: наименование
 
 
   Миха
1 - 24.06.04 - 13:00
разобрать строку на 3 составляющие, учитывая пробелы
   Волшебник
 
2 - 24.06.04 - 13:05
см. функцию РаздФИО
в конфигурации Мини-зарплата
http://www.mista.ru/tutor_1c/files/mini_zarplata.zip

или в типовых конфигурациях
   Волшебник
 
8 - 24.06.04 - 13:12
Вот теория выделения фамилии, имени и отчества из ФИО:
http://www.aot.ru/docs/graphan.html
   Волшебник
 
9 - 24.06.04 - 13:15
1-й вариант:

ФИО=СокрЛП(ФИО);
Пока СтрНайти(ФИО, " ")<>0 Цикл
  ФИО=СтрЗаменить(ФИО, " ", " ");
КонецЦикла;
ФИО=СтрЗаменить(ФИО, " ", РазделительСтрок);
Фамилия=СтрПолучитьСтроку(ФИО, 1);
Имя=СтрПолучитьСтроку(ФИО, 2);
Отчество=СтрПолучитьСтроку(ФИО, 3);

-------------------------------------------
2-й вариант:

Фамилия = "";
Имя = "";
Отчество ="";

ФИО=СокрЛП(ФИО);
ОбщДлина=СтрДлина(ФИО);

//поделим на фамилию, имя и очество

// позиция первого пробела
ПервПроб = Hайти(ФИО," ");
Если ПервПроб=0 Тогда
    Фамилия = СокрЛ(ФИО);
Иначе
    Фамилия = Лев(ФИО,ПервПроб);
    ИО = Сред(ФИО,ПервПроб+1);
    ИО = СокрЛП(ИО);
   // позиция второго пробела

    ВтПроб = Hайти(ИО," ");
    Если ВтПроб = 0 Тогда
        Имя = СокрЛП(ИО);
    Иначе
        Имя = СокрЛ(Лев(ИО,ВтПроб-1));
        Отчество =СокрЛ((Сред(ИО,ВтПроб+1)));
    КонецЕсли;
КонецЕсли;


Список тем форума
Рекламное место пустует   Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует