Вход | Регистрация


1С:Предприятие ::

Метки:справочники

Справочники

Я
   sov
 
23.06.04 - 14:13
Мэтры 1С, подскажите пожалуйста.
Создал 3-х уровневый справочник Номенклатура. При открытии справочника, без разворачивания по уровням, пытаюсь вывести его на печать. Таблица формируется, но в полях, где указаны цены (ЦенаП и ЦенаР), стоят нули. Если же разворачиваю уровни(щелкаю мышью по конкретному товару), таблица заполняется нормально.
Процедуру вывода на печать справочника привожу ниже.

Процедура Печать()
    СпрТов=СоздатьОбъект("Справочник.Номенклатура");
    СпрТов.ПорядокКодов();
    Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Шапка");   
    СпрТов.ВыбратьЭлементы();
    Пока СпрТов.ПолучитьЭлемент()=1 Цикл
        ТЭ=СпрТов.ТекущийЭлемент();
        Если ТЭ.ЭтоГруппа()=1 Тогда
            Код=ТЭ.Код;
            Наз=ТЭ.Наименование;
            Таб.ВывестиСекцию("Группа");   
        Иначе
            Код=ТЭ.Код;
            Наз=ТЭ.Наименование;  
            ЕдИ=Строка(ТЭ.ЕдИзм);
            ЦенаП=ТЭ.ЦенаП.Получить(ТекущаяДата());
            Сообщить(ЦенаП);
            ЦенаР=ТЭ.ЦенаР.Получить(ТекущаяДата());
            Таб.ВывестиСекцию("Элемент");
        КонецЕсли;
    КонецЦикла;
Таб.ТолькоПросмотр(1);
Таб.ПараметрыСтраницы(1,100,1);
Таб.Показать("");
КонецПроцедуры
 
 
   Valery
 
1 - 23.06.04 - 14:19
попробуй получить значение на рабочую дату.
   sov
 
2 - 23.06.04 - 14:23
На (1). Не помогло.
   Тупой Мля
 
3 - 23.06.04 - 14:25
СпрТов.ЦенаП.Получить(ТекущаяДата());
   sov
 
4 - 23.06.04 - 14:28
На (3). Не помогло.
   Gruz
 
5 - 23.06.04 - 14:59
Командой Сообщить(ЦенаП) что-нить сообщается ?
   Тупой Мля
 
6 - 23.06.04 - 15:08
Чего-то ты не договариваешь.
   Stra
 
7 - 23.06.04 - 15:42
А откуда процедура печати вызывается? Из модуля не видно чтобы печать реагировала на иерархию справочника. Такую процедуру можно вызвать откуда хошь, не открывая справочника.
   Рупор абсурда
 
8 - 23.06.04 - 15:46
(7) По твоему, есть принципиальная разница? Какая?
   sov
 
9 - 23.06.04 - 15:51
На (5). Выдаются нули.
На(7). Кнопкой Печать расположенной на форме списка. Выбираю справочник из меню.
Он открывается свёрнутым( в смысле все ветки дерева свёрнуты). Далее как описал в вопросе.
   Stra
 
10 - 23.06.04 - 15:55
(8) Есть, если вызывать процедуру из модуля формы списка, то ТекущийЭлемент() возвратит элемент на котором спозиционирован курсор.
Может у sov она к колонке привязана?
 
  Рекламное место пустует
   Рупор абсурда
 
11 - 23.06.04 - 15:58
(10) У него же нигде нет ТекущийЭлемент() ...
Я имею ввиду конкретный текущий случай ...
   Тупой Мля
 
12 - 23.06.04 - 15:58
.
   sov
 
13 - 23.06.04 - 16:01
На (10 - Может у sov она к колонке привязана? ). Это как?
На (если вызывать процедуру из модуля формы списка, то ТекущийЭлемент() возвратит элемент на котором спозиционирован курсор). В этом что-то есть. Но как это обойти?
   Stra
 
13 - 23.06.04 - 16:02
(9) Попробуй сделать это внешней обработкой.
   Тупой Мля
 
15 - 23.06.04 - 16:06
Сегодня день тупых советов.
   Рупор абсурда
 
16 - 23.06.04 - 16:10
(15) И самое интересное, что прислушиваются именно к таким ...
   sov
 
17 - 23.06.04 - 16:16
На (13). Получилось!!?! Почему внешняя сработала, а из формы нет?
   Тупой Мля
 
18 - 23.06.04 - 16:19
Потому что все тупые.
   sov
 
19 - 23.06.04 - 16:20
Волшебнику. Поясни пожалуйста ситуацию по поводу вопроса,(10), (13), (17).
   STRA1
20 - 23.06.04 - 17:43
(17) Что прописано в модуле формы списка, кроме процедуры Печать()? Нет ли там переменных ЦенаР, ЦенаП?
   sov
 
21 - 24.06.04 - 08:17
На (20). Переменных ЦенаП и ЦенаР в модуле формы списка нет. В процедуре Печать() это поля. Сама процедура полностью приведена в вопросе.
   Warlock
 
22 - 24.06.04 - 08:41
(21)Как же нет таких переменных?!
ЦенаП - это реквизит справочника и
ЦенаП=ТЭ.ЦенаП.Получить(ТекущаяДата()); - переменная для формирования таблицы.
Вот тут то и трабла. Просто назови переменную по-другому и все.
   sov
 
23 - 24.06.04 - 08:51
На (22). Получилось,спасибо за подсказку.



Список тем форума
Рекламное место пустует   Рекламное место пустует
2 + 2 = 3.9999999999999999999999999999999...
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует