Вход | Регистрация

1С:Предприятие ::

Метки:Встроенный язык

Функция будет работать?

Я
   dvtp
 
23.06.04 - 00:15
Будет ли работать эта функция в накладной комплексной конфигурации? Задача отдельными ячейками вывести НДС по ставке 10 и 18%.

Функция 10%() 
   ВыбратьСтроки(); 
   Рез = 0; 
   Пока ПолучитьСтроку() = 1 Цикл 
       Если СтавкаНДС=10 Тогда
    Рез = Рез+Число(СуммаНДС); 
   КонецЦикла; 
   Возврат(Рез); 
КонецФункции

Попробовать не на чем. Не ругайте, я чайник, поясните если что не так.
 
  Рекламное место пустует
   ChAlex
 
1 - 23.06.04 - 00:21
Почеиу бы и нет. При условии, что СтавкаНДС - число и функция находится в модуле документа.
   dvtp
 
2 - 23.06.04 - 00:24
СтавкаНДС - это вроде процент. Будет ли он выбирать его из столбца НДС или нет?
   ChAlex
 
3 - 23.06.04 - 00:42
А в чем сомнени ?
   dvtp
 
4 - 23.06.04 - 00:45
Спасибо за консультацию
   SnarkHunter
 
5 - 23.06.04 - 06:06
Если СтавкаНДС=10 Тогда < == Вот с ЭТИМ работать не будет...
   dvtp
 
6 - 24.06.04 - 18:31
Да, не работает. Не поясните почему?
   lexa
 
7 - 24.06.04 - 18:42
(6) СтавкаНДС имеет тип Перечисление.СтавкиНДС
   dvtp
 
8 - 24.06.04 - 18:52
Т.е.
Если Перечисление.СтавкиНДС=10 Тогда
Будет работать?
   lexa
 
9 - 24.06.04 - 18:54
СтавкаНДС=Перечисление.СтавкиНДС.НДС10
   dvtp
 
10 - 24.06.04 - 19:02
Я извиняюсь за назойливость. но правильная функция будет:
Функция 10%() 
  ВыбратьСтроки(); 
  Рез = 0; 
  Пока ПолучитьСтроку() = 1 Цикл
      Если СтавкаНДС=Перечисление.СтавкиНДС.НДС10 Тогда
         Рез = Рез+Число(СуммаНДС);
      КонецЕсли;
  КонецЦикла; 
  Возврат(Рез); 
КонецФункции
 
  Рекламное место пустует
   lexa
 
11 - 24.06.04 - 19:13
СуммаНДС и так число, если тебе надо получить сумму НДС по ставке 10 по всей накладной, то наверное будет, но лучше убери % из названия функции


Список тем форума
Рекламное место пустует   Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует