Вход | Регистрация

1С:Предприятие ::

Метки:Обмен данными и УРБД

dbf

Я
   bam
 
22.06.04 - 17:01
Люди Добрые, не могли бы Вы помочь мне с куском кода, формирующим файл dbf скажем со списком сотрудников?
Агромная просьба!!
 
  Рекламное место пустует
   mszsuz
 
1 - 22.06.04 - 17:12
   Gruz
 
2 - 22.06.04 - 17:15
Пример со справочником стран (сотрудников - аналогично)

Процедура ВыгрузкаСправочникаСтран()   
    ПутьКБазе=?(Вар=1,"a:\",СокрЛП(Кат));
     Если ФС.СуществуетФайл(ПутьКБазе+"Cnt.dbf")=1 Тогда
          ФС.УдалитьФайл(ПутьКБазе+"Cnt.dbf");
    КонецЕсли; 

    Сообщить("=======================================");
    Сообщить("Выгрузим страны-производители");
     //Выгрузим справочник стран

    ДБФ=СоздатьОбъект("XBase");
    ДБФ.ДобавитьПоле("CODE",1,13,0);
    ДБФ.ДобавитьПоле("NAIM",2,80,0);
    ДБФ.СоздатьФайл(ПутьКБазе+"Cnt.DBF",);
    Спр=СоздатьОбъект("Справочник.Страны");
    Спр.ВыбратьЭлементы();
    Ном=0;
    Пока Спр.ПолучитьЭлемент()=1 цикл
        Если Спр.ЭтоГруппа()=1 тогда
            Продолжить;
        КонецЕсли;
        Ном=Ном+1;
        Состояние("Выгружено "+Ном);
        ДБФ.Добавить();
        ДБФ.CODE=Спр.Код;
        ДБФ.NAIM=СокрЛП(Спр.Наименование);
        ДБФ.Записать();
    КонецЦикла;
    ДБФ.ЗакрытьФайл();
    Сообщить("Выгружено "+Ном+" стран");
    Сообщить("Выгрузка справчника стран-производителей закончена!");
КонецПроцедуры
   bam
 
3 - 22.06.04 - 17:21
Вери БИГ thенкс от начинающего 1С-программера! :-)


Список тем форума
Рекламное место пустует   Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует