Вход | Регистрация

1С:Предприятие ::

Метки:документы

Перепроведение

Я
   Term2
 
22.06.04 - 04:21
В обработке документов стоит такой код

Если Док.ПометкаУдаления() = 1 Тогда
ИначеЕсли СписокНеПроводимыхДокументов.НайтиЗначение(Док.Вид()) = 0 Тогда
  Сообщить("Проведение "+Док);
  Если МонопольныйРежим() = 1 Тогда
       БИ.Рассчитать(, Док.ТекущийДокумент());
  КонецЕсли;
  Если Док.Провести() = 0 Тогда
       Возврат;
  КонецЕсли;
КонецЕсли;


Интересуют следующие 3 стрики
  Если МонопольныйРежим() = 1 Тогда
       БИ.Рассчитать(, Док.ТекущийДокумент());
  КонецЕсли;

Для чего это? И изменятся ли итоги, если пероепроводить не в монопольном режиме?
 
  Рекламное место пустует
   Warlock
 
1 - 22.06.04 - 08:41
В теории такой командой должно рассчитывать итоги не зависимо от режима. Я так думаю, что в документах тоже где-то есть проверка на монопольный режим, и, в зависимости от проверки, используется или нет переменная БИ...
Хотя все это странно и определенной логики я здесь не вижу...(не исключено, что она есть, надо копать глубже)
   SnarkHunter
 
3 - 22.06.04 - 08:59
Обработка-то что делает?
   Term2
 
4 - 22.06.04 - 09:31
(3) Перепроведение всех документов за указанный период
   Asmodeus
 
5 - 22.06.04 - 10:14
А кстати, в тему...
Я слышал, что одним из возможных решений перепроведения (восстановления последовательности) является создание бота, который будет при отставании ГП от ТА потихоньку перепроводить документы один за другим от ГП до ТА.
Вопрос вот в чем: есть ли здесь какие-то "подводные камни", которые надо учитывать при написании такой программки? И как лучше ее использовать (как новый сеанс некоего пользователя или просто повесить в глобальном модуле на обработку ожидания)?
   mszsuz
 
6 - 22.06.04 - 11:10
(0) Подтягивает итоги на тек. документ, чтобы остатки быстро получать.
(5) Нету смысла восстановления ГП в фоновом режиме в течении рабочего дня. Получишь только доп.нагрузку на сервер при полном отсутствии гарантий того, что граница будет восстановлена и установлена в тот момент когда это потребуется.
   Asmodeus
 
7 - 22.06.04 - 12:04
(6) Оно конечно так. :-(
Смысл есть если рассматривать различные временные отрезки допустимости исправлений. Смотри, документы забиваются, затем исправляются - такова текущая работа и от этого никуда не денешься. Дата исправления (реально) колеблется, если рассматривать график распределения вероятности, с пиками в районе недели-двух назад (от текущего момента) и двумя-тремя последними днями. Проблема обычно в том, что изредка исправляются документы месячной, двухмесячной давности и более (например, остаток на начало года). Если недельные исправления вполне терпимы (например, для того, чтобы получить реальный отчет за прошлый месяц), то более ранние откидывают ГП слишком далеко назад, а каждый раз тратить время на восстановление нецелесообразно. Звучит логично?
   mszsuz
 
8 - 22.06.04 - 12:42
(7) Читал, много думал ...
Но не увидел как это пересекается с (5) и (6), а именно с "роботом по восстановлению ГП".
У нас на предприятии Последовательность восстанавливается ежедневно по ночам в автономном режиме. Два/три месяца, если надо, за ночь успевают перепровестить, соответственно утром ГП практически всегда на ТА.
Единственные случаи когда приходится делать это вручную - перед формированием "Книги покупок", в том случае когда ГП сбивается при внесении "последних штрихов к портрету".
   Asmodeus
 
9 - 22.06.04 - 13:02
(8) *вздохнув*: Согласен, конечно...
А если ночью, при проведении, документ не сможет провестись?


Список тем форума
Рекламное место пустует   Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует