Вход | Регистрация

Информационные технологии ::

Метки:

Помогите, пожалуйста, начинающему....

Я
   Sever
19.12.03 - 12:57
Такая проблема - в Бухгалтерии в справочнике Номенклатура в форме списка ДляПодбора есть Функция ОстатокНаСкладе() - (1).
Мне надо показывать остатки товара по различным 3-м складам. Если я создаю в форме еще 3-и текстовых колонки и добавляю 3-и аналогичные (1)
функции, то на слабой машине, по сети да еще с большим количеством, забитой номенклатуры, - это работает ну очень медленно.
Как мне избежать этого дублежа(триблежа :) )? Присвоить значение по идентификатору текстовой колонки нельзя - она изначально
при вставке недоступна.
 
  Рекламное место пустует
   Sever
1 - 19.12.03 - 13:22
Упс,забыл про тематику как стояло IT - так и ушло.
   Sever
2 - 19.12.03 - 15:09
Ну хоть кто-нибудь, ну хоть что-нибудь :(
   gr13
 
3 - 19.12.03 - 15:17
слушай, что за сеть? какие принтера по сети установлены? установлено ли avp?
   Sever
4 - 19.12.03 - 15:20
Да вопрос не по сети, а по оптимизации кода. Ну извиняюсь еще раз,за не ту тематику.
   gr13
 
5 - 19.12.03 - 15:26
понимаю,если хочешь про оптимизацию кода, приведи участок кода, а сеть немаловажна правильная настройка, у меня ужасно 1с тормозила на 2 IIIпнях соединенных 100 напрямую, из-за подключенного принтера по сети, объясни
   gr13
 
6 - 19.12.03 - 15:27
(5)в смысле двух третьих пнях
   Львенок
 
7 - 19.12.03 - 15:36
На двух третих пня? ;) Одну треть видимо, с..ли! ;)

На самом деле вся идея в том, что по сети гоняются огромные объемы данных, если не используется TS. Лишьнее обращение к справочнику, обычно проявляется нимоверными закачками и дикими тормозами. Либо ставить TS, либо за один проход читать все остатки, и каким-то образом кэшировать их на локальной машине, ну там читать в ТаблицуЗначений при открытии формы, а выводить остатки из нее.
___
Искренне Ваш, Львенок.
___
Искренне Ваш, Львенок.
   ally
 
8 - 19.12.03 - 15:40
(7)  ;-))) Ну что за выражения!
   Sever
9 - 19.12.03 - 15:42
Что такое TS?
   gr13
 
10 - 19.12.03 - 15:43
(7) согласен, но после того как убрал монитор принтера на сетевой машине (был Canon LBP800 or 810 не суть) 1с забегала
 
 
   Sever
11 - 19.12.03 - 16:03
Функция ОстатокНаСкладе(РасчетИзКолонки=1)
--------------------------------------------------------....................
// Здесь идет длинная часть функции по определению счета учета            
   Иначе //Последнее иначе функции
--------------------------------------------------------!Вот здесь вопрос!
--------------------------------------------------------Спр = СоздатьОбъект("Справочник.МестаХранения");
Спр.НайтиПоКоду("00002");
//Скдад1    
Посуда = БухИт.СКД(СчетУчета, "К",, ТекущийЭлемент(),Спр.ТекущийЭлемент());
Спр.НайтиПоКоду("00005");
//Скдад2    
Витрина = БухИт.СКД(СчетУчета, "К",, ТекущийЭлемент(),Спр.ТекущийЭлемент());
Спр.НайтиПоКоду("00006");                                              
//Скдад3    
Резерв = БухИт.СКД(СчетУчета, "К",, ТекущийЭлемент(),Спр.ТекущийЭлемент());
Общийостаток    Остаток = БухИт.СКД(СчетУчета, "К",, ТекущийЭлемент());
--------------------------------------------------------Я хочу написать вот так как есть - все в одной функции, но проблема в том что идентификатору текстовой колонки(Резерв,Посуда,Остаток)
нельзая присвоить значение. Так можно сделать только для реквизита справочника - но мне сказали что хранить остатки в
реквизитах справочника равносильно изпользованию GOTO.
--------------------------------------------------------                КонецЕсли;
           КонецЕсли;
       КонецЕсли;
   КонецЕсли;
   
   Возврат СокрЛ(Формат(Остаток, "Ч15.3."));
   
КонецФункции // ОстатокНаСкладе()
   Sever
12 - 19.12.03 - 16:03
Функция ОстатокНаСкладе(РасчетИзКолонки=1)
--------------------------------------------------------....................
// Здесь идет длинная часть функции по определению счета учета            
   Иначе //Последнее иначе функции
--------------------------------------------------------!Вот здесь вопрос!
--------------------------------------------------------Спр = СоздатьОбъект("Справочник.МестаХранения");
Спр.НайтиПоКоду("00002");
//Скдад1    
Посуда = БухИт.СКД(СчетУчета, "К",, ТекущийЭлемент(),Спр.ТекущийЭлемент());
Спр.НайтиПоКоду("00005");
//Скдад2    
Витрина = БухИт.СКД(СчетУчета, "К",, ТекущийЭлемент(),Спр.ТекущийЭлемент());
Спр.НайтиПоКоду("00006");                                              
//Скдад3    
Резерв = БухИт.СКД(СчетУчета, "К",, ТекущийЭлемент(),Спр.ТекущийЭлемент());
Общийостаток    Остаток = БухИт.СКД(СчетУчета, "К",, ТекущийЭлемент());
--------------------------------------------------------Я хочу написать вот так как есть - все в одной функции, но проблема в том что идентификатору текстовой колонки(Резерв,Посуда,Остаток)
нельзая присвоить значение. Так можно сделать только для реквизита справочника - но мне сказали что хранить остатки в
реквизитах справочника равносильно изпользованию GOTO.
--------------------------------------------------------                КонецЕсли;
           КонецЕсли;
       КонецЕсли;
   КонецЕсли;
   
   Возврат СокрЛ(Формат(Остаток, "Ч15.3."));
   
КонецФункции // ОстатокНаСкладе()
   Sever
13 - 19.12.03 - 16:06
Ой, Дико извиняюсь, похоже решить этот вопрос на форуме  не реально
   gr13
 
14 - 19.12.03 - 16:13
(13)почему?
   Sever
15 - 19.12.03 - 16:14
Ну вишь как некрасиво получается
   Львенок
 
16 - 19.12.03 - 16:29
(9) TS - это Terminal Server. Ставишь терминальный сервер и проблема отпадает. Причем до тех пор пока пользователей не становится человек 15. Потом уже начинает тормозить и TS. Тогда к нему добавляется SQL Server. :)
___
Искренне Ваш, Львенок.


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует