Вход | Регистрация

1С:Предприятие ::

Метки:ТиС

Показать цену в справочнике

Я
   ollleup
 
18.06.04 - 08:37
Ситуация такая. Решил последний релиз торговли переделать чучуть. В ФормеСписка Справочника номенклатуры решил добавить Колонку Цена. поскольку она у нас всего одна - ЦенаРеализации. Короче надо чтобы она отображаласть в ФормеСписка Справочника Номенклатура. Как сделать то? Нижеследущая фигня почему то не работает...
Функция ФЦена()
  Период=СоздатьОбъект("Периодический"); 
  Спр=СоздатьОбъект("Справочник.Цены");
  ТекНоменклатура = ТекущийЭлемент();
    Спр.ИспользоватьВладельца(ТекНоменклатура);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 цикл
    Если Строка(Спр.ТипЦен)="ЦенаРеализации" Тогда
    Период.ИспользоватьОбъект("Цена",Спр.ТекущийЭлемент());
    Период.ВыбратьЗначения(,ТекущееВремя());
    Пока Период.ПолучитьЗначение()=1 цикл
    Ц=Период.Значение;
    КонецЦикла;    
    КонецЕсли;
    КонецЦикла;
    Возврат Ц;         
КонецФункции
 
  Рекламное место пустует
   shura
 
1 - 18.06.04 - 08:52
Во первых почитай про ТекущееВремя().
Во вторых попробуй так:
//   Период.ИспользоватьОбъект("Цена",Спр.ТекущийЭлемент()); 

//   Период.ВыбратьЗначения(,ТекущееВремя()); 
//   Пока Период.ПолучитьЗначение()=1 цикл 

//   Ц=Период.Значение; 
//   КонецЦикла;    

Цена.Получить(ТекущаяДата());
Прервать;


Список тем форума
Рекламное место пустует   Рекламное место пустует
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует