Вход | Регистрация

1С:Предприятие ::

Метки:дата и время

Установить время документу

Я
   Кирил
17.06.04 - 14:10
Можно ли при записи нового документа установить "своё" время?
 
  Рекламное место пустует
   gr13
 
1 - 17.06.04 - 14:14
да...
   It is me
 
2 - 17.06.04 - 14:17
АвтоВремяОтключить();
Синтаксис:
АвтоВремяОтключить()
Назначение:
Отключить режим автоматической установки времени для новых документов, при этом новые документы заносятся с временем, устанавливаемым при помощи метода УстановитьВремя.
Замечание:
Для новых документов в модуле формы доступно использование методов установки признака автоформирования времени документа и собственно установки времени. Если эти методы использованы, то диалог запроса времени не вызывается и игнорируются пользовательские установки в параметрах системы.
   Кирил
3 - 17.06.04 - 14:55
УстановитьВремя(,,) Метод  можно использовать только для объектов, созданных функцией СоздатьОбъект.
   Кирил
4 - 17.06.04 - 15:19
(1), (2), так можно установить "своё" время при записи нового документа?
   Gavrila
 
5 - 17.06.04 - 15:23
(4)програмно или интерактивно?
   gr13
 
6 - 17.06.04 - 15:24
(4) читай 1
   Кирил
7 - 17.06.04 - 15:29
gr13, можно полететь на марс. ответ да. При записи нового документа нужно, чтоб время у него было 18:01:01. Запись времени програмно, без опроса пользователя. Метод АвтоВремяОтключить() понятно, как теперь присвоить своё время? Метод УстановитьВремя(,,) не подходит!
   Кирил
8 - 17.06.04 - 15:30
При записи нового документа нужно, чтоб время у него было 18:01:01. Запись времени програмно, без опроса пользователя. Метод АвтоВремяОтключить() понятно, как теперь присвоить своё время? Метод УстановитьВремя(,,) не подходит!
(1) тогда вопрос 2, например?
   lexa
 
9 - 17.06.04 - 15:32
УстановитьВремя(<Часы>, <Минуты>, <Секунды>)
   Кирил
10 - 17.06.04 - 15:36
Повторю. УстановитьВремя(,,) Метод  можно использовать только для объектов, созданных функцией СоздатьОбъект. Мне нужно записать время в модуле формы!!!
Это, наверное, невозможно :(.
 
  Рекламное место пустует
   Valery
 
11 - 17.06.04 - 15:54
Ну в модуле формы эту функцию можно использовать.
Значит выход есть.
   It is me
 
12 - 17.06.04 - 15:58
АвтоВремяОтключить();
    Если выбран()=0 Тогда
        УстановитьВремя(18,1,1);
    КонецЕсли;

Проверял только что, все прекрасно работает
   Кирил
13 - 17.06.04 - 17:52
(12) Как только я ставлю УстановитьВремя(18,1,1), ошибка "Недопустимая операция".
Пробовал и в модуле формы, и в модуле документа. Не могу понять в чём дело...
   Press
14 - 17.06.04 - 17:57
УстановитьВремя(<?>,,);
Синтаксис:
УстановитьВремя(<Часы>,<Минуты>,<Секунды>)
.....................................
(!)Метод  можно использовать только для объектов, созданных функцией СоздатьОбъект.
   It is me
 
15 - 17.06.04 - 18:19
Ты условие Если Выбран()=0 Тогда видишь или нет? Работать будет только для новых документов, при перезаписи старых ошибка будет
//

Процедура ПриЗаписи()
АвтоВремяОтключить();
  Если выбран()=0 Тогда
    УстановитьВремя(18,1,1);
  КонецЕсли;
КонецПроцедуры
   Press
16 - 17.06.04 - 19:02
Да, иногда ветки полезно читать не только с последнего поста...(это я себе)
   Кирил
17 - 18.06.04 - 09:09
It is me, большое спасибо! Всё заработало!!! Я протупил, что нужно вызывать метод  
УстановитьВремя, только для новых документов.


Список тем форума
Рекламное место пустует   Рекламное место пустует
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует