Вход | Регистрация

1С:Предприятие ::

Метки:дата и время

Установить время документу

Я
   Кирил
17.06.04 - 14:10
Можно ли при записи нового документа установить "своё" время?
 
  Рекламное место пустует
   It is me
 
2 - 17.06.04 - 14:17
АвтоВремяОтключить();
Синтаксис:
АвтоВремяОтключить()
Назначение:
Отключить режим автоматической установки времени для новых документов, при этом новые документы заносятся с временем, устанавливаемым при помощи метода УстановитьВремя.
Замечание:
Для новых документов в модуле формы доступно использование методов установки признака автоформирования времени документа и собственно установки времени. Если эти методы использованы, то диалог запроса времени не вызывается и игнорируются пользовательские установки в параметрах системы.
   Кирил
3 - 17.06.04 - 14:55
УстановитьВремя(,,) Метод  можно использовать только для объектов, созданных функцией СоздатьОбъект.
   lexa
 
9 - 17.06.04 - 15:32
УстановитьВремя(<Часы>, <Минуты>, <Секунды>)
   Кирил
10 - 17.06.04 - 15:36
Повторю. УстановитьВремя(,,) Метод  можно использовать только для объектов, созданных функцией СоздатьОбъект. Мне нужно записать время в модуле формы!!!
Это, наверное, невозможно :(.
 
  Рекламное место пустует
   It is me
 
12 - 17.06.04 - 15:58
АвтоВремяОтключить();
    Если выбран()=0 Тогда
        УстановитьВремя(18,1,1);
    КонецЕсли;

Проверял только что, все прекрасно работает
   It is me
 
15 - 17.06.04 - 18:19
Ты условие Если Выбран()=0 Тогда видишь или нет? Работать будет только для новых документов, при перезаписи старых ошибка будет
//

Процедура ПриЗаписи()
АвтоВремяОтключить();
  Если выбран()=0 Тогда
    УстановитьВремя(18,1,1);
  КонецЕсли;
КонецПроцедуры


Список тем форума
Рекламное место пустует   Рекламное место пустует
Компьютеры — это как велосипед. Только для нашего сознания. Стив Джобс
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует