Вход | Регистрация

1С:Предприятие ::

Метки:отчеты

не открывается документ из отчета

Я
   Чайник 1с
17.06.04 - 11:47
//*******************************************

Процедура Сформировать()   
    
            
      Перем Запрос, ТекстЗапроса, Таб;
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =  
        "//{{ЗАПРОС(Сформировать)

    |Период с ВыбНачПериода по ВыбКонПериода;
    |ТекущийДокументЗапроса = Документ.ПоступлениеТМЦ.ТекущийДокумент;
    |Поставщик = Документ.ПоступлениеТМЦ.Контрагент;   
    |Группировка ТекущийДокументЗапроса; 
    |Условие(Поставщик = ВыбПоставщик);
    |"

    ;
    
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
                    
        Докты = СоздатьОбъект("Документ");  
                 
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Заголовок");    
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 1, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл 
       //ВыбратьПодчиненныеДокументы(,,Запрос.ТекущийДокументЗапроса); 

        Расшифровка=Запрос.ТекущийДокументЗапроса; 

            
        Таб.ВывестиСекцию("ТекущийДокумент|ОсновнойДок"); 
        
        Докты.ВыбратьПодчиненныеДокументы(,,Запрос.ТекущийДокументЗапроса); 
        Пока Докты.ПолучитьДокумент()<>0 Цикл   
       //    Докты.ТекущийДокумент();          

        Если  Докты.ТекущийДокумент().Вид()="ПоступлениеДопРасходы" тогда
            Таб.ПрисоединитьСекцию("ТекущийДокумент|ПодчДок"); 
        КонецЕсли;
            
        КонецЦикла;    
        
        
    КонецЦикла;      
     
    
        
    
    Таб.Опции(1,1,0,0);
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");            
    
КонецПроцедуры  

//*******************************************************

  Процедура ОбработкаЯчейкиТаблицы(Расшифровка,1)  
      ???????????    
  КонецПроцедуры
//******************************************************    

не могу написать обработку ячейки таблицы
(только не стебаться - я 2 дня 1с изучаю)
 
  Рекламное место пустует
   Чайник 1с
1 - 17.06.04 - 11:51
+ как развернуть и подчиненные а не только текущие запроса?

заранее биг сенькьсь
   HideMan
 
2 - 17.06.04 - 11:52
В чем проблемы?
   AlexMan
 
3 - 17.06.04 - 11:53
Ничего себе 2 дня изучает а уже запросы пишет , так держать!
   SnarkHunter
 
4 - 17.06.04 - 12:05
(3)Он их не пишет, а конструирует...
   HideMan
 
5 - 17.06.04 - 12:10
Процедура ОбработкаЯчейкиТаблицы работает? В отладчике проверял Расшифровка?
   Чайник 1с
6 - 17.06.04 - 12:31
Это у меня таблица

    ТМЦ с [ВыбНачПериода] по [ВыбКонПериода]                                
                                    
    Поставщик : [ВыбПоставщик]                                
                                    
    Запрос.ТекущийДокументЗапроса            Докты.ТекущийДокумент()                    
                
а вот так он ругается
Процедура ОбработкаЯчейкиТаблицы(Расшифровка,<<?>>1)
.............Ожидается имя формального параметра
Процедура ОбработкаЯчейкиТаблицы(Расшифровка,1)<<?>>
............Обнаружено логическое завершение исходного текста модуля

а в свойствах выражений Запрос.ТекущийДокументЗапроса    ,Докты.ТекущийДокумент()    
указалА(это я к теме личности) в расшифровке -  #расшифровка
   HideMan
 
7 - 17.06.04 - 12:58
А пробовал 
Процедура ОбработкаЯчейкиТаблицы(Расшифровка,пар,Таб)
//пар=1;возврат;//стандартная обработка

//прочая всякая хрень
КонецПроцедуры
   romix
 
8 - 17.06.04 - 13:25
В поле Расшифровка в свойстваъ ячейки отчета не забыл написать слово Расшифровка?

Режим стоит редактирования или запрета редактирования? (надо - последнее)
   Чайник 1с
9 - 17.06.04 - 13:28
to HideMan
не идеть...
   Чайник 1с
10 - 17.06.04 - 13:29
первое сделала
а
*Режим стоит редактирования или запрета редактирования? (надо - последнее)*
не понятно - я чайник
 
 
   Чайник 1с
11 - 17.06.04 - 13:29
//прочая всякая хрень 
??
   romix
 
12 - 17.06.04 - 13:33
(10) Поставь
    Таб.ТолькоПросмотр(1);
Или сделай вручную в меню Вид-Только Просмотр.
   AlexP
13 - 17.06.04 - 13:38
(0) Попробуй в свойствах ячейки, в поле "расшифровка" написать - ТекущийДокументЗапроса , а Процедуру ОбработкаЯчейкиТаблицы() закомментируй.
   Чайник 1с
14 - 17.06.04 - 13:39
*Таб.ТолькоПросмотр(1); *
у меня так и стоит
   Чайник 1с
15 - 17.06.04 - 14:02
Спасибо всем!!!!
Заработало!!!
   Чайник 1с
16 - 17.06.04 - 17:01
в продолжение темы
Почему, если
Процедура ОбработкаЯчейкиТаблицы(Расшифровка,Г,Таб) 
    Г=1;
    Возврат;
КонецПроцедуры    

то все работает..

а если
Процедура ОбработкаЯчейкиТаблицы(Расшифровка,1,Таб) 
    
КонецПроцедуры    

то грязно ругается...

а если

Процедура ОбработкаЯчейкиТаблицы(Расшифровка,Г=1,Таб) 
    
КонецПроцедуры    


не ругается но и не выполняет?

С уважением Чайник 1С
   Чайник 1с
17 - 17.06.04 - 17:02
в продолжение темы
Почему, если
Процедура ОбработкаЯчейкиТаблицы(Расшифровка,Г,Таб) 
    Г=1;
    Возврат;
КонецПроцедуры    

то все работает..

а если
Процедура ОбработкаЯчейкиТаблицы(Расшифровка,1,Таб) 
    
КонецПроцедуры    

то грязно ругается...

а если

Процедура ОбработкаЯчейкиТаблицы(Расшифровка,Г=1,Таб) 
    
КонецПроцедуры    


не ругается но и не выполняет?

С уважением Чайник 1С


Список тем форума
Рекламное место пустует  
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует