Вход | Регистрация


1С:Предприятие ::

Метки:отчеты

Как получить текст расшифровки в таблице отчета.

Я
   sheale
 
16.06.04 - 16:40
Как получить текст расшифровки в таблице отчета. Т.е. тот текст, который написан в свойствах ячейки в поле расшифровка?
 
 
   sheale
 
2 - 16.06.04 - 17:07
По этому тексту можно обращаться именно к нужной ячейки, отсеивая ненужные (в столбце или строке).
   sheale
 
4 - 16.06.04 - 17:14
Для н=4 по Таб.ВысотаТаблицы() цикл
// тут я проверяю на пустую строку (выкрутился), но в этом столбце может быть не пустое значение расштфровки.
Если ПустаяСтрока(Таб.Область("R"+н+"C9").Расшифровка())=1 Тогда -- здесь
Колич = Число(Таб.Область("R"+н+"C9").Текст);
Тз.НоваяСтрока();
Тз.Количество         =   Колич;
Тз.Номенклатура     =    Таб.Область("R"+н+"C4").Расшифровка(); 
Тз.ПоСчету             =    Таб.Область("R"+н+"C6").Расшифровка();
з.ПоЗаявке         =   Тз.ПоСчету.ДокОснование;
Тз.ЗаявкаБМ         =    Таб.Область("R"+н+"C8").Расшифровка();
КонецЕсли;
КонецЦикла;
   Рупор абсурда
 
6 - 16.06.04 - 17:24
Проверяй ЗНАЧЕНИЕ рсшифровки на пустое ЗНАЧЕНИЕ, а не на пустую строку ...
   Рупор абсурда
 
10 - 16.06.04 - 17:30
(7) Нуууу, к примеру, если ты в функцию ПустаяСтрока() подставишь элемент справочника с наименованием "" и представлением в виде наименования, она вернёт 1 ...
 
  Рекламное место пустует
   LOSS
 
12 - 16.06.04 - 17:34
ПустаяСтрока
Проверить строку на наличие значащих символов.

Синтаксис:

ПустаяСтрока(<Строка>)




Англоязычный синоним:

IsBlankString

Параметры:

<Строка>
Строковое выражение.


Возвращаемое значение:

Числовое значение. 1 — пустая строка или только пробелы. 0 — не пустая строка.

Описание:

Функция ПустаяСтрока проверяет переданный параметр <Строка> на наличие значащих символов (любых кроме пробелов) и возвращает число 1, если строка пустая или содержит только пробелы, 0 , если строка не пустая.

Пример:

Если ПустаяСтрока(Буфер) = 1 Тогда
  // если Буфер содержит только пробелы, то его удаляем


   Буфер = "";

КонецЕсли;


А вот значение


ПустоеЗначение
Проверить значение любого типа.

Синтаксис:

ПустоеЗначение(<3начение>)

Англоязычный синоним:

Empty Value

Параметры:

<3начение>                Выражение любого типа данных, значение которого про­веряется на «пустое».

Возвращаемое значение:

Функция возвращает числовое значение: 1 — значение пустое; 0 — значение не пустое.

Описание:

Функция ПустоеЗначение определяет, является ли пустым переданное в параметре значение. При этом применяется следующее правило:

-             значение неопределенного типа — всегда пустое;

-             значение типа «строка» проверяется как в методе ПустаяСтрока;

-             значение типа «число» проверяется на равенство нулю;

-             значение типа «дата» проверяется на пустое значение;

-             значения следующих типов: «справочник», «перечисление», «документ», «счет», «вид субконто», «план счетов», «календарь» проверяются как в методах Выбран для соответствующего типа объекта.

Пример:

Если ПустоеЗначение(Код) = 1 Тогда
   Предупреждение("Задайте непустое значение Кода !!!");

КонецЕсли;
   romix
 
19 - 17.06.04 - 14:01
(15) Есть такая функция - Расшифровка()
Может она вернет этот текст - если хочешь, попробуй...
А вообще, чтобы однозначно идентифицировать ячейку, я всегда использую такой трюк:

п=СоздатьОбъект("СписокЗначений");
п.ДобавитьЗначение("Какой-то идентификатор");
п.ДобавитьЗначение(док);
Расшифровка=п;

Ну и извлекаю из расшифровки тоже список значений, и из него беру, что мне надо
(ПолучитьЗначение()



Список тем форума
Рекламное место пустует   Рекламное место пустует
2 + 2 = 3.9999999999999999999999999999999...
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует