Вход | Регистрация

1С:Предприятие ::

Метки:

РАсшифровка ячейки

Я
   Shadow
 
18.12.03 - 09:03
вот вставил я в расшифровку переменную,
а переменную определяю как а=Запрос.ТекущийДокумент.
т.е. я эту переменную определяю перед выводом секции с той ячейкой,
по которой кликанье происходит.
НО! В ячейке у меня считается Расход(ОстатокТовара), т.е. при клике на ячейке открывается последняя накладная (например в ячейке число 4 , по расх.накл№1 -1шт,расх.накл№2 -2шт,расх.накл№3 -1шт) - открывается последняя расх№3, можно ли как нить сделать чтоб открывался выбор из всех возможных расх.накл. ???
PS.Остаток товара в запросе определяется так
|ОстатокТовара=Регистр.ОстаткиТовара.ОстатокТовара.
а числов ячейке так - Cумма=Расход(ОстатокТовара).
Т.е. вроде бы без переделки запроса нельзя сделать, чтоб открылась форма с нужными документами ???
 
 
   dimsonn
1 - 21.12.03 - 00:53
Процедура Сформировать()
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)

    |Период с НачДата;
    |Товар = Регистр.ТоварыНаСкладе.Товар;
    |Количество=Регистр.ТоварыНаСкладе.Количество;
    |ТекущийДокумент = Регистр.ТоварыНаСкладе.ТекущийДокумент;
    |Функция КоличествоРасход = Расход(Количество);
    |Группировка Товар;
    |Группировка ТекущийДокумент;
    |//}}ЗАПРОС

    ;
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    Таб.ВывестиСекцию("Заголовок");
    Пока Запрос.Группировка(1) = 1 Цикл
        спДоков=СоздатьОбъект("СписокЗначений");
        Пока Запрос.Группировка(2) = 1 Цикл
            спДоков.ДобавитьЗначение(Запрос.ТекущийДокумент);
        КонецЦикла;
       // в свойствах ячейки в поле "Расшифровка" пишешь: спДоков

        Таб.ВывестиСекцию("Товар");
    КонецЦикла;
    Таб.ВывестиСекцию("Итого");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры

Процедура ОбработкаЯчейкиТаблицы(ЗначРасш,ФлагСтандОбраб)
    ЗначРасш.ВыбратьЗначение(ЗначРасш,,,,2);
    ФлагСтандОбраб=1;
КонецПроцедуры
   dimsonn
2 - 21.12.03 - 07:28
// Другой вариант


Перем Запрос;

Процедура Сформировать()
    
   // Запрос тот же самый

    
   // Обработка результатов запроса

    Пока Запрос.Группировка(1) = 1 Цикл
       // в свойствах ячейки в поле "Расшифровка" пишешь: Запрос.Товар

        Таб.ВывестиСекцию("Товар");
    КонецЦикла;
    
   // и т.д.

КонецПроцедуры

Процедура ОбработкаЯчейкиТаблицы(ЗначРасш,ФлагСтандОбраб)
    Запрос.ВНачалоВыборки();
    Запрос.Получить(ЗначРасш,);
    спДоков=СоздатьОбъект("СписокЗначений");
    Пока Запрос.Группировка(2) = 1 Цикл
        спДоков.ДобавитьЗначение(Запрос.ТекущийДокумент);
    КонецЦикла;
    спДоков.ВыбратьЗначение(ЗначРасш,,,,2);
    ФлагСтандОбраб=1;
КонецПроцедуры


Список тем форума
  Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует