Вход | Регистрация

1С:Предприятие ::

Метки:справочники

ПометкаУдаления()=0

Я
   Sh_s
 
15.06.04 - 15:29
Функция ПровНаОдинКодВПодгр(Код,Род);
    Спр=СоздатьОбъект("Справочник.КодыПоставщики");
    
    Спр.ИспользоватьРодителя(род);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
        Если Спр.ЭтоГруппа()=0 Тогда    
            Если (Спр.Товар<>Товар) и (Спр.КодПост=Код) Тогда
----------- Вот здесь всегда = 0 ---->    Если Спр.Товар.ПометкаУдаления()=0 Тогда
                    Предупреждение("Проверте код."+LineBreak+
                    "Уже используется в "+Спр.Наименование);    
                    Возврат(0);
                КонецЕсли; 
            КонецЕсли; 
        КонецЕсли; 
    КонецЦикла;
КонецФункции 

Как поняли - функция проверяет на одинак. код в подгруппе (род).
Да вот только проверка на помеченность, на удаление - дает сбой ( Если Спр.ПометкаУдаления()=0 Тогда), тут почему-то  всегда ноль, хотя спецально метил на удаление.
Справочник.КодыПоставщики - не подчиненый.

Кто, что знаить, по ентому поводу !?
 
  Рекламное место пустует
   iceTiger
 
1 - 15.06.04 - 15:57
Спр.Товар ?
Просто Спр.ПометкаУдаления()
   Sh_s
 
2 - 15.06.04 - 16:41
Пробовал не катит.
Были мысли про алгоритм, может он где то не там смотрит, но по логике вроде все ок.
Поэтому и запарился искать сам. Думал может свежий взгляд поможет.
   Sh_s
 
3 - 16.06.04 - 10:21
Может тогда объясните смысл этого форума !!!

Если такие вопросы не решаемы,
то за что тут звездами раскидываются. (риторика).
   Killgur
 
4 - 16.06.04 - 10:39
А ты уверен, что помеченные на удаление выводятся?
   SnarkHunter
 
5 - 16.06.04 - 10:43
(3)У тебя в справочнике КодыПоставщики имеется реквизит Товар? Какого типа?
   ws_mason
 
6 - 16.06.04 - 10:47
ПометкаУдаления()
Синтаксис:
ПометкаУдаления()
Назначение:
Прочитать флаг пометки удаления элемента справочника.
Возвращает: 1 - если на элементе справочника стоит пометка удаления; 0 - иначе.
Замечание:
Метод  можно использовать только для объектов, созданных функцией СоздатьОбъект.
   Sh_s
 
7 - 17.06.04 - 15:53
Спасибо всем.

(6) Хелп я умею читать и сам.

Тема Закрыта.
   Frol
 
8 - 17.06.04 - 16:36
В первых: зачем ты проверяешь пометку на удаление? Если код не уникален, то какая разница, помечен элемент на удаление или нет...
а во вторых, если Товар - это элемент справочника, то твоя строчка проверяет пометку не в справочнике \"КодыПоставщиков\", а в справочнике \"Товары\".
Правильным будет , всётаки:
Если Спр.ПометкаУдаления() = 0


Список тем форума
Рекламное место пустует   Рекламное место пустует
2 + 2 = 3.9999999999999999999999999999999...
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует