Вход | Регистрация

1С:Предприятие ::

Метки:документы

Непосредственное удаление документов!

Я
   wind_wail
15.06.04 - 14:22
Задача: сделать так, чтобы документ удалялся сразу из журнала документов без поментки на удаление. Нажал Del и документа нет.

Пробовал это сделать через предопределенную функцию глобального модуля:
1. Попытка сделать след образом:
Процедура ПриУдаленииДокумента(Докум,Режим)
   Если (Докум.Вид()="ДокПоОтработаннымЧасам") тогда
      Докум.Удалить(1);
   КонецЕсли;
КонецПроцедуры

Результат:
Докум.Удалить(1);
{Глобальный модуль(5889)}: Не выбран документ!

Интересно как же это он может быть невыбран если условие Докум.Вид() успешно проходится. Ладно, читаю инструкцию, там написано что Удалить() можно применять только к объектам созданным с помощью СоздатьОбъект. Делаю след образом:
2. След попытка:
Процедура ПриУдаленииДокумента(Докум,Режим)
   Если (Докум.Вид()="ДокПоОтработаннымЧасам") тогда
  //Докум.Удалить(1);

      МойДок = СоздатьОбъект("Документ");
      Если МойДок.НайтиДокумент(Докум)=1 тогда 
         МойДок.Удалить(1);
      КонецЕсли;
      Сообщить(Докум);
   КонецЕсли;
КонецПроцедуры

Результат:
МойДок.Удалить(0);
{Глобальный модуль(5892)}: Объект заблокирован: ЕДокПоОтработаннымЧасам ГЗ-0000001

Что ему теперь то не нравится?
Кто сталкивался с подобной проблемой помогите пожалуста!
Заранее признателен.
 
  Рекламное место пустует
   iceTiger
 
1 - 15.06.04 - 14:35
Блокировка. 1С уже его удаляет, а ты его еще раз хочешь удалить...
Сделай обработкой. Повесь на форму кнопку: "Удалить на века...", в нее передавай параметром текущий документ и сноси на здоровье... Только если этот док. уже где-то выбран - полезут бока...
   Press
3 - 15.06.04 - 14:49
А как насчет галочки в конфигураторе?
   wind_wail
4 - 15.06.04 - 14:53
(3) Если ты имеешь ввиду "Разрешить непосредственное удаление объектов",то она стоит.
(1) А как вызвать обратоку так, чтобы ее форма не открывалась ? или это нельзя сделать?
   AlexMan
 
5 - 15.06.04 - 14:54
ОткрытьФормуМодально()
   Рупор абсурда
 
6 - 15.06.04 - 14:55
Используй свой 2 вариант, только в  добавь СтатусВозврата(0) ...
   Press
7 - 15.06.04 - 14:56
И Сервис=>Параметры - Непосредственное удаление, тоже стоит?
   iceTiger
 
8 - 15.06.04 - 15:51
(6) Просвети причем тут СтатусВозврата()... ;)
(7) Пимпочка не влияет на удаления в журналах, она лишь разрешает сносить связанные и помеченные на удаление объекты...
   wind_wail
9 - 15.06.04 - 15:51
(6) Не помогло. Все то же самое.
(7) Эммм... не понимаю о чем ты, там нету такого.
(5) Спасибо. Но я наверно пойду другим путем. Попробую использовать процедуру ОбработкаОжидания :)
   Press
10 - 15.06.04 - 16:58
(9)Сервис=>Параметры=>Общие - Режим удаления объектов (последняя строчка)
(8)Не понял на что там, эта пимпочка влияет, но условиям "зачачи" (0) она
удовлетворяет.
 
 
   Орк
 
11 - 15.06.04 - 20:36
Процедура глобального модуля ПриУдаленииДокумента() вызывается
перед удалением документа и на время выполнения ее тела документ
блокируется. Т. е. к самому удалению не имеет никакго отношения.
Чтобы удалить документ из формы журнала нужно в форме повесить
кнопочку с вызовом примерно такой процедуры

Процедура УдалитьЗаявку()
    Док=СоздатьОбъект("Документ");
    Док.НайтиДокумент(ТекущийДокумент);
    Док.Удалить(1);
КонецПроцедуры


Список тем форума
Рекламное место пустует   Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует