Вход | Регистрация

1С:Предприятие ::

Метки:справочники

создание справочника

Я
   Владимир
14.06.04 - 22:53
Как создать справочник на основе таблицы Ексел?
По-моему, где-то видел такую обработку... Подскажите, кто знает, пожалуйста!
 
  Рекламное место пустует
   Череп
 
1 - 14.06.04 - 22:56
существует много других более удобных методов. А про такой я даже не слышал...
   Владимир
2 - 14.06.04 - 22:57
Мильпардон, в СЕМЕРКЕ.
   Владимир
3 - 14.06.04 - 23:01
(2) Каких? В ШЕСТЕРКЕ готовится специального текстового формата файл и заранее готовятся поля. Но то в шестерке, это было давно.А надо в семерке совсем новый справочник из 6000 записей(объектов) создать. Есть таблица Ексель...
   BorisG
 
4 - 14.06.04 - 23:35
(3) На hippo есть несколько разработок.
Например:
Перенос данных 6.0
Экспорт/импорт справочников в/из Excel
Импорта справочников из текстовых файлов с разделителями, DBF- и EXCEL-таблиц
   CYuri
5 - 14.06.04 - 23:49
Блин работа нескольких минут.
Сохрани из Excel в ДБФ.
И сделай обработку на 1С загрузки ДБФ в справочник.
Вещь простейшая. И практика щёлкания по клавишам увеличевается! ;-)
   Владимир
6 - 15.06.04 - 08:43
(4) Что такое hippo? и где его искать.
(5) То, что для кого-то работа нескольких минут, таким чайникам как я - вовсе нет... КАК сделать обработку?
   427
 
7 - 15.06.04 - 08:58
Хиппо - это такой отстойник, где при наличии некоторого количества знаний и мозгов дают много и на халяву...

Однако судя по (6) - знаний пока не хватает...
   СYuri
8 - 15.06.04 - 08:59
http://www.mista.ru/tutor_1c/dbf.htm#read - работа с дбф
http://www.mista.ru/tutor_1c/sprav.htm#new_elem - ну и со правочником.
   Eiena
9 - 15.06.04 - 08:59
Hippo - это Клуб Профессионалов 1С. Адрес http://www.1c.hippo.ru. Удачи.
   CYuri
10 - 15.06.04 - 09:03
Спр = СоздатьОбъект("Справочник.ТвойСправочник");
Файл = создатьОбъект("XBASE");//создаем ссылку на файл DBF

Файл.ОткрытьФайл("твойфайл.dbf");//открываем файл на диске 

Файл.КодоваяСтраница(1);//задаем кодировку: 0 - windows, 1 - DOS 


Если Файл.Открыта()=0 Тогда//проверяем, удалось ли открыть файл

Сообщить("Не удалось открыть файл!");
КонецЕсли; 

Файл.Первая();//позиционируемся на первой записи

Пока Файл.ВКонце()=0 Цикл//пока не дошли до конца, крутим цикл

.......НомерЗаписи = Файл.НомерЗаписи();//получаем номер текущей записи 

.......НазвТовара = Файл.NAME;//получаем значение поля

.......Цена = Файл.ПолучитьЗначениеПоля("PRICE");//так тоже можно, но чуть медленнее

.......Файл.Следующая();//переходим на следующую запись

КонецЦикла;
 
  Рекламное место пустует
   CYuri
11 - 15.06.04 - 09:08
Спр = СоздатьОбъект("Справочник.ТвойСправочник"); 
Файл = создатьОбъект("XBASE");//создаем ссылку на файл DBF 

Файл.ОткрытьФайл("твойфайл.dbf");//открываем файл на диске 

Файл.КодоваяСтраница(1);//задаем кодировку: 0 - windows, 1 - DOS 


Если Файл.Открыта()=0 Тогда//проверяем, удалось ли открыть файл 

Сообщить("Не удалось открыть файл!"); 
КонецЕсли; 

Файл.Первая();//позиционируемся на первой записи 

Пока Файл.ВКонце()=0 Цикл//пока не дошли до конца, крутим цикл 


Спр.Новый();
Спр.Реквизит=Число(Файл.Поле);//  если число или Строка(Файл.Поле)

//если елемент справочника то посложнее

Файл.Следующая();//переходим на следующую запись 

СпрСотр.Записать(); 

КонецЦикла;
   Владимир
12 - 17.06.04 - 07:54
Форум есть форум, конечно. Всякие люди сюда приходят...
Очень сильно благодарен Вам, уважаемый CYuri !
   427
 
13 - 17.06.04 - 07:59
Уважаемый CYuri ....

Судя по вопросу (0) и последующим, ваш текст поможет вопрошающему ненамного больше, чем зайцу стоп сигнал....
   Warlock
 
14 - 17.06.04 - 08:23
А вот загрузка сразу из Ехсеl'я:

Спр = СоздатьОбъект("Справочник.НужныйСправочник");
Ехсеl = СоздатьОбъект("Excel.Application");
Ехсеl.Visible = 1;
Ехсеl.Workbooks.Open(СокрЛП(ИмяФайла));
ТекРяд = 2//Строка в Ехсеl'е, с которой начинаются данные

Пока СокрЛП(Ехсеl.Worksheets(1).Cells(ТекРяд,1).Value) <> "" Цикл
//В колонке 1 Ехсеl'я значение обязательно не пустое для каждой записи

//или можно задать конкретное число строк
    Код = Число(Ехсеl.Worksheets(1).Cells(ТекРяд,1).Value);
    Наименование = СокрЛП(Ехсеl.Worksheets(1).Cells(ТекРяд,2).Value);
    Спр.Новый();
    Спр.Код = Код;
    Спр.Наименование = Наименование;
    Спр.Записать();
    Состояние("Обработано "+ТекРяд+" строку");
КонецЦикла;


Список тем форума
Рекламное место пустует  
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует