Вход | Регистрация

1С:Предприятие ::

Метки:

Как программно подсчитать кол-во месяцев использования ТМЦ

Я
   Forgesemi
 
18.12.03 - 08:30
Народ,всем привет!
Будьте добры подскажите как
получить кол-во месяцев типа число програмно в 1С
за определённый период(вроде не сложно,но нет времени
на пробы,прощупывание и экспиерименты).
Всем спасибо за внимание и помощь.
Привет Волшебнику. Давно собирался здесь оказаться.
 
  Рекламное место пустует
   Львенок
 
1 - 18.12.03 - 09:45
Т.е. кол-во месяцев между двумя датами? Думаю, что-то вроде:
МесяцевМежду=ДатаГод(Дата2)*12+ДатаМесяц(Дата2)-ДатаГод(Дата1)*12-ДатаМесяц(Дата1)

Не проверял, правда. Но дуамю, что именно так.
___
Искренне Ваш, Львенок.
   Forgesemi
 
2 - 18.12.03 - 12:41
Львенок Спасибо, попробую.
Сергей
   Forgesemi
 
3 - 19.12.03 - 03:52
Выражение не правильно, но направление то.
А вот вчера понапрягался и проверил в работе

Вот мое решение:
----------
Функция КоличествоПолныхМесяцев(НачДата,КонДата)
   Перем Мес;
   Перем Дат;
   Мес = 0; 
   
     Если НачДата > КонДата Тогда
      Сообщить(" Начальная дата больше конечной - ничего невыйдет ! ");
      Возврат 0;
     КонецЕсли; 
    
       Дат = НачДата;
       Пока  Дат < КонДата    Цикл
        Мес = Мес+1;    
        Дат = ДобавитьМесяц(НачДата,Мес);
       КонецЦикла;    
       
         Н = ДатаЧисло(НачДата);
         К = ДатаЧисло(КонДата);
           Если (Н < К) или (Н = К) Тогда
            Мес = Мес - 1;Иначе
               Мес = Мес - 2;
              КонецЕсли;
    
   Возврат(Мес);    
КонецФункции
   Львенок
 
4 - 19.12.03 - 07:47
Какой кошмар! Делать в цикле то, что записывется линейно и делать через "если иначе конецесли" прискоения которые записываеются, да еще с одним условием, а не с двумя: Мес=Мес-?((Н <= К),1,2);
Теперь я знаю, почему некоторые жалуются, что у них конфы тормозят уже при трех пользователях. ;)
___
Искренне Ваш, Львенок.
   ally
 
5 - 19.12.03 - 08:09
Львенок, ну чегож ты такой, ммм......"добрый" то? 8-)))
   Forgesemi
 
6 - 19.12.03 - 09:31
Львенок,иногда мы все делаем то что делаем,
главное личное удобство понимания и скорость и результат,
а насчет экономического програмирования тема отдельная
я не волшебник 1С пока но в стадии пока учусь.
   Forgesemi
 
7 - 19.12.03 - 09:32
Может Львенок ты бы показал что нибудь лучшее


Список тем форума
Рекламное место пустует   Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует