Вход | Регистрация

1С:Предприятие ::

Метки:документы

Получение остатков товаров в документе

Я
   busy1
 
11.06.04 - 13:12
Как мне сделать, что бы в документе Реализация в Табличной части
когда выделяешь товар внизу вместе с коментарием о подробном
описании товара был показан и остаток?
 
  Рекламное место пустует
   Valery
 
1 - 11.06.04 - 13:25
В этом документе есть строка информацияОНоменклатуре в нее и забей остаток.
надо только определится на какую дату будет этот остаток. На дату документа, или рабочую дату, или на текущую.
   Crystalizer
 
2 - 11.06.04 - 13:40
ну типа нужно по регистрам или по счетам посмотреть сколько есть этого товара
   SiMazx
 
3 - 11.06.04 - 13:53
(1) Чего-чего?
   iceTiger
 
4 - 11.06.04 - 14:56
А вообще можно напрячься и в типовых посмотреть...
Там этой байды...
   iceTiger
 
5 - 11.06.04 - 15:00
(+4) Из комплексной к примеру:
// ===============================

Функция КонтрольОстаткаВсего()      
    Если (фВключенаТорговля = Да)    
    И (ЧтоПродаем = Перечисление.ЧтоПродаем.Товары) Тогда
       // Вычислим, сколько всего данного товара

        ПолныйОстаток= Регистр.ОстаткиТоваров.СводныйОстаток(Фирма,ТМЦ,,"ОстатокТовара");
        Резерв= 0;
       // проверяем резерв товара

        Если Константа.РазрешитьПродаватьРезерв=Перечисление.ДаНет.Нет Тогда
           // Вычислим, сколько зарезервировано всего данного товара

            
           //Резерв= Регистр.РезервыТоваров.СводныйОстаток(ТМЦ,,"РезервТовара");                      

            ТабРезерв = СоздатьОбъект("ТаблицаЗначений");
            РегРезерв = СоздатьОбъект("Регистр.РезервыТоваров");            
            РегРезерв.УстановитьЗначениеФильтра("Товар",ТМЦ);
            РегРезерв.ВыгрузитьИтоги(ТабРезерв);
            ТабРезерв.ВыбратьСтроки();
            Пока ТабРезерв.ПолучитьСтроку() = 1 Цикл
                Если ПустоеЗначение(ТабРезерв.ПоСчету) = 0 Тогда
                    Если ТабРезерв.ПоСчету.Фирма = Фирма Тогда
                        Резерв = Резерв + ТабРезерв.РезервТовара;
                    КонецЕсли;    
                КонецЕсли;    
            КонецЦикла;    
        КонецЕсли;
        Если Коэффициент>0 Тогда
            Возврат (ПолныйОстаток-Резерв)/Коэффициент;
        Иначе
            Возврат 0;
        КонецЕсли;
    ИначеЕсли ПустоеЗначение(ТМЦ) = 0 Тогда
        Ост = 0;
        ИтЗапр = СоздатьОбъект("БухгалтерскиеИтоги");
        ИтЗапр.ВключатьСубсчета(1);
        ИтЗапр.ИспользоватьРазделительУчета(Фирма);        
        ИтЗапр.ИспользоватьСубконто(ВидыСубконто.ТМЦ,ТМЦ,1);
        ИтЗапр.ВыполнитьЗапрос(,ДатаДок,,,,,,4);
       // рассчитаем итоги запросом

        Если ИтЗапр.ПолучитьСчет(,ТМЦ.Счет) = 1 Тогда
            Если ИтЗапр.ПолучитьСубконто(1,,ТМЦ) = 1 Тогда
                Ост = ИтЗапр.СКД("К");
            КонецЕсли;
        КонецЕсли;
        Возврат Ост;
    КонецЕсли;    
КонецФункции

Правишь и вешаешь на форму...
   iceTiger
 
6 - 11.06.04 - 15:05
Подробней некуда ;)
   iceTiger
 
7 - 11.06.04 - 15:37
Пыхтиш и никакой благодарности.... "Обыдно слушай" (с) Грузыны
   Композитор
 
8 - 11.06.04 - 15:42
(7) Помогайте чаще. Получите звезду.
   iceTiger
 
9 - 11.06.04 - 15:50
(8) Шо прям как у Бонопарта? А можно деньгами? ;)
   Композитор
 
10 - 11.06.04 - 16:34
(9) Можно. Волшебными рублями.
 
  Рекламное место пустует
   iceTiger
 
11 - 11.06.04 - 16:36
Вот так всегда...


Список тем форума
Рекламное место пустует   Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует