Вход | Регистрация

1С:Предприятие ::

Метки:Бухгалтерия 7.7

Ит.ПолучитьСчет(,СчетКонтрагента) = ?

Я
   Crystalizer
 
11.06.04 - 12:45
фтыкаю в документ...
поясните пжлст смысл этого действия
почему ПолучитьСчет - это отдельный оператор? что за счет получается в результате? можно ж взять счет контрагента из справочника? %/
 
 
   SnarkHunter
 
1 - 11.06.04 - 12:54
СчетКонтрагента - это что?
   SiMazx
 
2 - 11.06.04 - 12:54
ВыбратьСчета перед этим есть? Думай номер своей планеты в тинктуре...
   Crystalizer
 
3 - 11.06.04 - 13:12
SnarkHunter: тип значения = счет.основной
вводится в форме как "счет поставщика"
   Crystalizer
 
4 - 11.06.04 - 13:13
документ = "ПриходнаяНакладная"
   Crystalizer
 
5 - 11.06.04 - 13:21
SiMazx: кстати нет

           .
           ..
           ....
           ......
        Ит.ИспользоватьСубконто(ВидыСубконто.Заказы,СписокЗаказов,2);
        Ит.ВыполнитьЗапрос(ТекущийДокумент(),,СписокСчетов,,,,,3);
    КонецЕсли;

    Если УказанаПредварительнаяОплата = 0 Тогда
        СуммаО = 0;
        Если Ит.ПолучитьСчет(,СчетКонтрагента) = 1 Тогда *****************!!!
            Если Ит.ПолучитьСубконто(1,,Контрагент) = 1 Тогда
                Если Ит.ПолучитьСубконто(2,,ПервыйДок) = 1 Тогда
                    Если Валюта = Гривня Тогда
                        СуммаО = Ит.СНД() - Ит.СНК();
                    Иначе
                        Если Ит.ПолучитьВалюту(,Валюта) = 1 Тогда
                            СуммаО = Ит.СНД("В") - Ит.СНК("В");
                        КонецЕсли;
                    КонецЕсли;
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
   SnarkHunter
 
6 - 11.06.04 - 13:54
ТипЗначенияСтр(СчетКонтрагента) что возвращает?
   Crystalizer
 
7 - 11.06.04 - 14:14
SnarkHunter: а что возможны варианты?
   SnarkHunter
 
8 - 11.06.04 - 14:28
Ты на вопрос можешь ответить... Впрочем, как хочешь... Разбирайся сам...
   Crystalizer
 
9 - 11.06.04 - 14:35
я ж ещё в 3 ответил: "счет"... ?!
   Crystalizer
 
10 - 11.06.04 - 14:45
Счет и выдается....
 
 
   SnarkHunter
 
11 - 11.06.04 - 14:52
Спасибо...
Тогда читай (2)...
   Crystalizer
 
12 - 11.06.04 - 15:00
(5)
   creator
 
13 - 11.06.04 - 16:54
Вначале вызывается Ит.ВыполнитьЗапрос(ТекущийДокумент(),,СписокСчетов,,,,,3) - это означает, что будут получены итоги по счетам, входящим в СписокСчетов, где СписокСчетов - это СписокЗначений или строка счетов.
Очевидно СчетКонтрагента - это счет, который входит в СписокСчетов. Т. е. это один из счетов, по которому будут получены итоги.
Когда вызывается Ит.ПолучитьСчет(,СчетКонтрагента), то бух. итоги будут спозиционированы на счете СчетКонтрагента и вызов Ит.СНД() и др. будут выдавать сальдо по этому счету (СчетКонтрагента).
   Crystalizer
 
14 - 11.06.04 - 17:30
creator: ну ф принципе понял, спасибо :)
только в документации сказано шо оно используеся с "ВыбратьСчета"... ну да ладно


Список тем форума
Рекламное место пустует  
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует