Вход | Регистрация

1С:Предприятие ::

Метки:OLE и COM

Загрузка справочников через ОЛЕ

Я
   Press
11.06.04 - 11:31
Перекидываю номенклатуру из одной конфы в другую:

_СпрРарусНоменклатура = СоздатьОбъект("Справочник.Номенклатура");
СпрБухНоменклатура = БазаБух.CreateObject("Справочник.Номенклатура");         

_СпрРарусНоменклатура.ВыбратьЭлементы(1); 
Пока _СпрРарусНоменклатура.ПолучитьЭлемент() = 1 Цикл
 Код = _СпрРарусНоменклатура.Код;
 Наименование = _СпрРарусНоменклатура.Наименование;
 КодРодителя = _СпрРарусНоменклатура.Родитель.Код;
 Если СокрЛП(КодРодителя) <> "" Тогда        
     Если СпрБухНоменклатура.НайтиПоКоду(КодРодителя,0)=0 Тогда
         Сообщить("Не нашел родителя!");//Находит...

    КонецЕсли;
    Родитель = СпрБухНоменклатура.ТекущийЭлемент(); 
    Сообщить(Родитель.Наименование)//Сообщает наименование 

   //необходимой группы-родителя

 КонецЕсли;
 Если _СпрРарусНоменклатура.ЭтоГруппа()=1 Тогда
    Если СпрБухНоменклатура.НайтиПоКоду(Код,0)=0 Тогда
        СпрБухНоменклатура.НоваяГруппа();
        СпрБухНоменклатура.Код = Код; 
        Если СокрЛП(КодРодителя) <> "" Тогда
            СпрБухНоменклатура.Родитель = Родитель;
        КонецЕсли;
        СпрБухНоменклатура.Наименование = Наименование;
        СпрБухНоменклатура.Записать();               
    КонецЕсли;                          
    Продолжить;
 КонецЕсли; 
 СпрБухНоменклатура.Новый();
 СпрБухНоменклатура.Наименование = Наименование;
 СпрБухНоменклатура.Код = Код; 
 Если СокрЛП(КодРодителя) <> "" Тогда
     СпрБухНоменклатура.Родитель = Родитель// Неизвестная ошибка!

 КонецЕсли;
 СпрБухНоменклатура.Записать();                
КонецЦикла;   

Сообщает наименование необходимой группы-родителя,
и все, база приемник виснет, убиваешь ее -
выскакивает ошибка -
СпрБухНоменклатура.Родитель = Родитель;Неизвестная ошибка
Почему не присваивается Родитель для элемента?
 
  Рекламное место пустует
   Миха
1 - 11.06.04 - 11:44
Попробуй Родитель.ТекущийЭлемент(), или через EvalExpr
   Valery
 
2 - 11.06.04 - 11:53
Я бы лучше переносил данные не в OLE базу, а из нее.
Т. е. РарусНоменклатура сделал OLE
   Press
3 - 11.06.04 - 11:59
(1,2) Не то..
   Миха
4 - 11.06.04 - 12:07
(2) тоже рекомендую, и ошибки будет легче отлавливать
   Bzzzzz
 
5 - 11.06.04 - 12:08
Сделай как в (2) и посмотри в Отладчике чего у тебя там в Родителе
   Миха
6 - 11.06.04 - 12:32
И что там у тебя в родителе?
   Press
7 - 11.06.04 - 13:03
Разобрался, проблема оказалась в битой базе и моих кривых мозгах.
Всем спасибо за участие.
ЗЫ.Чтоб я еще раз ветку завел...(это я зарекаюсь)


Список тем форума
Рекламное место пустует   Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует