Вход | Регистрация

1С:Предприятие ::

Метки:запросы, Запросы и построители

Проблемы с бух. запросом

Я
   Tani
 
11.06.04 - 08:12
Нужно выбрать дебетовое сальдо на конец периода по субсчетам 60, 62 и 76 у контрагентов. При  формировании отчета выводятся данные только по счетам, а хотелось бы получить данные по субсчетам. Как можно этого добиться?

Счета="60,62,76";
Ит=СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты, , );
Ит.ВыполнитьЗапрос(,Дата,Счета,,,,,"С");
Ит.ВыбратьСубконто();
Пока Ит.ПолучитьСубконто()-1 Цикл
  Ит.ВыбратьСчета();
    Пока Ит.ПолучитьСчет()=1 Цикл   
       Если Ит.СКД()<>0 Тогда
         Конт=Ит.Субконто();
         Счет=Ит.Счет;
         Сумма=Ит.СКД();
       КонецЕсли;
    КонецЦикла;
КонецЦикла;
 
  Рекламное место пустует
   Vol71
 
1 - 11.06.04 - 08:14
ВключатьСубсчета
Устанавливает режим отбора итогов методом ВыполнитьЗапрос по субсчетам.

Синтаксис:

ВключатьСубсчета(<ФлагСчета>, <ФлагКоррСчета>}

Англоязычный синоним:

IncludeSubAccounts

Параметры:

<ФлагСчета>
Необязательный параметр. Признак развертыва­ния сальдо по субсчетам основного счета. Число:

0 — не разворачить по субсчетам;

1 — разворачивать по субсчетам;

-1 (минус единица) — не выдавать итоги по сче­там-группам.

Значение по умолчанию — 0.

<ФлагКоррСчета>
Необязательный параметр. Признак развертыва­ния сальдо по субсчетам корреспондирующего счета. Число:

0 — не разворачить по субсчетам;

1 — разворачивать по субсчетам;

-1 (минус единица) — не выдавать итоги по кор­респондирующим счетам-группам.

Значение по умолчанию — 0.


Описание:

Метод ВключатьСубсчета должен вызываться до выполнения метода ВыполнитьЗапрос. Он устанавливает режим, при котором итоги отбираемые запросом будут разворачиваться по субсчетам соответвенно основных и коррес­пондирующих счетов.

Если метод не вызвался, разворот итогов по субсчетам не производится.

Пример:

БухИтоги.ВключатьСубсчета(1, 1);
   Tani
 
2 - 11.06.04 - 08:18
Спасибо, зря задавала вопрос сама нашла ответ


Список тем форума
 
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует