Вход | Регистрация

1С:Предприятие ::

Метки:ТиС

Получить сумму долга по договору

Я
   Freelancer
 
10.06.04 - 16:08
как можно получить сумму долга клиента по договору?
 
 
   lexa
 
1 - 10.06.04 - 16:11
Процедура РасчетТекущегоДолга()
    
    ТекущийДолг = глТекущийДолг(Фирма, Договор, "покупатель");
    Если ТекущийДолг < 0 Тогда
        Форма.ТекстТекущийДолг.Цвет(255); 
    Иначе
        Форма.ТекстТекущийДолг.Цвет(0,0,128); 
    КонецЕсли;

КонецПроцедуры//РасчетТекущегоДолга()
   Crystalizer
 
2 - 10.06.04 - 16:14
// попробую проламерить:
ну... это смотря где информация храница
если в регистре то нужно сделать запрос по регистру с указанием клиента и договора
если на бухсчете то по бух итогам с указанием в качестве субконто клиент и документ
   Freelancer
 
3 - 10.06.04 - 16:15
это для формы... а мне в отчет ;)
   lexa
 
4 - 10.06.04 - 16:18
(3) я тебе уже говорил, тебе надо делать через регистры, посмотри как сделано, пойми и сделай по своему
   427
 
5 - 10.06.04 - 16:33
Клиент? Слушай, сЮка - ты мне сколь должен?
   Crystalizer
 
6 - 10.06.04 - 16:34
вот я сегодня наламерил с регистрами
переделай на свой манер:

    Ре = СоздатьОбъект("Регистр.ПартииТоваров");
    Ре.УстановитьЗначениеФильтра("Товар", Товар,1);
    Ре.УстановитьЗначениеФильтра("Фирма",Фирма,1);
    Ре.УстановитьЗначениеФильтра("МестоХранения",Склад,1);
    
    Если ИтогиАктуальны()=0 Тогда
        Ре.ВременныйРасчет(1);
        РассчитатьРегистрыНа(ДатаДок);
    КонецЕсли;
    

   //тз = создатьОбъект("ТаблицаЗначений");

   //ре.Выгрузитьитоги(тз,1,1);

   //тз.Выбратьстроку();

    
    себрег = Ре.СводныйОстаток (Фирма, Товар, ,Склад,,,, "Стоимость");
    колич = Ре.СводныйОстаток (Фирма, Товар, ,Склад,,,, "ОстатокТовара");

если откоментировать 
   //тз = создатьОбъект("ТаблицаЗначений");

   //ре.Выгрузитьитоги(тз,1,1);

   //тз.Выбратьстроку();
то сразу увидишь результаты
   Gavrila
 
7 - 10.06.04 - 17:38
(6) для отчета (3) не использовать итогиактуальны
   Валентин
8 - 10.06.04 - 18:32
(6) А почему по партии товаров а не по Взаиморасчетам?
Может конечно у меня конфа какая нестандартная, но в регистре ВзаиморсчетыПокупателей есть измерение ДокументДоговор. Помоему так проще
   Crystalizer
 
9 - 10.06.04 - 18:55
(8)
ты что!
конечно пиши свои
я просто скопировал свой текст

Гаврила: чего нет?
   Gavrila
 
10 - 10.06.04 - 18:58
(9)
"ИтогиАктуальны()" - Метод доступен только в Модуле документа в предопределенной процедуре ОбработкаПроведения

ИтогиАктуальны()
AreTotalsActual()
Синтаксис:
ИтогиАктуальны()
Назначение:
Возвращает флаг актуальности итогов: 1 - итоги актуальны, 0 - иначе.
Замечание:
Метод доступен только в Модуле документа в предопределенной процедуре ОбработкаПроведения.
Подробнее см. в документации, глава 'Работа с Документами'
 
  Рекламное место пустует
   lexa
 
11 - 10.06.04 - 19:47
РабРег = Регистр.Покупатели;                                      
Долг    = РабРег.СводныйОстаток(Фирма, Договор, , , ,"СуммаВал");


Список тем форума
Рекламное место пустует  
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует