Вход | Регистрация

  1  2   
1С:Предприятие ::

Метки:формы

Форма диалога. Текущее время на форме.

Я
   Aнтoн
10.06.04 - 09:04
Хочу сделать, что бы у меня показывало время, которое меняется на форме. Кто-нибудь знает как?
 
  Рекламное место пустует
   GrayT
 
1 - 10.06.04 - 09:13
ОбработкаОжидания() тебе поможет
   Aнтoн
2 - 10.06.04 - 09:15
Ну она же в глобальном модуле. Как она мне поможет в форме?
   GrayT
 
3 - 10.06.04 - 09:16
А ты ее на форме попробуй :))
   Aнтoн
4 - 10.06.04 - 09:20
Вставил ОбработкаОжидания() в процедуру ПриОткрытии(). Не работает. Время выводится, но не тикает.
   GrayT
 
5 - 10.06.04 - 09:23
Короче в обработке ожидания говоришь какую процедуру вызывать и через какое время. В этой процедуре пишешь вывод на форму
   GrayT
 
6 - 10.06.04 - 09:30
Процедура ТТ()
    Форма.ТТ.Заголовок(ТекущееВремя());
КонецПроцедуры//ТТ

//_____________________________________________________________________________
Процедура ПриОткрытии()
    Форма.ОбработкаОжидания("ТТ", 1);
КонецПроцедуры//ПриОткрытии
   Aнтoн
7 - 10.06.04 - 09:30
Я так написал.
ОбработкаОжидания("ПоказатьВремяРаботы",1);  - Это при открытии

Процедура ПоказатьВремяРаботы()  
Форма.ТекВремя.Заголовок(ТекущееВремя()); 
КонецПроцедуры    

ТекВремя - это текстовое поле.
   Aнтoн
8 - 10.06.04 - 09:31
А, вот как.
Щас попробую
   Zubr
 
9 - 10.06.04 - 09:31
Можно и без ОбработкаОжидания()
Дай мыло - вышлю обработку-пример.
   AlexP
10 - 10.06.04 - 09:34
Не надо ОбработкуОжидания вставлять в процедуру ПриОткрытии(). ОбработкуОжидания вставь в конце модуля формы после всех процедур.
 
  Рекламное место пустует
   Aнтoн
11 - 10.06.04 - 09:42
Получилось!!!
НО!!!
Это работает только в немодальническом режиме, а в мне нужно в модальническом. Там не работает!
   GrayT
 
12 - 10.06.04 - 09:51
В модальном не пробовал. Может у Zubra что поинтереснее будет.
   Aнтoн
13 - 10.06.04 - 10:07
Zubr, высылай
anton164@yandex.ru
   SnarkHunter
 
14 - 10.06.04 - 11:09
Ну что, никто не знает что ли?
Или вы только издеваться умеете?
   Aнтoн
15 - 10.06.04 - 11:28
Да, я тоже хотл спросить. никто не сталкивался что ли?
Зубр, я ящик перепутал anton614@yandex.ru
   Zubr
 
16 - 10.06.04 - 11:46
(15) Ушло
   At
 
17 - 10.06.04 - 11:49
(14) Шутка повторенная дважды...
   At
 
18 - 10.06.04 - 11:50
+(17) в два раза смешнее!
   Aнтoн
19 - 10.06.04 - 12:39
Зубр, получил. НО!!! Проблема в том, что нужно нажимать кнопку, чтобы все заработало. Если не нажимать - не работает. Я хочу, штобы при открытии само начинало тикать. Как сделать?
Кто-нибудь знает?
   SiMazx
 
20 - 10.06.04 - 12:53
Посмотри процедуру, привязанную к кнопке... И запускай ее при открытии..
Скорее всего поможет...
   Aнтон
21 - 10.06.04 - 12:55
Зубр - ты идиот! Эта фишка мне изменила системное время и я случайно загнал часть документов задним числом. Гадёнышь.
   Aнтoн
22 - 10.06.04 - 12:57
В формуле кнопки написано d=0 и все.
   Gavrila
 
23 - 10.06.04 - 12:58
(21) пора взрослеть :)
   SiMazx
 
24 - 10.06.04 - 12:58
(21)Теперь от Зубра ты больше помощи не дождешься...
И не только от Зубра...
Посмотреть в текст фишки религия не позволяет?
   Aнтон
25 - 10.06.04 - 12:58
Не нужен мне никакой d=0, там надо что-то другое написать.
   Shadal
 
26 - 10.06.04 - 12:59
Как функцию к текстовому полю привязать.
   Gavrila
 
27 - 10.06.04 - 12:59
(25) вот и напиши...
   Aнтoн
28 - 10.06.04 - 13:01
Автор этого какойто avb.
   At
 
30 - 10.06.04 - 13:02
Нельзя людям добро делать.
Мало того, что не оценят. Так они еще и обгадят.
   3V
 
31 - 10.06.04 - 13:03
(26) если ты имеешь ввиду форму дока или справочника, то там в свойствах есть "формула"
   Aнтон
32 - 10.06.04 - 13:04
Педараст - тебе чё от меня надо?
Нет там никакой формулы.
   At
 
33 - 10.06.04 - 13:05
для Zubr...
а можно мне тоже на мыло кинуть skat@land.ru?
если не затруднит...
 
  Рекламное место пустует
   Aнтoн
34 - 10.06.04 - 13:06
Там вот такое. Уже голову сломал.

//
//                          by Alexey Bazhitov aka avb

//                     Moscow,  April 2003 
//                   mailto:avb@dmitrovka.net

//
//-----------------------------------------------------------------------------

var s,c,d,h;
//-----------------------------------------------------------------------------

function hueToRGB(hue)   
if hue<0 then hue=hue+240 elsif hue>240 then hue=hue-240 endif;
if hue<40 then return (240*hue+20)/40 endif;
if hue<120 then return 240 endif;
if hue<160 then return (240*(160-hue)+20)/40 endif;
 return 0;
endFunction  
//-----------------------------------------------------------------------------

function getColor(hue)
 r=round((hueToRGB(hue+80)*255+120)/240);
 g=round((hueToRGB(hue)*255+120)/240);
 b=round((hueToRGB(hue-80)*255+120)/240);
if r<0 then r=0 endif; if r>255 then r=255 endif;
if g<0 then g=0 endif; if g>255 then g=255 endif;
if b<0 then b=0 endif; if b>255 then b=255 endif;
 return b*65536+g*256+r;
endFunction
//-----------------------------------------------------------------------------

function time()
  form.refresh();
    if _getPerformanceCounter()-c>200 then
      c=_getPerformanceCounter(); 
        s=?(d=0,mid(s,2)+left(s,1),right(s,1)+mid(s,1,strlen(s)-1));
    endif;  
  h=1+h;                              
  if h>240 then h=0 endif;
  form.time.color(getColor(h));
    return currentTime();
endFunction  
//-----------------------------------------------------------------------------  

procedure onOpen()
 if form.parameter<>"modal" then 
  openFormModal("Processing#","modal",filePath()); 

    returnStatus(0);
    return;
 endif;    
 s="    Делу - время, делу - время, делу - время, а потехе - час!       ";
 c=_getPerformanceCounter();
endProcedure
   Aнтoн
36 - 10.06.04 - 13:10
Все!!! Я придумал!! В модальническом окне тоже работает время! Запускается сразу при открытии!!! Если кто хочет поучиться - обращайтесь, вышлю.
   Gavrila
 
37 - 10.06.04 - 13:12
(36)Высылай
   SiMazx
 
38 - 10.06.04 - 13:13
Модальническое окно, 11-базный ключ (с) Антуан
   Zubr
 
39 - 10.06.04 - 13:31
(33) Ушло.
   Zubr
 
40 - 10.06.04 - 13:34
(34) Придурок, и где здесь происходит изменение времени ?
   Aнтoн
41 - 10.06.04 - 13:35
Гаврила, отправил.
   Gavrila
 
42 - 10.06.04 - 13:38
(41) Получил, щас посмотрим... поучимся :)
   At
 
43 - 10.06.04 - 13:38
Ребята! Давайте жить дружно! :)
   Aнтон
44 - 10.06.04 - 13:43
Извини зубр, эт не ты идиот! Идиотская 1С. Постоянно с этой программой проблемы.
   At
 
45 - 10.06.04 - 13:43
теперь 1С виновата... :(
   Aнтoн
46 - 10.06.04 - 13:44
Гаврила, ну как? Понял глубину решения?
   SiMazx
 
47 - 10.06.04 - 13:44
Вот, теперь у него 1С виновата... Проверь, мож у тя hands.dll и brain.dll битые?
   Aнтон
48 - 10.06.04 - 13:46
Ребята, серьёзна, вы сейчас все не идиоты. Вы же мне ещё помогаете..
Давайте не наезжать друг на друга.
   Aнтoн
49 - 10.06.04 - 13:47
Да нормально все у меня. Гаврила вот молчит. Наверно понять не может ничего.
 
  Рекламное место пустует
   At
 
50 - 10.06.04 - 13:47
ты правда так думаешь??
ню-ню... :)
   Aнтон
51 - 10.06.04 - 13:50
Проверил все длл-ки. всё в норме, ничего не битое, всё пашет как надо.
   Gavrila
 
52 - 10.06.04 - 13:51
(49) Я вернулся, понять могу, только с англ. проблемы(сидел переводил), решение интересное, только вот половину модуля закомментировать можно :)
   Aнтон
53 - 10.06.04 - 13:52
Чего тебе не понятно? Там всё просто - как в чайнике.
   Zubr
 
54 - 10.06.04 - 13:53
(44) Извинения не приняты...
Теперь ты у меня в личном игнор-листе.
И похоже ты попал в тор-list товарищуPederast'у...
   Gavrila
 
55 - 10.06.04 - 13:53
(51) попробуй их зарегистрировать (Regsvr32.exe), на всяк випадок, шоб не глючило :)
   At
 
56 - 10.06.04 - 13:55
(55)а можно перевод показать?
а то у меня с английским проблемы :(
   Aнтон
57 - 10.06.04 - 13:55
Ну вы чё - совсем ламеры? Я ж так и проверяю - всё реглю только через regsvr32. Всё в норме. Даже не ругнулось.
   Aнтон
58 - 10.06.04 - 13:57
Зубр - ну я ж извинился. Меня тут бухи с ламерами достают, пойми, не просто мне сичас.
   At
 
59 - 10.06.04 - 13:58
гнилая отмазка!
   Aнтoн
60 - 10.06.04 - 13:59
Гаврила, чего там закомментировать? Не будет тогда работать. Скажи что закомментировать
   At
 
61 - 10.06.04 - 13:59
даже мне за Зубра обидно было... а я его первый раз вижу!
   Aнтон
63 - 10.06.04 - 14:01
Я не педик. А друзья есть. как и у всех нормальных людей.
Так чё закомментировать?
   Gavrila
 
64 - 10.06.04 - 14:04
(56)
//Var MustBeClosed;


//// -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

//Procedure OnClose()
//    If MustBeClosed = 1 Then

//        Activate("CurrTime");
//        ReturnStatus(0);

//    EndIf;
//    MustBeClosed=0;

//EndProcedure

// -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Функция ПоказатьВремя()  
    Форма.ТекВремя.Заголовок(""+ТекущееВремя());
   //If MustBeClosed=1 Then

   //    Form.Close(0);

   //EndIf;

    Форма.Обновить(0);
    Возврат "";
КонецФункции

// -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Процедура ПриОткрытии()
    Если Форма.Параметр <> "Модально" Тогда
        ОткрытьФормуМодально("Обработка#","Модально",РасположениеФайла()); 

        СтатусВозврата(0);
        Возврат;
    КонецЕсли;    
   //MustBeClosed=1;

КонецПроцедуры
   Pedrila
65 - 10.06.04 - 14:05
Опа! Пери, и ты тут?  
Уже блин снял кого-то?
   Aнтoн
67 - 10.06.04 - 14:08
Гаврила, так после этого время не тикает
   Gavrila
 
69 - 10.06.04 - 14:15
(67) еще как тикает, только не слышно :)
   Aнтoн
70 - 10.06.04 - 14:16
Гаврила, я понял - ты просто лажанулся, да?
И за чем ты код на русский определим...
   Gavrila
 
71 - 10.06.04 - 14:19
(70) не понимаешь по русски - не читай
   Aнтoн
72 - 10.06.04 - 14:20
Ну так не работает ведь.
   Aнтoн
73 - 10.06.04 - 14:21
Кому еще выслать? Чтобы проверили Гаврилу?
   Gavrila
 
74 - 10.06.04 - 14:22
(73)Только лучше я вышлю, а то ты щас напосылаешь :)
   Aнтoн
75 - 10.06.04 - 14:24
Мне пришли свой вариант
   Bzzzzz
 
76 - 10.06.04 - 14:26
(74) Намыль пожалуйста
   SiMazx
 
77 - 10.06.04 - 14:29
(76) Поаккуратнее... А то у нас тут ребята бродят... Они те вмиг намылят...
   Aнтoн
78 - 10.06.04 - 14:47
Гаврила, где твой вариант?
Или ты все-таки облажался?
   At
 
79 - 10.06.04 - 14:50
Хорошо быть тупым!!!
   Aнтoн
80 - 10.06.04 - 15:04
Дело в том, что когда закомментаришь как Гаврила часики не тикают.
   Aнтон
81 - 10.06.04 - 15:38
Затикали. Я блин забыл колонки включить.
   Bzzzzz
 
82 - 10.06.04 - 15:41
(81) Так это значит ты облажался? ;-)
   Aнтoн
83 - 10.06.04 - 15:43
Нет, Гаврила.
(82)Он тебе прислал?
   SiMazx
 
84 - 10.06.04 - 15:46
У Антуана лажают все... Кроме него самого, ессно... Плохому 1С-нику все мешают...
   Bzzzzz
 
85 - 10.06.04 - 15:47
(83)Нее. Ждём-с.
В 80 ты говоришь, что у Гаврилы не тикают, в 81 - тикают. Ты уж определись :-)
   At
 
86 - 10.06.04 - 15:49
+(79)А тупым и невоспитанным еще лучше! :)
   Bzzzzz
 
87 - 10.06.04 - 15:51
+(84) Еще все идиоты и тупые :*)
http://www.forum.mista.ru/topic.php?id=5351#msg7
Антуан, ты на этот форум как вышел?
   SiMazx
 
88 - 10.06.04 - 15:53
Антон умело настраивает против себя всю мисту... Начал с Зубра... Подобрался к Гавриле... Эххх... Скоро только пи.оры ему помогать будут... С удовольствием... ;)))
   Aнтон
89 - 10.06.04 - 16:04
Ну сколько можно ещё повторять. Ну я ж сказал -  не идиоты пока ещё все.
Это у меня сначала вырвалось. Типа - боевой кличь.
   Aнтон
90 - 10.06.04 - 16:05
А по большому счёту - код тот кривой до ужаса, сейчас сам правлю. Думаю будет шедевр.
   Bzzzzz
 
91 - 10.06.04 - 16:06
Не мля, меня умиляет этот персонаж:
в (89) "Ну я ж сказал -  не идиоты ПОКА ЕЩЁ все"
   At
 
92 - 10.06.04 - 16:08
(91) тут несколько Антонов... :)
   Aнтон
93 - 10.06.04 - 16:09
И много у вас тут пидеров? Странный форум.
   Jerry Mnemonic
94 - 10.06.04 - 16:13
ШЕДЕВРальная ветка. Она - истинное золото этого ресурса. Полностью отражает ситуацию на форуме мисты.
Какой ресурс - такие и антоны...
   SiMazx
 
95 - 10.06.04 - 16:14
(93)Да вот вчера еще один появился... Все байки про ключи, базовые и типовые 1С-ки рассказывал...
   iceTiger
 
96 - 10.06.04 - 16:23
Давно не видел такие ветки на спец. форумах :))) Антону БРАВО! Ты знаменит!
   SiMazx
 
97 - 10.06.04 - 16:25
Антон - мужская инкарнация Светы...
   Aнтон
98 - 10.06.04 - 16:41
А чё это за Свету вы тут поминаете?
   SiMazx
 
100 - 10.06.04 - 16:53
(98) Тебя не приколет...

  1  2   

Список тем форума
  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует