Вход | Регистрация

1С:Предприятие ::

Метки:Запросы и построители

вопрос по Запросу к оборотному Регистру

Я
   vita55555
17.12.03 - 17:44
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса = "
|Период с НачДата по КонДата;
|Материал = Регистр.МатериалыМесяц.Материал;    
|Объект = Регистр.МатериалыМесяц.Объект;
|Количество = Регистр.МатериалыМесяц.Количество;
|Группировка Материал;
|Группировка Объект; 
|Условие (Материал в ВыбрМатериалГруппа); 
|Условие (Объект в ВыбрОбъект); 
|";                  
        
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
 Возврат;
КонецЕсли;
        
Таб = СоздатьОбъект("Таблица");
Таб.ВывестиСекцию("Заголовок");
        
Пока Запрос.Группировка(1) = 1 Цикл
Если Запрос.Материал.ЭтоГруппа()=1 Тогда
 Таб.ВывестиСекцию("Группа");
Иначе
 Таб.ВывестиСекцию("МатериалыМесяц");
КонецЕсли;
КонецЦикла;

не работает Запрос.Группировка(1), пишет = 0
МатериалыМесяц - оборотный регистр
 
 
   skunk
 
1 - 17.12.03 - 20:12
Попробуй воткнуть между "|Количество = Регистр.МатериалыМесяц.Количество;" и "|Группировка Материал;" вот это "|Функция Конец = КонОст(Количество);"
   vita55555
2 - 18.12.03 - 10:12
все равно пишет:
Запрос.Группировка(1) = 0
   skunk
 
3 - 18.12.03 - 10:40
А если условие с группировкой местами поменять
   GrayT
 
4 - 18.12.03 - 10:44
Это оборотный регистр регистр? Тогда вместо КонОст используй Сумма
   vita55555
5 - 18.12.03 - 11:00
(3) пробовал не помогло

(4) с Сумма все поперло, ура !!!!!!!!!!!!
подскажите где можно почитать про функции в Запросе
и поподробнее про Запрос.
ссылочку или Книгу ???
   GrayT
 
6 - 18.12.03 - 11:04
Книга "Описание встроенного языка" из стандартной поставки 1С :)
А еще у Волшебника на сайте пара учебников лежит.
   vita55555
7 - 18.12.03 - 11:09
1с не основная работа, а для души когда минутка свободная появляется ).
Читать описание встроенного языка все, просто времени не хватае, а жаль..
на сайте у Волшебника и учусь.. спасибо ему
тока я там Сумму не встречал.
и по встроенному помошнику, но там Суммы тож нет.
   kvm
 
8 - 18.12.03 - 20:24
А Описание языка не учебник, а справочник. Надо что, посмотрел. Не надо - забыл:)
   GrayT
 
9 - 19.12.03 - 14:39
Может тут что найдешь. Правда давно ссылки не проверял - если мертвые - не обижайся :(
www.firststeps.ru
www.school1c.narod.ru


Список тем форума
  Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует