Вход | Регистрация

1С:Предприятие ::

Метки:бухгалтерский учет

Отрицательная сумма в колонке ТЗ.

Я
   sov
 
07.06.04 - 13:14
Мужики, помогите!
В форме надо ввести конкретную Расходную накладную из списка реализованного в виде ТЗ. В форме находится кнопка, при нажатии на которую выполняется следующая процедура:
 Процедура Основание()
     ТабЗн=СоздатьОбъект("ТаблицаЗначений");
     ТабЗн.НоваяКолонка("Док","Документ.РасходнаяНакладная",,,"РасхНакл",18);  
     ТабЗн.НоваяКолонка("Нум","Число",8,0,"Номер",9); 
     ТабЗн.НоваяКолонка("Дат","Дата",10,0,"Дата",10); 
     ТабЗн.НоваяКолонка("Сум","Число",14,2,"Сумма",14);
     ТабЗн.ВидимостьКолонки("1",0);
     БухИтоги=СоздатьОбъект("БухгалтерскиеИтоги");
    БухИтоги.ИспользоватьПланСчетов(ПланыСчетов.Учебный); 
    БухИтоги.ИспользоватьРазделительУчета(Константа.ОснФирма);    
    БухИтоги.ИспользоватьСубконто(ВидыСубконто.Контрагент,Покупатель,2);
    БухИтоги.ИспользоватьСубконто(ВидыСубконто.РасходнаяНакладная,,1);
    БухИтоги.ВыполнитьЗапрос(,ДатаДок,"62");
    БухИтоги.ВыбратьСубконто(1);
    Пока БухИтоги.ПолучитьСубконто(1)=1 Цикл
        БухИтоги.ВыбратьСубконто(2);     
        Пока БухИтоги.ПолучитьСубконто(2)=1 Цикл     
            ТДок=БухИтоги.Субконто(2);
            КреС=БухИтоги.СКК(1);
            ТабЗн.НоваяСтрока();
            ТабЗн.Док=ТДок;
            ТабЗн.Нум=ТДок.НомерДок;
            ТабЗн.Дат=ТДок.ДатаДок;
            ТабЗн.Сум=КреС;
        КонецЦикла;
    КонецЦикла;
    ТабЗн.Сортировать("1+");
    Стр=0;
    Рез=ТабЗн.ВыбратьСтроку(Стр,"Выберите расходную накладную");
    Если Рез=1 Тогда
        Основание=ТабЗн.ПолучитьЗначение(Стр,"Док");
    КонецЕсли;
КонецПроцедуры   

Мне непонятно, почему в колонке ТЗ "Сумма" значение суммы получается отрицательным. Хотя в случае Приходной накладной , где реализована та же самая прцедура(только счёт 60-й), сумма положительная. Смотрел проводку данных накладных в журнале операций, везде суммы положительные.
 
 
   Michael99
 
1 - 07.06.04 - 13:24
В оборотно-сальдовой красненькие цифры видел ?
Так как "ПланыСчетов.Учебный" сказать что-либо конкретно трудно.
Вероятно закрыл аванс которого небыло, вот и вылезло красное сальдо.
   sov
 
5 - 07.06.04 - 13:37
В данной учебной базе ситуация простейшая. Купил детали, собрал из них новую деталь, продал. Когда купил детали, оплатил покупку через приходную накладную. Продажу оформил через расходную накладную. Деньги от покупателя оформил через приходный ордер. При его оформлении нужно ввести документ (конкретную расходную накладную). Далее всё как в вопросе(0).
   427
 
9 - 07.06.04 - 13:50
(4) фигня... полная

такое (в (0)) происходит из-за наличия у счетов признака А (активный) П (пассивный) АП (активно-пассивный). Почитай про эти признаки...

Есть еще смысл счета...

на примере кассы (счет 50) он активный. т.е. на нем хранится сумма находящихся в кассе денег... Пусть это 100 рупий... Если ты выдашь 80 рупий - останется 20... Далее если расходным ордером (без проверки остатка) выдать еще 30 рупий на руки - в кассе будет минус 10 рупий... Естественно, в жизни такого быть не может..

т.к. счет 50 активный - у него нет кредитового остатка. Фича в том, что в 1С в этом случае возвращается дебетовый остаток НО С МИНУСОМ....

Вообще прочитай про счета нормальную книжку.....


Список тем форума
Рекламное место пустует   Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует