Вход | Регистрация

1С:Предприятие ::

Метки:Расчет

Налоговые вычеты

Я
   Magnus
 
03.06.04 - 14:55
Пишу отчет о налоговых вычетах с сотрудников после расчета ЗП. Откуда их тащить (документов, справочников)?
 
  Рекламное место пустует
   Magnus
 
2 - 03.06.04 - 14:58
(1) Вычеты в отчет
   Valery
 
3 - 03.06.04 - 15:04
если речь идет о стандартных вычетах, то параметры дожны быть в справочнике сотрудников. А суммы ни где не храняться. Думаю,что их надо расчитывать заново
   mszsuz
 
4 - 03.06.04 - 15:06
В ЗиК Справочник "ВычетыСотрудниковПоНДФЛ" подчиненный справочнику "Сотрудники"
   Magnus
 
5 - 03.06.04 - 15:31
пытаюсь вывести налоговые вычеты через запрос, но что-то вычеты не выводятся, не пойму в чем грабли. Код:
Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
   //Создание объекта типа Запрос

    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)

    |Период с ВыбНачПериода по ВыбКонПериода;
    |Обрабатывать НеПомеченныеНаУдаление;
    |ДатаРождения = Справочник.Сотрудники.ДатаРождения;
    |Наименование = Справочник.Сотрудники.Наименование;
    |ВычетыСотрудниковПоНДФЛ = Справочник.ВычетыСотрудниковПоНДФЛ.ТекущийЭлемент;
    |Группировка Наименование;
    |//}}ЗАПРОС

    ;
   // Если ошибка в запросе, то выход из процедуры

    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;

   // Подготовка к заполнению выходных форм данными запроса

    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
   // Заполнение полей "Заголовок"

    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
       // Заполнение полей Наименование

        Таб.ВывестиСекцию("Наименование");
    КонецЦикла;
   // Вывод заполненной формы

    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры
   SnarkHunter
 
6 - 03.06.04 - 15:45
|Период с ВыбНачПериода по ВыбКонПериода; 
|Обрабатывать НеПомеченныеНаУдаление; 
|Сотрудник = Справочник.ВычетыСотрудниковПоНДФЛ.Владелец; 
|ВычетыСотрудниковПоНДФЛ = Справочник.ВычетыСотрудниковПоНДФЛ.ТекущийЭлемент; 
|Группировка Сотрудник Упорядочить По Сотрудник.Наименование;
   Magnus
 
7 - 03.06.04 - 15:56
(6) Точно, забыл что вычеты-это подчиненный справочник, спасиба
   Magnus
 
8 - 03.06.04 - 16:15
А мне еще нада дату рождения вывести, добавил строчку с датой рождения из справочника сотрудники, но выодится пустая строка, не пойму в чем дело.
   SnarkHunter
 
9 - 03.06.04 - 16:16
Запрос.Сотрудник.ДатаРождения


Список тем форума
  Рекламное место пустует
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует