Вход | Регистрация

1С:Предприятие ::

Метки:регистры

Регистры в 1С:Предприятии 7.7

Я
   Дима
02.06.04 - 16:33
Подскажите как использовать регистры? Как их создавать и т.д.
 
  Рекламное место пустует
   wind_wail
1 - 02.06.04 - 16:36
Почитай учебник на mista.ru, почитай "описание внутреннего языка 1С" (в 2х частях) (пиши на wind_wail@mosk.ru, если нужно поделюсь), на крайний случай можно поглядеть как это делается в стандартных конфигах.
   lexa
 
4 - 02.06.04 - 17:26
   HanProg
5 - 02.06.04 - 17:37
В учебнику в стандартном действительно непонятно описано
но на www.mista.ru все подробно описано главное помнить
что ты работаешь с базой данных имеющей много измерений
и посмотреть можно все что угодно в любом срезе это очень
удобно и класно лучше работать при помощи запросов с регистром
а вообще это в 8.0 стало основой.
   romix
 
6 - 02.06.04 - 19:57
Попробуй создать регистр Остатки (с измерениями Товар и ресурсом Количество).
И попробуй создать документ ПриходнаяНакладная и РасходнаяНакладная.
Установи флажок Оперативный учет в документах.

Модуль проведения в приходной накладной:

Процедура ОбработкаПроведения()
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
 Регистр.Остатки.Товар=Товар;
 Регистр.Остатки.Количество=Количество;
 Регистр.Остатки.ДвижениеПриходВыполнить();
КонецЦикла;
КонецПроцедуры

В расходной то же самое, но либо
Регистр.Остатки.Количество=-Количество;
либо
 Регистр.Остатки.ДвижениеРасходВыполнить();

После проведения документа посмотри в меню Действия - Движения документа, что там изменилось.

Чтобы получить итоги по регистру (сколько и каких товаров сейчас на складе),
создай отчет, помести на него таблицу значений с именем тз, и напиши

Процедура Сформировать()
  рег=СоздатьОбъект("Регистр.Остатки");
  рег.ВыгрузитьИтоги(тз);
КонецПроцедуры


Список тем форума
  Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует