Вход | Регистрация

1С:Предприятие ::

Метки:Приемы программирования

Выснить разрешение экрана на пользовательской машине

Я
   Валентин
31.05.04 - 23:48
Где-то видел на коныеренции, но поиск что-то не находит.
Там как-то через VBS извращались.
Помогите пожалуйста...
 
  Рекламное место пустует
   unior
 
2 - 01.06.04 - 06:15
// Как определить экранное разрешение

// ------------------------------------------
// Copyright (C) MAV 2002

// ------------------------------------------
// Автор: Андрей Михайлов

// E-Mail/MSN : m4v@mail.ru
// ICQ : 137167406
// URL : http://zone1c.narod.ru


//_____________________________________________________________________________

//
// Через WMI

//_____________________________________________________________________________

Процедура Через_WMI()
    Locator = СоздатьОбъект("WbemScripting.SWbemLocator");
    Service = Locator.ConnectServer();
    Service.Security_.ImpersonationLevel=3;

    Video = Service.Get("Win32_VideoController.DeviceID='VideoController1'");
    Стр = "" + Video.CurrentHorizontalResolution + "x" + Video.CurrentVerticalResolution;

    Предупреждение(Стр, 5);
КонецПроцедуры//Через_WMI


//_____________________________________________________________________________

//
// Через IE

//_____________________________________________________________________________

Процедура Через_IE()
    oIE = СоздатьОбъект("InternetExplorer.Application");
    oIE.navigate("about:blank");
    Пока oIE.readyState<4 Цикл
    КонецЦикла;
    
    oScreen = oIE.document.parentWindow.screen;
    Стр = ""+oScreen.width+"x"+oScreen.height;
    
    Предупреждение(Стр, 5);
КонецПроцедуры//Через_IE

//_____________________________________________________________________________
   mszsuz
 
4 - 01.06.04 - 09:11


Список тем форума
Рекламное место пустует   Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует