Вход | Регистрация


1С:Предприятие ::

Метки:дата и время

Как сложить время? Например 12:26 + 05:06 = 17:32

Я
   Lucky
 
26.05.04 - 13:22
Собственно а можно ли?
Когда складываю ТекущееВремя()+число то получаю=ВремяЧисло
Например  12:26  + 05:06 = 12,260506

Подскажите пожайлуста.
 
  Рекламное место пустует
   Arhitektor
 
2 - 26.05.04 - 14:05
Не очень красиво, но надеюсь понятно...

//*******************************************

Функция Выполнить()
    Перем Час, Ми, Сек;
    
    ТекущееВремя(Час,Ми,Сек);//возвращает три переменные типа строка

    Час = число(Час);
    Ми = число(Ми);
    Сек = число(Сек);
    Сек = Сек + 125;
    Ми = Ми+123;
    Час = Час + 122;
               
    Если Сек/60 > 0 Тогда
          Сек = Сек%60;
          Ми = Ми + 1;
    КонецЕсли;
      
    Если Ми/60 > 0 Тогда
          Ми = Ми%60;
          Час = Час + 1;
    КонецЕсли;

    Если Час/24 > 0 Тогда
        Час = Час%24;
    КонецЕсли;
    
    Стр = "";
    
    Если Час < 10 Тогда
        Стр = "0" + Строка(Час);
    Иначе
        Стр = Строка(Час);
    КонецЕсли;
    
    Стр = Стр + ":";
    
    Если Ми < 10 Тогда
        Стр = Стр + "0" + Строка(Ми);
    Иначе
        Стр = Стр + Строка(Ми);
    КонецЕсли;      
    
    Стр = Стр + ":";
               
    Если Сек < 10 Тогда
        Стр = Стр + "0" + Строка(Сек);
    Иначе
        Стр = Стр + Строка(Сек);
    КонецЕсли;
    
    Возврат Стр;
КонецФункции
   Arhitektor
 
3 - 26.05.04 - 14:07
опс-с-с ошибочка
вместо
Сек = Сек%60; 
Ми = Ми + 1;
надо писать
Сек = Сек%60; 
Ми = Ми + цел(Сек/60);

аналогично для Ми и Час

сорри
   Рупор абсурда
 
12 - 26.05.04 - 15:03
12:26 + 05:06 = 17:32 
 
Функция Время(чч,мм,сс,Время=0)
  Если Время=0 Тогда Возврат сс+мм*60+чч*3600 КонецЕсли;
  чч=Цел(Время/3600);
  мм=Цел((Время%3600)/60);
  сс=(Время%3600)%60;
  Возврат Время;
КонецФункции

А=Время(12,26,0);
Б=Время(5,6,0);
чч=0; мм=0;
Время(чч,мм,0,А+Б);
Сообщить(""+чч+":"+мм);
   Рупор абсурда
 
15 - 26.05.04 - 15:17
Эх! Придерусь сам ...
(12) А последнюю строчечку лучше заменить на:
Сообщить(?(чч<10,"0","")+чч+?(мм<10,":0",":")+мм);



Список тем форума
Рекламное место пустует   Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует