Вход | Регистрация

1С:Предприятие ::

Метки:Обмен данными и УРБД

Как создать обработку по выгрузке данных из Exel в 1С 7.7

Я
   stalker_kz
25.05.04 - 06:53
Может кто подскажет или сталкивался с учебниками в инете по создании обрабодки подргузки данных из Exel в 1С. Знаю что это возможно, но нигде не могу найти хоть одно подробное описаниее или руководство как создавать такие обработки. Если кто сталкивался скиньте ссылку. Заранее благодарен.
 
  Рекламное место пустует
   Влад
1 - 25.05.04 - 07:20
Смотрите почту, примерно так.
   romix
 
2 - 25.05.04 - 14:47
//*******************************************

Процедура Сформировать()
    xl=СоздатьОбъект("Excel.Application");
    row=1;//номер строки

    col=1;//номер колонки

    для row=1 по 1000 цикл
      Значение=""+xl.Cells(row,col).Value;
      Сообщить("Значение="+Значение);
      Если Значение="" Тогда
          Прервать;
      КонецЕсли;
    конеццикла;
КонецПроцедуры

Обратная выгрузка в Excel возможна похожим способом
xl.Cells(row,col).Value="Привет!"


Управление цветом, рамками и прочее - рекомендую сохранять Таблицу (функция Сохранить(ИмяТаблицы,"XLS"), или ищи в Яндексе по ключевым словам (Cells, Value, КонецПроцедуры....), или попробуй поюзать Запись Макроса в Excel. Он дает код на языке Бейсик, который примерно соответствует коду 1С (за некоторыми отличиями).
   lexa
 
3 - 25.05.04 - 15:01
лучше Значение=""+xl.Cells(row,col).Text;
если в ячейке ошибка (например деление на 0) - висяк обеспечен
   stalker_kz
5 - 26.05.04 - 06:18
Спасибо... вашим примерам, по ключевым словам из примеров удалось найти учебники в сети по данному вопросу.


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует