Вход | Регистрация

1С:Предприятие ::

Метки:

Про секции в печатной форме

Я
   Таня
 
19.05.04 - 14:46
у меня есть одна большая вертикальная секция и несколько горизонтальных. Они выводятся ВывестиСекцию("Гор|Верт")
Еще есть две дополнительных вертикальных секций и одна дополнительная горизонтальная секция
дополнительная горизонтальная секция выводится ПрисоединитьСекцию("Н")
Почему, если я пишу ПрисоединитьСекцию("Н|Верт"), то показывает и те две дополнительные вертикальные?
Мне пока дополнительные вертикальные секции не надо выводить.
 
 
   Таня
 
1 - 19.05.04 - 14:52
неправильно сказала, оно не только показывает дополнительные но и вообще присоединяет не снизу, а слева от нужной строки. вобщем в бок все сдвигается
   GrayT
 
2 - 19.05.04 - 14:56
Что к чему присоеденяешь? Покажи модуль.
   Таня
 
3 - 19.05.04 - 15:03
поменяла Присоединить на Вывести и все нормально заработало, но почему при Присоединить получается такая ерунда интересно...

Таб.ВывестиСекцию("Шапка|Основная");

Н = 9;
ВыбСтрока = "";    
    
Для А = 1 По СЗ.РазмерСписка() Цикл
    Счет =СЗ.ПолучитьЗначение(А,ВыбСтрока);
    БИ_1.ВыполнитьЗапрос(,Дата1,Счет,,,,3);
    БИ_2.ВыполнитьЗапрос(,Дата2,Счет,,,,3); 
    Если Счет.Валютный = 0 Тогда
    Остаток_1 = Число(Формат(БИ_1.СКД(1),"Ч015.2"));
    Остаток_2 = Число(Формат(БИ_2.СКД(1),"Ч015.2"));
    ВалОстаток_1 = Число(Формат(Остаток_1*Курс_1/Кратность_1, "Ч015.2"));
    ВалОстаток_2 = Число(Формат(Остаток_2*Курс_2/Кратность_2,"Ч015.2")); 

    Иначе
    Остаток_1 = Число(Формат(БИ_1.СКД(),"Ч015.2"));   
    Остаток_2 =  Число(Формат(БИ_2.СКД(),"Ч015.2")); 
ВалОстаток_1 =  Число(Формат(Число(Остаток_1)/Курс_1*Кратность_1,"Ч015.2"));  
ВалОстаток_2 = Число(Формат(Число(Остаток_2)/Курс_2*Кратность_2,"Ч015.2"));  
    КонецЕсли; 
    Таб.ВывестиСекцию(Строка(А)+"|Основная");
    Если ПоСубконто = 1 Тогда 
        Для Б = 1 По Счет.КоличествоСубконто() Цикл
            ИТ.ИспользоватьСубконто(Счет.ВидСубконто(Б));
            ИТ.ВыполнитьЗапрос(,Дата1,Счет);
            ИТ.ВыбратьСубконто();
            Пока ИТ.ПолучитьСубконто()=1 Цикл
            Субконто = ИТ.ПредставлениеСубконто();
        Если Счет.Валютный = 0 Тогда
        ОстатокСубконто_1 = Число(Формат(ИТ.СКД(1),"Ч015.2"));
        ОстатокСубконто_2 = Число(Формат(ИТ.СКД(1),"Ч015.2"));
ВалОстатокСубконто_1 = Число(Формат(ОстатокСубконто_1*Курс_1/Кратность_1, "Ч015.2"));
ВалОстатокСубконто_2 = Число(Формат(ОстатокСубконто_2*Курс_2/Кратность_2,"Ч015.2")); 
        Иначе
    ОстатокСубконто_1 = Число(Формат(ИТ.СКД(),"Ч015.2"));                      ОстатокСубконто_2 =  Число(Формат(ИТ.СКД(),"Ч015.2")); 
ВалОстатокСубконто_1 =  Число(Формат(Число(ОстатокСубконто_1)/Курс_1*Кратность_1,"Ч015.2"));      
ВалОстатокСубконто_2 = Число(Формат(Число(ОстатокСубконто_2)/Курс_2*Кратность_2,"Ч015.2")); 
    КонецЕсли; 
    Таб.ВывестиСекцию("Н|Основная")// Было Таб.ПрисоединитьСекцию()

        КонецЦикла;
    КонецЦикла; 
    КонецЕсли;
   GrayT
 
4 - 19.05.04 - 15:15
Потому что ПРИСОЕДЕНЯЕТСЯ к тому что уже выведено
   Таня
 
5 - 19.05.04 - 15:19
Так ведь выведено : Таб.ВывестиСекцию(Строка(А)+"|Основная"); - к нему должно присоединяться. Как правильно сделать?
   GrayT
 
6 - 19.05.04 - 15:35
Н - горизонтальная секция? и ты ее присоеденяешь?
   Таня
 
7 - 19.05.04 - 15:37
А можно присоединять вертикальную секцию когда уже все основные секции выведены?, они будут раздвигаться?
   Таня
 
8 - 19.05.04 - 15:39
Да Н - горизонтальная
   GrayT
 
9 - 19.05.04 - 15:53
(7)Вроде нет. Хотя ни когда не пробовал такое.
Сделай просто маленький отчет (простой)с секциями и поиграйся. Там ведь еще символы есть "", ">" и др.
   427
 
10 - 19.05.04 - 16:20
Присоединение сверху вниз и слева направо ....
 
  Рекламное место пустует
   427
 
11 - 19.05.04 - 16:21
Присоединение сверху вниз и слева направо ....
   Таня
 
12 - 19.05.04 - 17:25
Мне надо по количеству валют добавить секцию, у меня не получается, потому что в этой секции часть является шапкой таблицы, которая попадает в секцию горизонтальную секцию Шапка, поэтому если валют больше одной, то шапка этого столбца остается одна, а ячейки сдвигаются в числе валют вправо
   Таня
 
13 - 19.05.04 - 17:26
а при выводе Шапки я не знаю сколько будет валют, так как выборки счетов еще не было.
   Таня
 
14 - 19.05.04 - 17:26
а при выводе Шапки я не знаю сколько будет валют, так как выборки счетов еще не было.
   GrayT
 
15 - 19.05.04 - 23:01
(12)Не совсем понял - сумбурно как то. Но похоже нужно это:
Заранее определяешь сколько будет валют, затем формируешь шапку - сперва общую часть выводишь и к ней присоеденяешь верт секц шапки для валют.
Ну а уже потом формируешь строки - выводишь общую часть. а потом присоеденияешь по валютам.


Список тем форума
 
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует