Вход | Регистрация

1С:Предприятие ::

Метки:бухгалтерский учет

Проблема с корреспондирующими счетами

Я
   Willhelm
 
18.05.04 - 17:07
Народ помогите разобраться со следующей ситуацией. Нужно получить выборку по контрагентам и договорам по счету 76.4 с остатками на начало и конец периода, а также обороты корреспондирующих счетов по каждой из позиций

//****************

Процедура Сформировать()   
    ТД=СоздатьОбъект("Таблица");                  
    ТД.ИсходнаяТаблица("Дебеторы");
    ТК=СоздатьОбъект("Таблица");   
    ТК.ИсходнаяТаблица("Кредиторы");
    
    Ит=СоздатьОбъект("БухгалтерскиеИтоги");
    Итг=СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты);
    Ит.ИспользоватьСубконто(ВидыСубконто.Договора);
    Ит.ВключатьСубсчета(1,1);     
    Ит.ВыполнитьЗапрос(Дата1,Дата2,"76.4","51.1;52.1;52.2;62.1;66.1;69.1;70;79.1;79.2;79.10;90.1;91.1");      
    
    ТД.ВывестиСекцию("Шапка");
    Ит.ВыбратьСубконто(1);
    Пока Ит.ПолучитьСубконто(1)=1 Цикл
        Контрагент=Ит.Субконто(1);
        ТД.ВывестиСекцию("Контрагент");
        Ит.ВыбратьСубконто(2);
        Пока Ит.ПолучитьСубконто(2)=1 Цикл
          Договор=Ит.Субконто(2);
          ДатаДоговора=Ит.Операция.ДатаОперации;
          СНД=Ит.СНД();
          СНК=Ит.СНК();
          СКД=Ит.СКД();
          СКК=Ит.СКК(); 
          КО76_4=Ит.КО();
          Ит.ВыбратьСчета(0,1);
          Пока Ит.ПолучитьСчет()=1 Цикл
                Ит.ВыбратьКорСчета(1,2);
              Пока Ит.ПолучитьКорСчет()=1 Цикл
                   Если Ит.КорСчет=СчетПоКоду("51.1") Тогда
                     КО51_1=Ит.КорКО();
                 ИначеЕсли Ит.КорСчет=СчетПоКоду("52.1") Тогда    
                     КО52_1=Ит.КорКО();
                 ИначеЕсли Ит.КорСчет=СчетПоКоду("52.2") Тогда    
                     КО52_2=Ит.КорКО();
                 ИначеЕсли Ит.КорСчет=СчетПоКоду("62.1") Тогда    
                     КО62_1=Ит.КорКО();
                 ИначеЕсли Ит.КорСчет=СчетПоКоду("66.1") Тогда    
                     КО66_1=Ит.КорКО();
                 ИначеЕсли Ит.КорСчет=СчетПоКоду("69.1") Тогда    
                     КО69=Ит.КорКО();
                 ИначеЕсли Ит.КорСчет=СчетПоКоду("70") Тогда    
                     КО70=Ит.КорКО();
                 ИначеЕсли Ит.КорСчет=СчетПоКоду("79.1") Тогда    
                     КО79_1=Ит.КорКО();
                 ИначеЕсли Ит.КорСчет=СчетПоКоду("79.2") Тогда    
                     КО79_2=Ит.КорКО();
                 ИначеЕсли Ит.КорСчет=СчетПоКоду("79.10") Тогда    
                     КО79_10=Ит.КорКО();
                 ИначеЕсли Ит.КорСчет=СчетПоКоду("90.1") Тогда    
                     КО90_1=Ит.КорКО();
                 ИначеЕсли Ит.КорСчет=СчетПоКоду("91.1") Тогда        
                     КО91_1=Ит.КорКО();
                 КонецЕсли;    
              КонецЦикла;    
          КонецЦикла;
          
          
          
          ТД.ВывестиСекцию("Строка");
          
        КонецЦикла;    
    КонецЦикла;                      
    ТД.Показать("Расчеты с дебеторами",,1);
КонецПроцедуры
 
 
   Valery
 
1 - 18.05.04 - 17:11
Я так понял обароты не считает?
   Willhelm
 
2 - 18.05.04 - 17:54
Да.
->Вот в этом месте см. по тексту
 Ит.ВыбратьКорСчета(1,2); 
 Пока Ит.ПолучитьКорСчет()=1 Цикл 
->
получается пустая выборка кор.счетов, а по журналу ордеру - они есть
Мой отчет это по сути журнал-ордер с детализацией по контрагентам и договорам
   Willhelm
 
3 - 18.05.04 - 19:09
Так как есть мнения из-за чего корреспондирующие счета не выгребаются?
   gerasan
 
4 - 18.05.04 - 19:14
Попробуй в параметрах метода ВыполнитьЗапрос (тип итогов по моему) указать необходимость расчета оборотов между счетами, так как по умолчанию рассчитываются остатки и обороты только по счетам, указанным в третьем параметре.
   Lark
6 - 18.05.04 - 19:55
Шестым параметром в бухЗапросе нужно поставить "3"
   Valery
 
10 - 19.05.04 - 15:28
В строке Запроса попробуй поставить Тип итогов 2 или 3
 
  Рекламное место пустует


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует