Вход | Регистрация

1С:Предприятие ::

Метки:

ТиС 931 Резерв.

Я
   lexa
 
18.05.04 - 14:58
Есть завка покупателя, реализация. ПКО
Покупатель вернул товар, а покупателю деньги
Сторнировали заявку, сделали возврат от покупателяи РКО
В результате по товару отрицательный резерв
 
  Рекламное место пустует
   a_aladdin
 
1 - 18.05.04 - 15:27
не надо было заявку сторнировать - реализация уже двинула регистр резервов назад, а сторнированием ты еще раз двинул - удали в общем сторно
   lexa
 
2 - 18.05.04 - 15:34
а долги по отгрузке
   lexa
 
3 - 18.05.04 - 15:38
и по оплате
   a_aladdin
 
4 - 18.05.04 - 16:09
заявка не делает долгов по отгрузке\оплате - это регистры Покупатели\Поставщики
Долги урегулировались возвратом и рко
   lexa
 
5 - 18.05.04 - 16:24
Не хотелось бы иметь неоплаченные заявки.
   lexa
 
6 - 18.05.04 - 17:22
Процедура КнопкаСканер() 
Товар =""; 
ЕдИзм =0; 
Колич=0; 
Цена=0; 
СтоимостьБезНДС=0; 
СтавкаНДС=0; 
СуммаНДС=0; 
СтоимостьВсего=0; 
СтранаПроисхож=""; 
НомерГТД=""; 
ДБФ=СоздатьОбъект("XBase"); 
ИмяФайла=""; 
ИмяПути=""; 
ФС.ВыбратьФайл(0,ИмяФайла,ИмяПути,,"*.dbf|*.dbf"); 
ПутьДБ=ИмяПути+ИмяФайла; 
ДБФ.ОткрытьФайл(ПутьДБ); 
ДБФ.КодоваяСтраница(0); 
Если ДБФ.Открыта()=1 Тогда 
    Предупреждение ("База открыта", 2); 
КонецЕсли;
Если ДБФ.КоличествоЗаписей() = 0 Тогда 
    Возврат();
КонецЕсли;
ДБФ.Первая(); 
Флаг =1;
Пока Флаг = 1 Цикл 
    Товар = СокрЛП(ДБФ.Column1); 
    ЕдИзм = СокрЛП(ДБФ.Column2); 
    Колич = СокрЛП(ДБФ.Column3); 
    Цена = СокрЛП(ДБФ.Column4); 
    СтоимостьБезНДС = СокрЛП(ДБФ.Column5); 
    СтавкаНДС = СокрЛП(ДБФ.Column6); 
    СуммаНДС = СокрЛП(ДБФ.Column7); 
    СтоимостьВсего = СокрЛП(ДБФ.Column8); 
    СтранаПроисхож = СокрЛП(ДБФ.Column9); 
    НомерГТД = СокрЛП(ДБФ.Column10); 
    Если СпрНом.НайтиПоНаименованию(Товар,0) = 0 Тогда 
        СпрНом.Новый(); 
        СпрНом.ПолнНаименование = Товар; 
        СпрНом.Наименование = СпрНом.ПолнНаименование; 
        СпрНом.ЕдиницаИзмерения = ЕдИзм; 
        СпрНом.ТипНоменклатуры = "Товар"; 
        СпрНом.ПлановаяСебестоимость = Цена; 
        СпрНом.Цена = (Цена + (Цена * 20)/100); 
        СпрНом.Валюта = "руб"; 
        СпрНом.СтавкаНДС = СтавкаНДС; 
        СпрНом.СтавкаНП = "0"; 
        СпрНом.СтранаПроисхождения = СтранаПроисхож; 
        СпрНом.Записать(); 
    КонецЕсли;
    НоваяСтрока(); 
    Док.Номенклатура = СпрНом.ТекущийЭлемент(); 
    Количество = Колич; 
    СтавкаНДС = СпрНом.СтавкаНДС; 
    Записать();
    Если ДБФ.Следующая()=0 Тогда 
        Флаг = 0; 
    КонецЕсли; 
КонецЦикла; 
КонецПроцедуры
   lexa
 
7 - 18.05.04 - 17:22
не туда постанул
   ander139
 
8 - 18.05.04 - 17:50
(5) А РКО возвращает заявке статус неоплаченной?


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует