Вход | Регистрация

1С:Предприятие ::

Метки:

Создание локального меню по нажатию на кнопку

Я
   List
 
17.05.04 - 13:37
Как создать локальное меню, как это делает фирма «1С» в своих типовых конфигурациях, например, когда нажимаешь на кнопку «Действия» в конфигурации ЗиК, то появляется меню в котором можно выбирать необходимые действия.
 
 
   Композитор
 
1 - 17.05.04 - 13:59
Простой пример
//*****************************************************************************

Процедура ПоКнопкеЗаполнить()            
Перем Ф;    
Если ТаблНоменклатура.КоличествоСтрок() <> 0 Тогда
 Если Вопрос("Перед заполнением табличная часть будет очищена!", "Да+Нет", 60) <> "Да" Тогда
  Возврат;
 КонецЕсли;
КонецЕсли;
ТаблНоменклатура.УдалитьСтроки();
СпособЗаполнения = СоздатьОбъект("СписокЗначений");
СпособЗаполнения.ДобавитьЗначение("По заявкам");
СпособЗаполнения.ДобавитьЗначение("Из справочника все");
СпособЗаполнения.ДобавитьЗначение("Из справочника ненулевые продажи");
Если СпособЗаполнения.ВыбратьЗначение(Ф, , , 60, 1) = 1 Тогда
 Если     Ф = "По заявкам" Тогда
  ЗаполнениеПоЗаявкам();
 ИначеЕсли Ф = "Из справочника все" Тогда
  ЗаполнениеИзСправочникаВсе();
 ИначеЕсли Ф = "Из справочника ненулевые продажи" Тогда
  ЗаполнениеПоФильтру();
 КонецЕсли;        
КонецЕсли;
КонецПроцедуры//ПоКнопкеЗаполнить()


Список тем форума
 
Основная теорема систематики: Новые системы плодят новые проблемы.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует