Вход | Регистрация

1С:Предприятие ::

Метки:документы

Название документа в торговле

Я
   inter
 
15.05.04 - 14:28
Кто подскажет что нужно сделать в обработке для того чтобы в  созданном документе "реализация" появилось наименование и оно отражалось в журнале.
 
  Рекламное место пустует
   Gavrila
 
1 - 15.05.04 - 15:01
(0) Вопрос можно ?
1. В какой обработке ?
2. Документ "реализация" - э то вид документа так?, а что значит появилось наименование (где появилось?, на форме, в заголовке?)
3. "оно отражалось в журнале" - оно исходя из того что такое "появилось наименование" ?
   inter
 
2 - 15.05.04 - 15:15
Пожалуйста... 1)В личной обработке по автовыделению к концу дня прихода в разрезе налогового учета на основе проводной реализации.
2)  Да.При создании нового документа в форме есть идентификатор НазваниеДокумента, но его нет в основных ревизитах шапки и непонятно как его установить.
3) Документ формируется проводится а в общем журнале все графы заполнены , кроме графы документ.
   Gavrila
 
3 - 15.05.04 - 15:22
(2) НазваниеДокумента - реквизит диалога и устанавливается(заполняется) в модуле формы документа (не помню в какой процедуре: делаешь поиск в модуле формы документа и смотришь как).
Открываешь форму списка журнала(журнал какой и в какой конфигурации?) и смотришь как заполняется эта самая графа. :)
   staer
4 - 15.05.04 - 15:28
Может НазваниеДокумениа  у тебя в Общих Реквизитах Документов.
Тогда в Модуле ФОРМЫ Например: НазваниеДокумента=Строка(Вид());
   GrayT
 
5 - 15.05.04 - 15:29
глНазваниеДокументаВЖурнале(Док) в глобальнике
   inter
 
6 - 15.05.04 - 15:36
В модуле формы он заполняется функцией ЗаголовокФормы, которая вызывается лишь при изменении самого заголовка, вернее в его закладке
Функция ЗаголовокФормы() 
    
    Перем Заголовок, Название;
                
    Заголовок     = глНазваниеДокументаВЖурнале(Контекст);
    Название     = Заголовок+ "";
    
    Если Выбран() = 1 Тогда  
        Если Проведен() = 1 Тогда
            Заголовок = Заголовок + ". Проведен";
        Иначе
            Заголовок = Заголовок + ". Не проведен";
        КонецЕсли;
    Иначе
        Заголовок = Заголовок + ". Новый";
    КонецЕсли;
    Форма.Заголовок(Заголовок);               
    Возврат Название;
    
КонецФункции//ЗаголовокФормы                                                   

                                 
А как его присвоить в обработке чтобы оно сохранилось
    Док=СоздатьОбъект("Документ.Реализация");
        Док.НазваниеДокумента= ?
    Док.Новый(); 
    глЗаполнитьШапку(Док, 0, "Продажа");
    Док.ДатаДок=ДатаКон;
    Док.АвтоВремяНачалоДня();
   GrayT
 
7 - 15.05.04 - 15:42
А он тебе в обработке зачем? Это же реквизит ФОРМЫ.
   Gavrila
 
8 - 15.05.04 - 15:46
(6) если у тебя нет названия документа на форме этого самого документа и в журнале, то скорее ошибка здесь (5)
   inter
 
9 - 15.05.04 - 15:51
Мне необходимо чтобы при открытие обработкой созданного документа в название документа была стандартная надпись Реализация(купля-продажа)№...Сейчас выходит просто №. И в общем журнале в графе документ было тоже а не пустое множество.
   Gavrila
 
10 - 15.05.04 - 15:54
(9) тогда тебе точно сюда: глНазваниеДокументаВЖурнале(Контекст);
смотри по отладчику :))
 
  Рекламное место пустует
   inter
 
11 - 15.05.04 - 15:57
Это не устраняет коллизию

       Док.Новый(); 
    глЗаполнитьШапку(Док, 0, "Продажа");
    глНазваниеДокументаВЖурнале(Док);
    Док.ДатаДок=ДатаКон;
    Док.АвтоВремяНачалоДня();
   Gavrila
 
12 - 15.05.04 - 15:59
(11) говорю русским языком, что при создании и последующем открытии его из обработки тебе не нужно указывать название дока !!!
Название документа появится в открытом документе и в журнале если ты исправишь гл. процедурку "глНазваниеДокументаВЖурнале(Контекст);" :))
   inter
 
13 - 15.05.04 - 16:06
В том и вопрос что в ней исправить ?
   Gavrila
 
14 - 15.05.04 - 16:11
(13)
- Вы здесь разговариваете, а там все стоит...
- Что стоит?
- Все стоит ! (с) DownHouse
см. по отладчику :))
   inter
 
15 - 15.05.04 - 16:16
Весело тут с Вами ...
   GrayT
 
16 - 15.05.04 - 16:17
Эх, было время когда не было отладчика.
Сдается мне, что есть у него в документе КодОперации. Который не заполнен...
   GrayT
 
17 - 15.05.04 - 16:17
(15)А то.
   inter
 
18 - 15.05.04 - 16:42
Всем огромное ПЛ..З . До меня кажется дошло. Надо было сделать так
   Док.КодОперации=Перечисление.КодыОпераций.Продажа;
   Док.ПредставлениеВида();
В самой обработке
или так
    Док.КодОперации=Перечисление.КодыОпераций.Продажа;
    глНазваниеДокументаВЖурнале(Док);
     
или    так         глНазваниеДокументаВЖурнале(Док); при этом изменяя гл.мод.
   GrayT
 
19 - 15.05.04 - 16:54
:)
   Шольц
20 - 24.05.04 - 03:10



Список тем форума
Рекламное место пустует   Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует