Вход | Регистрация

Информационные технологии ::

Метки:

Недокументированные функции языка 1С

Я
   skunk
 
14.12.03 - 03:22
Всем привет!

Народ, на днях скачал одну обработку и увидал там интересную функцию_getPerformanceCounter, причем конфигуратор 1С показывал ее как зарезервированное слово языка. В описании языка данной функции не нашел. Потрошение внутренностей 1С показало, что в seven.dll находятся недокументированные функции. Правда, я нашел только три, пока. Будет время, и желание поищем еще что-то.

А пока используйте.

_getPerformanceCounter – какой-то счетчик. До конца не разобрался, что он считает, но как-то привязан ко времени. Собственно я не разбирался, просто привожу кусок программы, где ее увидал:

Процедура Пауза(Параметр)
   Начало =_getPerformanceCounter();
   Пока(Начало + Параметр > _getPerformanceCounter()) Цикл
   КонецЦикла;  
КонецПроцедуры

Две другие переводят полученное значение из 36-чной системы счисления, для тех кто не знает внутренне представление поля ID в базе данных, к 10-чной и обратно.
_IdToStr() - получает 10-ное число, возвращает его 36-ное представление.
_StrToId() – наоборот, получает 36-ное, возвращает 10-ное.

Может, кому пригодиться.
Спасибо за внимание, а я пошел спать!
 
  Рекламное место пустует
   Львенок
 
1 - 14.12.03 - 09:07
_getPerformanceCounter не какой-то счетчик, а счетчик секунд с момента запуска системы. Им очень удобно вычислять время исполнения узких мест. Вроде:
а=_getPerformanceCounter();
Для ... по ... Цикл
КонецЦикла;
б=_getPerformanceCounter();
Сообщить ("Время выполнения : "+(б-а));

Есть же FAQ по недокументированным возможностям, вроде этой и моей любимой ОбработкаОжидания() не в глобальном модуле, а в любой форме.
___
Искренне Ваш, Львенок.
   Волшебник
 
2 - 14.12.03 - 11:39
Вот еще:
Недокументированные возможности функции Шаблон
http://www.sinor.ru/~my1c/knowhow/shablon.html
   Волшебник
 
3 - 15.12.03 - 20:20
   skunk
 
4 - 05.01.04 - 02:47
Народ вчера купил копашку, а ля все для бухгалтера. Там обнаружил файлик meta.als - вот коммент к нему
"Метаданные - ред 2.1(июль 2002) Моисеенко"
короче до фига не документированных фич от 1С.
   BorisG
5 - 05.01.04 - 08:48
(4) Кстати, Петр Моисеенко pit и есть... Львенку для сведения...
   Львенок
 
6 - 05.01.04 - 09:46
(5) К сведению принял. Хе-хе. У вас, кстати, тоже не полные сведения о присутствующих... ;)
___
Искренне Ваш, Львенок.
   345
7 - 05.01.04 - 10:06
Вполне достаточные ... Оговорки читать уметь надо ...

июль 2002 - старый ... На Хиппо есть вроде новее ... Малый набор разработчика ... Весьма рекомендую обработочку из этого набора от Бертыша - структуру конфы вываливает в виде АЛС .... Очень удобно... Постоянно использую ...
   skunk
 
8 - 05.01.04 - 16:40
pit а у тебя compound.dll под 2003 нормально работает или я где-то туплю.
   345
9 - 05.01.04 - 16:45
А фиг ее знает ... я ее под 2003 не пробовал ...

А какая нафих разница ... НТ подобная линейка ....

Длл зарегистрил?
   skunk
 
10 - 05.01.04 - 16:50
(9)я же не дурак, конечно, вот в том вся и х..... она регистрируется есть в реестре вроде все гуд но одинСи ее не достает. Правда я из других вещей не смотрел не когда было. Мож она что-то портачит. Или я все таки гоню
 
 


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует