Вход | Регистрация

1С:Предприятие ::

Метки:Обмен данными и УРБД

Импорт справочников из Excel

Я
   jetcom
 
11.05.04 - 23:03
Как импортировать из Excel вмесе с Наименованием элемента Номенклатуры соответствующий ему Штрих-код? Есть какие-нибудь наработки?
 
  Рекламное место пустует
   Влад
1 - 12.05.04 - 04:44
Процедура Сформировать()
    СпрНоменклатура=СоздатьОбъект("Справочник.Номенклатура");
    ExcelApp=СоздатьОбъект("Excel.Application");
    Книга=ExcelApp.Workbooks.Open(СокрЛП(XLSфайл));
    Лист=Книга.Sheets(1);
    Для ш=1 по ПоследняяСтрока Цикл//последняя строка задается в диалоге

        Попытка
            КонтрольноеЗначение=СокрЛП(Лист.Cells(ш,3).Value);
            Если ПустоеЗначение(КонтрольноеЗначение)=0 Тогда
                СпрНоменклатура.Новый();
                СпрНоменклатура.Название=Лист.Cells(ш,2).Value;
                СпрНоменклатура.ЦенаПродажи=КонтрольноеЗначение;
                СпрНоменклатура.ЦенаПокупки=Лист.Cells(ш,4).Value;
                СпрНоменклатура.Записать();
            КонецЕсли;
            Состояние(""+ш+" записано");
        Исключение
            Сообщить("Ошибка в строке "+ш);
        КонецПопытки;
    КонецЦикла;
    ExcelApp.Workbooks.Close();
    ExcelApp.Quit();
КонецПроцедуры

//примерно так, я думаю
   Frol
3 - 12.05.04 - 12:03
А Штрих-код как..., тоже через value, чтоли?
   jetcom
 
4 - 12.05.04 - 13:20
И непонятненько, кстати, как будет осуществляться проверка его (штрих-кода) на уникальность???
   jetcom
 
5 - 12.05.04 - 20:38
Подсказали люди добрые воспользоваться стандартной transref.ert
Мож кто намылит? Оч буду благодарен!!!
   Frol
6 - 13.05.04 - 14:20
Она на всех ИТС-ах имеется, если сильно нада...
Ну , если не на всех, тон на последних 3-х точно.
   jetcom
 
9 - 15.05.04 - 14:44
(8)Спасибо! RefImport.ert - Это то, что нужно! Только импортирует все, кроме штрих-кода... Или я неправильно выставляю настройки... Может кто работал с ней?
Подскажите, плиииз!!!


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует