Вход | Регистрация

1С:Предприятие ::

Метки:регистры

Использование регистров в запросе

Я
   -morgan-
07.05.04 - 16:26
оброго времени суток всем.
Вобщем проблема в следующем, пишу такой код:


ДатаК=РабочаяДата();
Запрос=СоздатьОбъект("Запрос");
ТекстЗапроса=
"//{{ЗАПРОС(ОстаткиТоваров)

|Период с '01.01.1990' по ДатаК;
|Продукт=Регистр.ПродОст.Продукция;
|Цена=Регистр.ПродОст.Цена;
|Колво=Регистр.ПродОст.Количество;
|Вес=Регистр.ПродОст.Вес;
|Группировка Продукт;
|Группировка Цена;
|//}}ЗАПРОС

;
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
КонецЕсли;
Сообщить("1");
Пока Запрос.Группировка("Продукт") = 1 Цикл
    Сообщить("2");
    Пока Запрос.Группировка("Продукт") = 1 Цикл
        Сообщить("3");
    КонецЦикла;
КонецЦикла;
Сообщить("4");

на выходе хочу получиь 1,2,3,4, а получаю только 1,4, то есть в цикли я не вхожу совсем.
В том что регистр не пуст я уверен.
Подскажите plz. в чем проблема?
 
 
   SiMazx
 
3 - 07.05.04 - 18:11
В запросе по регистру должны быть функции. В результирующию выборку включаются только позиции с ненулевыми значениями функций.
   Макс
5 - 07.05.04 - 18:27
Допустим регистр остатков. Ресурсы Количество, Вес. Тогда

ДатаК=РабочаяДата();
Запрос=СоздатьОбъект("Запрос"); 
ТекстЗапроса= 
"//{{ЗАПРОС(ОстаткиТоваров) 

|Период с '01.01.1990' по ДатаК; 
|Продукт=Регистр.ПродОст.Продукция; 
|Цена=Регистр.ПродОст.Цена; 
|Колво=Регистр.ПродОст.Количество; 
|Вес=Регистр.ПродОст.Вес; 
|Функция КолвоНачОст=НачОст(КолВо); 
|Функция КолвоПриход=Приход(КолВо); 
|Функция КолвоРасход=Расход(КолВо); 
|Функция КолвоКонОст=КонОст(КолВо); 
|Функция ВесНачОст=НачОст(Вес); 
|Функция ВесПриход=Приход(Вес); 
|Функция ВесРасход=Расход(Вес); 
|Функция ВесКонОст=КонОст(Вес); 
|Группировка Продукт; 
|Группировка Цена; 
|//}}ЗАПРОС 

; 
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда 
   Возврат; 
КонецЕсли; 
Сообщить("1"); 
Пока Запрос.Группировка("Продукт") = 1 Цикл 
   Сообщить("2"); 
   Пока Запрос.Группировка("Продукт") = 1 Цикл 
       Сообщить("3"); 
   КонецЦикла; 
КонецЦикла; 
Сообщить("4");


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует