Вход | Регистрация

1С:Предприятие ::

Метки:документы

Как запретить удаление документа (или пометку на удаление) ?

Я
   UltraViolet
 
07.05.04 - 13:35
Можно ли как-то запретить ставить пометку на удаление документов?
 
 
   427
 
1 - 07.05.04 - 13:37
Права

или

предопределенная процедура в глобальнике
   Valery
 
2 - 07.05.04 - 13:38
Самое простое назначить пользователям права соответствующие
   UltraViolet
 
3 - 07.05.04 - 13:38
предопределенная не катит... уже пробовала... а права очень хлопотно...
   UltraViolet
 
4 - 07.05.04 - 13:40
дело в том, что начальство желает устанавливать дату, чтобы документы до этой даты нельзя было удалять
   wolfy
 
5 - 07.05.04 - 13:42
имхо для случая описанного в (4) только предопределенная проц в глобальнике и подойдет
   UltraViolet
 
6 - 07.05.04 - 13:44
во время выполнения процедуры ПриУдаленииДокумента пометка еще не установлена, так что и снять ее не получается
   Valery
 
7 - 07.05.04 - 13:46
Незнаю какая конфигурация, но в последних есть константа Дата запрета редактирования. Может подойдет.
   wolfy
 
10 - 07.05.04 - 13:58
вот пример простейший попробуй


Процедура ПриУдаленииДокумента(УдалДокумент)
   //Если метим на удаление сменный отчнет то надо пометить и служебные документы

    
    Если УдалДокумент.ДатаДок<'01.01.2004' Тогда 
        СтатусВозврата(0);
    КонецЕсли;
    
КонецПроцедуры
 
  Рекламное место пустует
   wolfy
 
11 - 07.05.04 - 14:00
в (10)
то что в комментарии написано ни как к теме ветки не относиться, не обращайте на это внимания
   427
 
13 - 07.05.04 - 14:08
(6) Ой люли.....


(с) Дока по 1С

ПриУдаленииДокумента
Предопределенная процедура при удалении документа и при отмене пометки на удаление.
Синтаксис:
ПриУдаленииДокумента(<УдалДокум>, <Режим>)
Параметры:
<УдалДокум>    Значение удаляемого документа.
<Режим>    Значение флага непосредственного удаления: 1 — непосредственное удаление; 0 — пометка на удаление.
Описание:
Вызов предопределенной процедуры ПриУдаленииДокумента производится системой 1С:Предприятие неявно при интерактивном удалении документа и в случае отмены пометки на удаление. В этом случае, условия вызова мож-но узнать методом ПометкаУдаления документа. Если в данной предопределенной процедуре установить статус возврата — 0 (например, если не истек срок хранения документа), то удаление документа не будет выполнено.
Данная предопределенная процедура может располагаться только в глобальном программном модуле.
Пример:
Процедура ПриУдаленииДокумента(Док, Реж)
   Если НазваниеНабораПрав() = "Продавец" Тогда
      Если (Док.Вид() = "РасходнаяНакл") И (Реж = 1) Тогда
         Предупреждение("У вас нет права удалять накладную!", 2);
         СтатусВозврата(0);
      КонецЕсли;
   КонецЕсли;
КонецПроцедуры
См. также: СтатусВозврата


Список тем форума
Рекламное место пустует   Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует