Вход | Регистрация

1С:Предприятие ::

Метки:

Подскажите.....

Я
   Leha.
06.05.04 - 07:51
Если  я пишу 
Процедура ДобДок() 
    Парам=СоздатьОбъект("СписокЗначений");
        Парам.ДобавитьЗначение("Контрагент","ВидОтбора");
        Парам.ДобавитьЗначение(ВыбКонтрагент,"Параметр");  
    ОткрытьПодбор("Журнал.ЖурналОбщий","ФормасОтбором",Парам); КонецПроцедуры 

То выводит список всех документов данного контрагента
Далее
Процедура ДобДок() 
    Парам=СоздатьОбъект("СписокЗначений");
        Парам.ДобавитьЗначение("СчетФактура","ВидОтбора");
        Парам.ДобавитьЗначение(ВыбКонтрагент,"Параметр");  
    ОткрытьПодбор("Журнал.ЖурналОбщий","ФормасОтбором",Парам); КонецПроцедуры 
Выводит все счет фактуры ВЫБРАННОГО контрагента!
а если 
Процедура ДобДок() 
    Парам=СоздатьОбъект("СписокЗначений");
        Парам.ДобавитьЗначение("Реализация","ВидОтбора");
        Парам.ДобавитьЗначение(ВыбКонтрагент,"Параметр");  
    ОткрытьПодбор("Журнал.ЖурналОбщий","ФормасОтбором",Парам); КонецПроцедуры 

То почему то выводит ВСЕ РЕАЛИЗАЦИИ ВОООБЩЕ ВСЕХ КОНТРАГЕНТОВ! А не нужного
в чем ошибка с реализациями подскажите?
Надо чтобы выводились реализации выбранного контрагента!
Спасибо
 
 
   Leha1
1 - 06.05.04 - 08:57
Ну очень надо
   GrayT
 
2 - 06.05.04 - 08:58
А что это за конфигурация? Что то с настройками граф отбора
   Leha1
3 - 06.05.04 - 09:05
Конфигурация Торговля и Склад
   GrayT
 
4 - 06.05.04 - 09:38
Правленная? Не помню я там ВИдОтбора "СчетФактура" - попробовал смоделировать ситуацию не получилось :(
   Leha4
5 - 06.05.04 - 10:14
Граф отбор поставил тоже на реализацию так же как и на счет фактуру но что то не выходит
   GrayT
 
6 - 06.05.04 - 10:36
Ты граф отбора наплодил? С ними злоупотреблять не надо - на производительности плохо сказывается. А так смотри что с Выбранными значениями.
А вообще.То что ты пытаешься сделать  - отобрать одновременно по виду документа и по контрагенту. Отбор только по чему-нить одному. Если надо по двум - поищи на форуме, тут это уже не раз обсуждалось - либо дополнительный (составной) реквизит, либо своя обработка с ТЗ


Список тем форума
Рекламное место пустует  
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует