Вход | Регистрация

1С:Предприятие ::

Метки:бухгалтерский учет

Подскажите начинающему, как определить оборот по счету по определенным субк

Я
   leonid11111
30.04.04 - 10:51
Пробовал определять как разницу между функциями СККРС и СНКРС, но че то не получается одновременно по двум субконто. Может есть другой вариант.
 
 
   Сергей
1 - 30.04.04 - 11:13
ИспользоватьСубконто()
   leonid11111
2 - 30.04.04 - 11:32
Не совсем понял. Может примерчик подкинешь
   SiMazx
 
3 - 30.04.04 - 11:47
Перед тем как выполнить запрос по БИ, делаешь нужное количество раз ИспользоватьСубконто с указанием конкретных значений субконто...
Потом после запроса - ВыбратьСубконто, пока получитьСубконто...
   AVP
4 - 30.04.04 - 11:48
Ит.ИспользоватьСубконто("Материалы");    
    Ит.ВключатьСубсчета(-1,-1);
    Если Ит.ВыполнитьЗапрос(НачДата, КонДата, "10") = 0 Тогда
        Возврат;
    КонецЕсли;   
    Ит.ВыбратьСубконто(1);
    Пока Ит.ПолучитьСубконто(1) = 1 Цикл
// Ит.ДО() - это дебетовый оборот

// Ит.КО() - это кредитовый оборот

      КонецЦикла;
   dusic
 
5 - 07.06.04 - 08:54
4 - А почему не работает в такой ситуации?

    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто("Материалы");
    Ит.ИспользоватьСубконто("МестаХранения");
    Если Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, "10")= 0  Тогда  
        Возврат;  
    КонецЕсли;    
    Ит.ВыбратьСубконто(1);  
    Пока Ит.ПолучитьСубконто(1) = 1 Цикл  
        Сообщить(""+Ит.ПредставлениеСубконто(1)+": " + Ит.ДО() + "(" + Ит.ДО(3) + ")    " + Ит.КО() + "(" + Ит.КО(3) + ")");
        Ит.ВыбратьСубконто(2);  
        Пока Ит.ПолучитьСубконто(2) = 1 Цикл  
            Сообщить("    "+Ит.ПредставлениеСубконто(2)+": " + Ит.ДО() + "(" + Ит.ДО(3) + ")    " + Ит.КО() + "(" + Ит.КО(3) + ")");
        Конеццикла;
    Конеццикла;


результат

А/шины: 15415.86(6)    5138.62(2)
    Основной склад: 0(6)    0(2)
и т.д.

Нет суммы по второму субконто. В чем ошибка?
   Killgur
 
6 - 07.06.04 - 09:00
(5) План счетов стандартной бухии не предусматривает на 10х счетах ведение суммового учета по местам хранения. Только количество.
   dusic
 
7 - 07.06.04 - 09:27
пасиба.
   SiMazx
 
8 - 07.06.04 - 09:27
(+6) Однако это не значит, что это непоправимо... ;)


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует